CPU usage goes high when indexing one document in Solr 8.0.0

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

CPU usage goes high when indexing one document in Solr 8.0.0

vishal patel-2
I am upgrading solr 6.1.0 to 8.0.0. When I indexed only one document in solr 8.0.0, My CPU usage got high for some times even though indexing done.
I noticed that my autocommit maxTime was 600000 in solrconfig.xml of Solr 6.1.0. And same value I used in solrconfig.xml of solr 8.0.0.
After I replaced ${solr.autoCommit.maxTime:15000} which took from default collection, It is working fine and CPU usage does not high for more time.

I have attached my solrconfig.xml of 6.1.0 and 8.0.0. Some changes i have updated in solrconfig.xml so Please tell me is there any kind of changes needed in this?

Sent from Outlook

solrconfig_6.1.0.xml (61K) Download Attachment
solrconfig_8.0.0.xml (56K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: CPU usage goes high when indexing one document in Solr 8.0.0

Erick Erickson
Possibly SOLR-13349?

> On Apr 9, 2019, at 11:41 PM, vishal patel <[hidden email]> wrote:
>
> I am upgrading solr 6.1.0 to 8.0.0. When I indexed only one document in solr 8.0.0, My CPU usage got high for some times even though indexing done.
> I noticed that my autocommit maxTime was 600000 in solrconfig.xml of Solr 6.1.0. And same value I used in solrconfig.xml of solr 8.0.0.
> After I replaced ${solr.autoCommit.maxTime:15000} which took from default collection, It is working fine and CPU usage does not high for more time.
>
> I have attached my solrconfig.xml of 6.1.0 and 8.0.0. Some changes i have updated in solrconfig.xml so Please tell me is there any kind of changes needed in this?
>
> Sent from Outlook
> <solrconfig_6.1.0.xml><solrconfig_8.0.0.xml>

Reply | Threaded
Open this post in threaded view
|

Re: CPU usage goes high when indexing one document in Solr 8.0.0

vishal patel-2
Thanks for your reply..

Yes same problem like SOLR-13349.

We will wait for Solr 8.1.

Sent from Outlook<http://aka.ms/weboutlook>
________________________________
From: Erick Erickson <[hidden email]>
Sent: Wednesday, April 10, 2019 8:41 PM
To: [hidden email]
Subject: Re: CPU usage goes high when indexing one document in Solr 8.0.0

Possibly SOLR-13349?

> On Apr 9, 2019, at 11:41 PM, vishal patel <[hidden email]> wrote:
>
> I am upgrading solr 6.1.0 to 8.0.0. When I indexed only one document in solr 8.0.0, My CPU usage got high for some times even though indexing done.
> I noticed that my autocommit maxTime was 600000 in solrconfig.xml of Solr 6.1.0. And same value I used in solrconfig.xml of solr 8.0.0.
> After I replaced ${solr.autoCommit.maxTime:15000} which took from default collection, It is working fine and CPU usage does not high for more time.
>
> I have attached my solrconfig.xml of 6.1.0 and 8.0.0. Some changes i have updated in solrconfig.xml so Please tell me is there any kind of changes needed in this?
>
> Sent from Outlook
> <solrconfig_6.1.0.xml><solrconfig_8.0.0.xml>