Error while creating a new solr core

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Error while creating a new solr core

Shalvak Mittal (UST, )
Hi,


I have recently installed solr 7.2.1 in my ubuntu 16.04 system. While creating a new core, the solr logging shows an error saying


" Caused by: org.apache.solr.common.SolrException: fips module was not loaded."


I have downloaded the necessary jar files like cryptoj.jar and copied them in /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/ext/ but the error still persists.

I have also updated the java.security file with
security.provider.x=com.rsa.jsafe.provider.JsafeJCE



Can you please suggest a solution to the FIPS module problem. Are there any files I am missing while creating the solr core?


Thank You,

Shalvak Mittal


Reply | Threaded
Open this post in threaded view
|

Re: Error while creating a new solr core

Shawn Heisey-2
On 9/10/2018 11:51 PM, Shalvak Mittal (UST, ) wrote:
> I have recently installed solr 7.2.1 in my ubuntu 16.04 system. While creating a new core, the solr logging shows an error saying
>
> " Caused by: org.apache.solr.common.SolrException: fips module was not loaded."

I have never heard of a module for Solr called "fips".  It certainly
isn't one that comes with the Solr package. If you have are dealing with
a module named fips, you would need to talk to whoever created it for help.

If you are customizing Jetty, you won't find any help here for that. 
Beyond a very few simple changes, we don't know all that much about
Jetty.  It is used to provide network services for Solr, but this is
done with a config that isn't changed much from Jetty defaults.

> I have downloaded the necessary jar files like cryptoj.jar and copied them in /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/ext/ but the error still persists.

This is a directory location that is meaningless for Solr. You would
need to talk to someone at OpenJDK about this directory, since it's theirs.

Thanks,
Shawn

Reply | Threaded
Open this post in threaded view
|

Re: Error while creating a new solr core

Christopher Schultz
In reply to this post by Shalvak Mittal (UST, )
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Shalvak,

On 9/11/18 01:51, Shalvak Mittal (UST, ) wrote:

> I have recently installed solr 7.2.1 in my ubuntu 16.04 system.
> While creating a new core, the solr logging shows an error saying
>
>
> " Caused by: org.apache.solr.common.SolrException: fips module was
> not loaded."
>
>
> I have downloaded the necessary jar files like cryptoj.jar and
> copied them in /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/ext/ but
> the error still persists.
>
> I have also updated the java.security file with
> security.provider.x=com.rsa.jsafe.provider.JsafeJCE

Does JsafeJCE provide a FIPS-compliant JSSE back-end? If so, it looks
like it's not configured properly.

Does Solr work as expected when you are using the built-in JSSE (Sun)
provider?

> Can you please suggest a solution to the FIPS module problem. Are
> there any files I am missing while creating the solr core?
You'll have to talk to your security module vendor about fixing this
issue... it's got nothing to do with Solr.

- -chris
-----BEGIN PGP SIGNATURE-----
Comment: Using GnuPG with Thunderbird - https://www.enigmail.net/

iQIzBAEBCAAdFiEEMmKgYcQvxMe7tcJcHPApP6U8pFgFAluX9qgACgkQHPApP6U8
pFjM4BAAv1/bXM8VwKo+ObWaRR07Y2YC/K0v6BG1yQnxv5M3OWA9zQnrm0ktAFW6
yYzF/OP8HpDKjXoS/ZahHaDS54hjLwcnBbNzDK6vbSfk556gI55v6RIEpZ/R4aYE
cae7dQIYqiGQ18igIEoGxj8ZXcNHfLmfMhVoLBCd7JJnUucToTUVhpNY4UqzBlBq
sxUzziTuMsm0RWYB4HedK8k0Tg0Sltw1XgYzeFb325Dmhw9HOLQukVvjRHrg/tCW
+n0JVzXJdANqpJpHDhmEnv3/Lw6j/8kl9APOt0cLP3bRAmD2V7QkvDBsNpOnlwiE
TfBjkv4gCkBjcB9aPInMQOdwpVp+i28RqQzw+lMipqCUVY/F0/u45WHuM9BF2IED
7fZ6PhxY953qGn5KSKpg2ol6H5X9BMswI5Az+MMGfri2dNRjgU8UfW2sr/YdrNvN
KMzo9vKsbiTGQ6sxb3Ot1ARjDUivletvI4mGjb5dUwV+xKCpWe+CSrwSZDhk5JsE
mR9jeil7QtMBuSl1ts4KB7JJ4Hlx0bHmSX7UOGSUfoqqrdfKQYDGV0GIBsDfX4uC
olcW4HEmDBnwRkxuAfm+GHCtTyWMOYBkQ3LG0uUD/HptBeXAHtVrMP7Hy5EztDiq
VxdrHG7siEKo/kIUO1yQJxUz7cXo8ZFyS7BCMYQZgiuCU3bdowM=
=8e2z
-----END PGP SIGNATURE-----
Reply | Threaded
Open this post in threaded view
|

Re: Error while creating a new solr core

shalvak mittal
 
"When used in combination with the RSA JSSE and RSA JCE providers, this
crypto module provides a FIPS-compliant (FIPS 140-2) implementation. "

This is written in the oracle website so I suppose JsafeJCE provides a
FIPS-compliant JSSE.




--
Sent from: http://lucene.472066.n3.nabble.com/Solr-User-f472068.html