Quantcast

Hadoop 1.0.3 start-daemon.sh doesn't start all the expected daemons

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Hadoop 1.0.3 start-daemon.sh doesn't start all the expected daemons

Dinesh Joshi
Hi all,

I installed Hadoop 1.0.3 and am running it as a single node cluster. I
noticed that start-daemon.sh only starts Namenode, Secondary Namenode
and the JobTracker daemon.

Datanode and Tasktracker daemons are not started. However, when I
start them individually they start up without any issues.

I'm running this on Ubuntu 11.04 and followed the instructions here [1][2]

Can someone point me to some debugging steps?

Thanks.

Dinesh

[1] http://www.michael-noll.com/tutorials/running-hadoop-on-ubuntu-linux-single-node-cluster/
[2] http://hadoop.apache.org/common/docs/stable/mapred_tutorial.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hadoop 1.0.3 start-daemon.sh doesn't start all the expected daemons

in.abdul
Hi Dinesh Joshi,
  Can you please paste your xml(core site,hdfs-site,mapred-site) and did you found any Error in your log dir ..

            Thanks and Regards,
        S SYED ABDUL KATHER 
               


On Fri, Jul 27, 2012 at 2:54 PM, Dinesh Joshi [via Lucene] <[hidden email]> wrote:
Hi all,

I installed Hadoop 1.0.3 and am running it as a single node cluster. I
noticed that start-daemon.sh only starts Namenode, Secondary Namenode
and the JobTracker daemon.

Datanode and Tasktracker daemons are not started. However, when I
start them individually they start up without any issues.

I'm running this on Ubuntu 11.04 and followed the instructions here [1][2]

Can someone point me to some debugging steps?

Thanks.

Dinesh

[1] http://www.michael-noll.com/tutorials/running-hadoop-on-ubuntu-linux-single-node-cluster/
[2] http://hadoop.apache.org/common/docs/stable/mapred_tutorial.html



If you reply to this email, your message will be added to the discussion below:
http://lucene.472066.n3.nabble.com/Hadoop-1-0-3-start-daemon-sh-doesn-t-start-all-the-expected-daemons-tp3997685.html
To unsubscribe from Lucene, click here.
NAML

THANKS AND REGARDS, SYED ABDUL KATHER
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hadoop 1.0.3 start-daemon.sh doesn't start all the expected daemons

bejoy.hadoop
Hi Dinesh

Try using $HADOOP_HOME/bin/start-all.sh . It starts all the hadoop
daemons including TT and DN.


Regards
Bejoy KS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hadoop 1.0.3 start-daemon.sh doesn't start all the expected daemons

Nitin Pawar
I had written a script to setup a single node setup
this is just a dummy script to get things in working state on a single node

just download the files and run the script
https://github.com/nitinpawar/hadoop/

On Fri, Jul 27, 2012 at 5:46 PM, Bejoy Ks <[hidden email]> wrote:
> Hi Dinesh
>
> Try using $HADOOP_HOME/bin/start-all.sh . It starts all the hadoop
> daemons including TT and DN.
>
>
> Regards
> Bejoy KS



--
Nitin Pawar
Loading...