Quantcast

Hadoop on Eclipse

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Hadoop on Eclipse

Alexandre de Assis Bento Lima
Hi,

I'm following the steps suggested by the wiki page:

EclipseEnvironment - Hadoop Wiki (http://wiki.apache.org/hadoop/EclipseEnvironment)

in order to have an Eclipse project for Hadoop. I'm exactly trying to execute the
following command:

mvn eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true

But I always get the following error:

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 12.657s
[INFO] Finished at: Tue Oct 04 02:04:11 BRT 2011
[INFO] Final Memory: 31M/282M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project hadoop-yarn-common: Could not resolve
dependencies for project org.apache.hadoop:hadoop-yarn-common:jar:0.24.0-SNAPSHOT:
Failed to collect dependencies for [log4j:log4j:jar:1.2.12 (compile),
org.apache.hadoop:hadoop-yarn-api:jar:0.24.0-SNAPSHOT (compile),
org.apache.avro:avro:jar:1.5.3 (compile), com.google.protobuf:protobuf-java:jar:2.4.0a
(compile), org.apache.hadoop:hadoop-common:jar:0.24.0-SNAPSHOT (compile),
org.apache.hadoop:hadoop-annotations:jar:0.24.0-SNAPSHOT (compile),
junit:junit:jar:4.8.2 (compile), org.mockito:mockito-all:jar:1.8.5 (test),
org.apache.hadoop:hadoop-common:jar:tests:0.24.0-SNAPSHOT (test),
org.apache.hadoop:hadoop-hdfs:jar:0.24.0-SNAPSHOT (runtime),
com.google.inject.extensions:guice-servlet:jar:2.0 (compile),
org.jboss.netty:netty:jar:3.2.3.Final (compile), org.slf4j:slf4j-api:jar:1.6.1
(compile), org.slf4j:slf4j-log4j12:jar:1.6.1 (compile)]: Failed to read artifact
descriptor for org.apache.hadoop:hadoop-yarn-api:jar:0.24.0-SNAPSHOT: Failure to find
org.apache.hadoop:hadoop-yarn:pom:${yarn.version} in
http://repository.jboss.org/nexus/content/groups/public/ was cached in the local
repository, resolution will not be reattempted until the update interval of
repository.jboss.org has elapsed or updates are forced -> [Help 1]

Then, I try

mvn -X eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true

and get

[DEBUG] =======================================================================
[INFO]
[INFO] >>> maven-eclipse-plugin:2.8:eclipse (default-cli) @ hadoop-yarn-common >>>
[DEBUG] Could not find metadata
org.apache.hadoop:hadoop-yarn-api:0.24.0-SNAPSHOT/maven-metadata.xml in local
(/home/assis/.m2/repository)
[DEBUG] Using connector WagonRepositoryConnector with priority 0 for
http://repository.apache.org/snapshots
Downloading:
http://repository.apache.org/snapshots/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/maven-metadata.xml
Downloaded:
http://repository.apache.org/snapshots/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/maven-metadata.xml
(785 B at 1.0 KB/sec)
[DEBUG] Reading resolution tracking file
/home/assis/.m2/repository/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/resolver-status.properties
[DEBUG] Writing resolution tracking file
/home/assis/.m2/repository/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/resolver-status.properties
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] Apache Hadoop Project POM ......................... SUCCESS [1.626s]
[INFO] Apache Hadoop Annotations ......................... SUCCESS [0.289s]
[INFO] Apache Hadoop Project Dist POM .................... SUCCESS [0.255s]
[INFO] Apache Hadoop Assemblies .......................... SUCCESS [0.207s]
[INFO] Apache Hadoop Auth ................................ SUCCESS [0.557s]
[INFO] Apache Hadoop Auth Examples ....................... SUCCESS [0.384s]
[INFO] Apache Hadoop Common .............................. SUCCESS [1.912s]
[INFO] Apache Hadoop Common Project ...................... SUCCESS [0.083s]
[INFO] Apache Hadoop HDFS ................................ SUCCESS [3.209s]
[INFO] Apache Hadoop HDFS Project ........................ SUCCESS [0.160s]
[INFO] hadoop-yarn-api ................................... SUCCESS [2.273s]
[INFO] hadoop-yarn-common ................................ FAILURE [0.926s]

I check the local repository and realize that there's no maven-metadata.xml file there.
So, I download it myself, try again, and the same things happen.
Can anyone help me, please? I'm using Ubuntu 11.04 with jdk1.7.0, maven 3.0.3 and
protobuf 2.4.1.

Thanks in advance!

Alexandre A. B. Lima.
-----------------------------------------------
COPPE / Computer Science
Federal University of Rio de Janeiro
Rio de Janeiro, Brazil.
+55-21-2562-8690

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hadoop on Eclipse

Luke Lu
Try to do a mvn install -DskipTests -P-cbuild before mvn eclipse:eclipse..

On Mon, Oct 3, 2011 at 10:08 PM, Alexandre de Assis Bento Lima
<[hidden email]> wrote:

> Hi,
>
> I'm following the steps suggested by the wiki page:
>
> EclipseEnvironment - Hadoop Wiki (http://wiki.apache.org/hadoop/EclipseEnvironment)
>
> in order to have an Eclipse project for Hadoop. I'm exactly trying to execute the
> following command:
>
> mvn eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true
>
> But I always get the following error:
>
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 12.657s
> [INFO] Finished at: Tue Oct 04 02:04:11 BRT 2011
> [INFO] Final Memory: 31M/282M
> [INFO] ------------------------------------------------------------------------
> [ERROR] Failed to execute goal on project hadoop-yarn-common: Could not resolve
> dependencies for project org.apache.hadoop:hadoop-yarn-common:jar:0.24.0-SNAPSHOT:
> Failed to collect dependencies for [log4j:log4j:jar:1.2.12 (compile),
> org.apache.hadoop:hadoop-yarn-api:jar:0.24.0-SNAPSHOT (compile),
> org.apache.avro:avro:jar:1.5.3 (compile), com.google.protobuf:protobuf-java:jar:2.4.0a
> (compile), org.apache.hadoop:hadoop-common:jar:0.24.0-SNAPSHOT (compile),
> org.apache.hadoop:hadoop-annotations:jar:0.24.0-SNAPSHOT (compile),
> junit:junit:jar:4.8.2 (compile), org.mockito:mockito-all:jar:1.8.5 (test),
> org.apache.hadoop:hadoop-common:jar:tests:0.24.0-SNAPSHOT (test),
> org.apache.hadoop:hadoop-hdfs:jar:0.24.0-SNAPSHOT (runtime),
> com.google.inject.extensions:guice-servlet:jar:2.0 (compile),
> org.jboss.netty:netty:jar:3.2.3.Final (compile), org.slf4j:slf4j-api:jar:1.6.1
> (compile), org.slf4j:slf4j-log4j12:jar:1.6.1 (compile)]: Failed to read artifact
> descriptor for org.apache.hadoop:hadoop-yarn-api:jar:0.24.0-SNAPSHOT: Failure to find
> org.apache.hadoop:hadoop-yarn:pom:${yarn.version} in
> http://repository.jboss.org/nexus/content/groups/public/ was cached in the local
> repository, resolution will not be reattempted until the update interval of
> repository.jboss.org has elapsed or updates are forced -> [Help 1]
>
> Then, I try
>
> mvn -X eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true
>
> and get
>
> [DEBUG] =======================================================================
> [INFO]
> [INFO] >>> maven-eclipse-plugin:2.8:eclipse (default-cli) @ hadoop-yarn-common >>>
> [DEBUG] Could not find metadata
> org.apache.hadoop:hadoop-yarn-api:0.24.0-SNAPSHOT/maven-metadata.xml in local
> (/home/assis/.m2/repository)
> [DEBUG] Using connector WagonRepositoryConnector with priority 0 for
> http://repository.apache.org/snapshots
> Downloading:
> http://repository.apache.org/snapshots/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/maven-metadata.xml
> Downloaded:
> http://repository.apache.org/snapshots/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/maven-metadata.xml
> (785 B at 1.0 KB/sec)
> [DEBUG] Reading resolution tracking file
> /home/assis/.m2/repository/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/resolver-status.properties
> [DEBUG] Writing resolution tracking file
> /home/assis/.m2/repository/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/resolver-status.properties
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] Apache Hadoop Project POM ......................... SUCCESS [1.626s]
> [INFO] Apache Hadoop Annotations ......................... SUCCESS [0.289s]
> [INFO] Apache Hadoop Project Dist POM .................... SUCCESS [0.255s]
> [INFO] Apache Hadoop Assemblies .......................... SUCCESS [0.207s]
> [INFO] Apache Hadoop Auth ................................ SUCCESS [0.557s]
> [INFO] Apache Hadoop Auth Examples ....................... SUCCESS [0.384s]
> [INFO] Apache Hadoop Common .............................. SUCCESS [1.912s]
> [INFO] Apache Hadoop Common Project ...................... SUCCESS [0.083s]
> [INFO] Apache Hadoop HDFS ................................ SUCCESS [3.209s]
> [INFO] Apache Hadoop HDFS Project ........................ SUCCESS [0.160s]
> [INFO] hadoop-yarn-api ................................... SUCCESS [2.273s]
> [INFO] hadoop-yarn-common ................................ FAILURE [0.926s]
>
> I check the local repository and realize that there's no maven-metadata.xml file there.
> So, I download it myself, try again, and the same things happen.
> Can anyone help me, please? I'm using Ubuntu 11.04 with jdk1.7.0, maven 3.0.3 and
> protobuf 2.4.1.
>
> Thanks in advance!
>
> Alexandre A. B. Lima.
> -----------------------------------------------
> COPPE / Computer Science
> Federal University of Rio de Janeiro
> Rio de Janeiro, Brazil.
> +55-21-2562-8690
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hadoop on Eclipse

Alexandre de Assis Bento Lima
Thanks, Luke! But I'm still having problems.

After importing all projects into Eclipse, I got 1007 erros. The first one:

"Project 'MapReduceTools' is missing required library: 'lib/hadoop-core.jar'"

Then, many of the following kind:

"Unbound classpath variable: 'M2_REPO/aopalliance/aopalliance/1.0/aopalliance-1.0.jar'
in project 'hadoop-mapreduce-client-app'"

Is there any place where I can have a complete step list about how to develop Hadoop?
The wiki seems no to be up-to-date.
Can anyone help?

Thanks in advance!
Alexandre.

On Tue, 4 Oct 2011 03:05:02 -0700, Luke Lu wrote

> Try to do a mvn install -DskipTests -P-cbuild before mvn eclipse:eclipse..
>
> On Mon, Oct 3, 2011 at 10:08 PM, Alexandre de Assis Bento Lima
> <[hidden email]> wrote:
> > Hi,
> >
> > I'm following the steps suggested by the wiki page:
> >
> > EclipseEnvironment - Hadoop Wiki (http://wiki.apache.org/hadoop/EclipseEnvironment)
> >
> > in order to have an Eclipse project for Hadoop. I'm exactly trying to execute the
> > following command:
> >
> > mvn eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true
> >
> > But I always get the following error:
> >
> > [INFO] ------------------------------------------------------------------------
> > [INFO] BUILD FAILURE
> > [INFO] ------------------------------------------------------------------------
> > [INFO] Total time: 12.657s
> > [INFO] Finished at: Tue Oct 04 02:04:11 BRT 2011
> > [INFO] Final Memory: 31M/282M
> > [INFO] ------------------------------------------------------------------------
> > [ERROR] Failed to execute goal on project hadoop-yarn-common: Could not resolve
> > dependencies for project org.apache.hadoop:hadoop-yarn-common:jar:0.24.0-SNAPSHOT:
> > Failed to collect dependencies for [log4j:log4j:jar:1.2.12 (compile),
> > org.apache.hadoop:hadoop-yarn-api:jar:0.24.0-SNAPSHOT (compile),
> > org.apache.avro:avro:jar:1.5.3 (compile), com.google.protobuf:protobuf-java:jar:2.4.0a
> > (compile), org.apache.hadoop:hadoop-common:jar:0.24.0-SNAPSHOT (compile),
> > org.apache.hadoop:hadoop-annotations:jar:0.24.0-SNAPSHOT (compile),
> > junit:junit:jar:4.8.2 (compile), org.mockito:mockito-all:jar:1.8.5 (test),
> > org.apache.hadoop:hadoop-common:jar:tests:0.24.0-SNAPSHOT (test),
> > org.apache.hadoop:hadoop-hdfs:jar:0.24.0-SNAPSHOT (runtime),
> > com.google.inject.extensions:guice-servlet:jar:2.0 (compile),
> > org.jboss.netty:netty:jar:3.2.3.Final (compile), org.slf4j:slf4j-api:jar:1.6.1
> > (compile), org.slf4j:slf4j-log4j12:jar:1.6.1 (compile)]: Failed to read artifact
> > descriptor for org.apache.hadoop:hadoop-yarn-api:jar:0.24.0-SNAPSHOT: Failure to find
> > org.apache.hadoop:hadoop-yarn:pom:${yarn.version} in
> > http://repository.jboss.org/nexus/content/groups/public/ was cached in the local
> > repository, resolution will not be reattempted until the update interval of
> > repository.jboss.org has elapsed or updates are forced -> [Help 1]
> >
> > Then, I try
> >
> > mvn -X eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true
> >
> > and get
> >
> > [DEBUG] =======================================================================
> > [INFO]
> > [INFO] >>> maven-eclipse-plugin:2.8:eclipse (default-cli) @ hadoop-yarn-common >>>
> > [DEBUG] Could not find metadata
> > org.apache.hadoop:hadoop-yarn-api:0.24.0-SNAPSHOT/maven-metadata.xml in local
> > (/home/assis/.m2/repository)
> > [DEBUG] Using connector WagonRepositoryConnector with priority 0 for
> > http://repository.apache.org/snapshots
> > Downloading:
> >
http://repository.apache.org/snapshots/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/maven-metadata.xml
> > Downloaded:
> >
http://repository.apache.org/snapshots/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/maven-metadata.xml
> > (785 B at 1.0 KB/sec)
> > [DEBUG] Reading resolution tracking file
> >
/home/assis/.m2/repository/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/resolver-status.properties
> > [DEBUG] Writing resolution tracking file
> >
/home/assis/.m2/repository/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT/resolver-status.properties

> > [INFO] ------------------------------------------------------------------------
> > [INFO] Reactor Summary:
> > [INFO]
> > [INFO] Apache Hadoop Project POM ......................... SUCCESS [1.626s]
> > [INFO] Apache Hadoop Annotations ......................... SUCCESS [0.289s]
> > [INFO] Apache Hadoop Project Dist POM .................... SUCCESS [0.255s]
> > [INFO] Apache Hadoop Assemblies .......................... SUCCESS [0.207s]
> > [INFO] Apache Hadoop Auth ................................ SUCCESS [0.557s]
> > [INFO] Apache Hadoop Auth Examples ....................... SUCCESS [0.384s]
> > [INFO] Apache Hadoop Common .............................. SUCCESS [1.912s]
> > [INFO] Apache Hadoop Common Project ...................... SUCCESS [0.083s]
> > [INFO] Apache Hadoop HDFS ................................ SUCCESS [3.209s]
> > [INFO] Apache Hadoop HDFS Project ........................ SUCCESS [0.160s]
> > [INFO] hadoop-yarn-api ................................... SUCCESS [2.273s]
> > [INFO] hadoop-yarn-common ................................ FAILURE [0.926s]
> >
> > I check the local repository and realize that there's no maven-metadata.xml file there.
> > So, I download it myself, try again, and the same things happen.
> > Can anyone help me, please? I'm using Ubuntu 11.04 with jdk1.7.0, maven 3.0.3 and
> > protobuf 2.4.1.
> >
> > Thanks in advance!
> >
> > Alexandre A. B. Lima.
> > -----------------------------------------------
> > COPPE / Computer Science
> > Federal University of Rio de Janeiro
> > Rio de Janeiro, Brazil.
> > +55-21-2562-8690
> >
> >


Alexandre A. B. Lima.
-----------------------------------------------
COPPE / Computer Science
Federal University of Rio de Janeiro
Rio de Janeiro, Brazil.
+55-21-2562-8690

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Hadoop on Eclipse

Ravi Teja
Hi Alexandre,

You need to set the M2_REPO variable in your eclipse to the maven repository
which is present in your local system. By default it is
{userhome}/.m2/repository

Regards,
Ravi Teja

-----Original Message-----
From: Alexandre de Assis Bento Lima [mailto:[hidden email]]
Sent: Wednesday, October 05, 2011 3:55 AM
To: [hidden email]
Subject: Re: Hadoop on Eclipse

Thanks, Luke! But I'm still having problems.

After importing all projects into Eclipse, I got 1007 erros. The first one:

"Project 'MapReduceTools' is missing required library:
'lib/hadoop-core.jar'"

Then, many of the following kind:

"Unbound classpath variable:
'M2_REPO/aopalliance/aopalliance/1.0/aopalliance-1.0.jar'
in project 'hadoop-mapreduce-client-app'"

Is there any place where I can have a complete step list about how to
develop Hadoop?
The wiki seems no to be up-to-date.
Can anyone help?

Thanks in advance!
Alexandre.

On Tue, 4 Oct 2011 03:05:02 -0700, Luke Lu wrote
> Try to do a mvn install -DskipTests -P-cbuild before mvn eclipse:eclipse..
>
> On Mon, Oct 3, 2011 at 10:08 PM, Alexandre de Assis Bento Lima
> <[hidden email]> wrote:
> > Hi,
> >
> > I'm following the steps suggested by the wiki page:
> >
> > EclipseEnvironment - Hadoop Wiki
(http://wiki.apache.org/hadoop/EclipseEnvironment)
> >
> > in order to have an Eclipse project for Hadoop. I'm exactly trying to
execute the
> > following command:
> >
> > mvn eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true
> >
> > But I always get the following error:
> >
> > [INFO]
------------------------------------------------------------------------
> > [INFO] BUILD FAILURE
> > [INFO]
------------------------------------------------------------------------
> > [INFO] Total time: 12.657s
> > [INFO] Finished at: Tue Oct 04 02:04:11 BRT 2011
> > [INFO] Final Memory: 31M/282M
> > [INFO]
------------------------------------------------------------------------
> > [ERROR] Failed to execute goal on project hadoop-yarn-common: Could not
resolve
> > dependencies for project
org.apache.hadoop:hadoop-yarn-common:jar:0.24.0-SNAPSHOT:
> > Failed to collect dependencies for [log4j:log4j:jar:1.2.12 (compile),
> > org.apache.hadoop:hadoop-yarn-api:jar:0.24.0-SNAPSHOT (compile),
> > org.apache.avro:avro:jar:1.5.3 (compile),
com.google.protobuf:protobuf-java:jar:2.4.0a
> > (compile), org.apache.hadoop:hadoop-common:jar:0.24.0-SNAPSHOT
(compile),
> > org.apache.hadoop:hadoop-annotations:jar:0.24.0-SNAPSHOT (compile),
> > junit:junit:jar:4.8.2 (compile), org.mockito:mockito-all:jar:1.8.5
(test),
> > org.apache.hadoop:hadoop-common:jar:tests:0.24.0-SNAPSHOT (test),
> > org.apache.hadoop:hadoop-hdfs:jar:0.24.0-SNAPSHOT (runtime),
> > com.google.inject.extensions:guice-servlet:jar:2.0 (compile),
> > org.jboss.netty:netty:jar:3.2.3.Final (compile),
org.slf4j:slf4j-api:jar:1.6.1
> > (compile), org.slf4j:slf4j-log4j12:jar:1.6.1 (compile)]: Failed to read
artifact
> > descriptor for org.apache.hadoop:hadoop-yarn-api:jar:0.24.0-SNAPSHOT:
Failure to find
> > org.apache.hadoop:hadoop-yarn:pom:${yarn.version} in
> > http://repository.jboss.org/nexus/content/groups/public/ was cached in
the local
> > repository, resolution will not be reattempted until the update interval
of
> > repository.jboss.org has elapsed or updates are forced -> [Help 1]
> >
> > Then, I try
> >
> > mvn -X eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true
> >
> > and get
> >
> > [DEBUG]
=======================================================================
> > [INFO]
> > [INFO] >>> maven-eclipse-plugin:2.8:eclipse (default-cli) @
hadoop-yarn-common >>>
> > [DEBUG] Could not find metadata
> > org.apache.hadoop:hadoop-yarn-api:0.24.0-SNAPSHOT/maven-metadata.xml in
local
> > (/home/assis/.m2/repository)
> > [DEBUG] Using connector WagonRepositoryConnector with priority 0 for
> > http://repository.apache.org/snapshots
> > Downloading:
> >
http://repository.apache.org/snapshots/org/apache/hadoop/hadoop-yarn-api/0.2
4.0-SNAPSHOT/maven-metadata.xml
> > Downloaded:
> >
http://repository.apache.org/snapshots/org/apache/hadoop/hadoop-yarn-api/0.2
4.0-SNAPSHOT/maven-metadata.xml
> > (785 B at 1.0 KB/sec)
> > [DEBUG] Reading resolution tracking file
> >
/home/assis/.m2/repository/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT
/resolver-status.properties
> > [DEBUG] Writing resolution tracking file
> >
/home/assis/.m2/repository/org/apache/hadoop/hadoop-yarn-api/0.24.0-SNAPSHOT
/resolver-status.properties
> > [INFO]
------------------------------------------------------------------------
> > [INFO] Reactor Summary:
> > [INFO]
> > [INFO] Apache Hadoop Project POM ......................... SUCCESS
[1.626s]
> > [INFO] Apache Hadoop Annotations ......................... SUCCESS
[0.289s]
> > [INFO] Apache Hadoop Project Dist POM .................... SUCCESS
[0.255s]
> > [INFO] Apache Hadoop Assemblies .......................... SUCCESS
[0.207s]
> > [INFO] Apache Hadoop Auth ................................ SUCCESS
[0.557s]
> > [INFO] Apache Hadoop Auth Examples ....................... SUCCESS
[0.384s]
> > [INFO] Apache Hadoop Common .............................. SUCCESS
[1.912s]
> > [INFO] Apache Hadoop Common Project ...................... SUCCESS
[0.083s]
> > [INFO] Apache Hadoop HDFS ................................ SUCCESS
[3.209s]
> > [INFO] Apache Hadoop HDFS Project ........................ SUCCESS
[0.160s]
> > [INFO] hadoop-yarn-api ................................... SUCCESS
[2.273s]
> > [INFO] hadoop-yarn-common ................................ FAILURE
[0.926s]
> >
> > I check the local repository and realize that there's no
maven-metadata.xml file there.
> > So, I download it myself, try again, and the same things happen.
> > Can anyone help me, please? I'm using Ubuntu 11.04 with jdk1.7.0, maven
3.0.3 and

> > protobuf 2.4.1.
> >
> > Thanks in advance!
> >
> > Alexandre A. B. Lima.
> > -----------------------------------------------
> > COPPE / Computer Science
> > Federal University of Rio de Janeiro
> > Rio de Janeiro, Brazil.
> > +55-21-2562-8690
> >
> >


Alexandre A. B. Lima.
-----------------------------------------------
COPPE / Computer Science
Federal University of Rio de Janeiro
Rio de Janeiro, Brazil.
+55-21-2562-8690

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hadoop on Eclipse

Tim Broberg
I am having issues similar to Alexandre's.
 
The suggestion to run "mvn install -DskipTests -P-cbuild" clears up the initial problems, but problems ensue...
 
 1a - There is no hdfs subdirectory to change into.
 1b - If I instead cd to hadoop-hdfs-project and proceed, I get...
[tbroberg@f15 hadoop-common]$ cd hadoop-hdfs-project/
[tbroberg@f15 hadoop-hdfs-project]$ ant compile eclipse
Buildfile: build.xml does not exist!
Build failed
[tbroberg@f15 hadoop-hdfs-project]$
 2 - If I skip hdfs altogether and go to hadoop-mapreduce-project problems much like the original issues crop up:
 
Output is below, debug output is attached.
 
Looks like maybe he's failing to expand ${yarn.version}?
 
Anybody got any better suggestions than "go out to dinner?"
 
Thanks,
    - Tim.
[tbroberg@f15 hadoop-mapreduce-project]$ ant compile eclipse
Buildfile: /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml
clover.setup:
clover.info:
     [echo]
     [echo]      Clover not found. Code coverage reports disabled.
     [echo]
clover:
ivy-download:
      [get] Getting: http://repo2.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
      [get] To: /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivy-2.2.0.jar
      [get] Not modified - so not downloaded
ivy-init-dirs:
ivy-probe-antlib:
ivy-init-antlib:
ivy-init:
[ivy:configure] :: Ivy 2.2.0 - 20100923230623 :: http://ant.apache.org/ivy/ ::
[ivy:configure] :: loading settings :: file = /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivysettings.xml
ivy-resolve-common:
[ivy:resolve]
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve]   io problem while parsing ivy file: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-20110914.035045-1.pom: Impossible to load parent for file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-server-common/ivy-0.24.0-SNAPSHOT.xml.original. Parent=org.apache.hadoop#hadoop-yarn-server;${yarn.version}
[ivy:resolve]           module not found: org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT
[ivy:resolve]   ==== apache-snapshot: tried
[ivy:resolve]     <A href="https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.pom">https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.pom
[ivy:resolve]     -- artifact org.apache.hadoop#hadoop-yarn-server;${yarn.version}!hadoop-yarn-server.jar:
[ivy:resolve]     <A href="https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.jar">https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.jar
[ivy:resolve]   ==== maven2: tried
[ivy:resolve]     http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.pom
[ivy:resolve]     -- artifact org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT!hadoop-yarn-server-common.jar:
[ivy:resolve]     http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.jar
[ivy:resolve]   io problem while parsing ivy file: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-20110914.035126-1.pom: Impossible to load parent for file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-mapreduce-client-core/ivy-0.24.0-SNAPSHOT.xml.original. Parent=org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}
[ivy:resolve]           module not found: org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT
[ivy:resolve]   ==== apache-snapshot: tried
[ivy:resolve]     <A href="https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.pom">https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.pom
[ivy:resolve]     -- artifact org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}!hadoop-mapreduce-client.jar:
[ivy:resolve]     <A href="https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.jar">https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.jar
[ivy:resolve]   ==== maven2: tried
[ivy:resolve]     http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.pom
[ivy:resolve]     -- artifact org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT!hadoop-mapreduce-client-core.jar:
[ivy:resolve]     http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.jar
[ivy:resolve]   io problem while parsing ivy file: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-20110914.034958-1.pom: Impossible to load parent for file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-common/ivy-0.24.0-SNAPSHOT.xml.original. Parent=org.apache.hadoop#hadoop-yarn;${yarn.version}
[ivy:resolve]           module not found: org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT
[ivy:resolve]   ==== apache-snapshot: tried
[ivy:resolve]     <A href="https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.pom">https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.pom
[ivy:resolve]     -- artifact org.apache.hadoop#hadoop-yarn;${yarn.version}!hadoop-yarn.jar:
[ivy:resolve]     <A href="https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.jar">https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.jar
[ivy:resolve]   ==== maven2: tried
[ivy:resolve]     http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.pom
[ivy:resolve]     -- artifact org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT!hadoop-yarn-common.jar:
[ivy:resolve]     http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.jar
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]           ::          UNRESOLVED DEPENDENCIES         ::
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]           :: org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT: not found
[ivy:resolve]           :: org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT: not found
[ivy:resolve]           :: org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT: not found
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]
[ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
BUILD FAILED
/home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml:2223: impossible to resolve dependencies:
        resolve failed - see output for details
Total time: 23 seconds
[tbroberg@f15 hadoop-mapreduce-project]$

ace_output.zip (57K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hadoop on Eclipse

Prasanth J
Am also facing the exact issue. I think the documentation for setting up
hadoop on eclipse is for older versions of hadoop. Now i am using hadoop
0.24.0 snapshot and with reference to that the documentation seems outdated.
Any help on this regard will be very useful.

On Wed, Oct 5, 2011 at 10:34 PM, Tim Broberg <[hidden email]> wrote:

> I am having issues similar to Alexandre's.
>
> The suggestion to run "mvn install -DskipTests -P-cbuild" clears up the
> initial problems, but problems ensue...
>
>  1a - There is no hdfs subdirectory to change into.
>  1b - If I instead cd to hadoop-hdfs-project and proceed, I get...
>
> [tbroberg@f15 hadoop-common]$ cd hadoop-hdfs-project/
> [tbroberg@f15 hadoop-hdfs-project]$ ant compile eclipse
> Buildfile: build.xml does not exist!
> Build failed
> [tbroberg@f15 hadoop-hdfs-project]$
>
>  2 - If I skip hdfs altogether and go to hadoop-mapreduce-project problems
> much like the original issues crop up:
>
> Output is below, debug output is attached.
>
> Looks like maybe he's failing to expand ${yarn.version}?
>
> Anybody got any better suggestions than "go out to dinner?"
>
> Thanks,
>     - Tim.
>
> [tbroberg@f15 hadoop-mapreduce-project]$ ant compile eclipse
> Buildfile:
> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml
> clover.setup:
> clover.info:
>      [echo]
>      [echo]      Clover not found. Code coverage reports disabled.
>      [echo]
> clover:
> ivy-download:
>       [get] Getting:
> http://repo2.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
>       [get] To:
> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivy-2.2.0.jar
>       [get] Not modified - so not downloaded
> ivy-init-dirs:
> ivy-probe-antlib:
> ivy-init-antlib:
> ivy-init:
> [ivy:configure] :: Ivy 2.2.0 - 20100923230623 ::
> http://ant.apache.org/ivy/ ::
> [ivy:configure] :: loading settings :: file =
> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivysettings.xml
> ivy-resolve-common:
> [ivy:resolve]
> [ivy:resolve] :: problems summary ::
> [ivy:resolve] :::: WARNINGS
> [ivy:resolve]   io problem while parsing ivy file:
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-20110914.035045-1.pom:
> Impossible to load parent for
> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-server-common/ivy-0.24.0-SNAPSHOT.xml.original.
> Parent=org.apache.hadoop#hadoop-yarn-server;${yarn.version}
> [ivy:resolve]           module not found:
> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT
> [ivy:resolve]   ==== apache-snapshot: tried
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.pom
> [ivy:resolve]     -- artifact
> org.apache.hadoop#hadoop-yarn-server;${yarn.version}!hadoop-yarn-server.jar:
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.jar
> [ivy:resolve]   ==== maven2: tried
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.pom
> [ivy:resolve]     -- artifact
> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT!hadoop-yarn-server-common.jar:
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.jar
> [ivy:resolve]   io problem while parsing ivy file:
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-20110914.035126-1.pom:
> Impossible to load parent for
> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-mapreduce-client-core/ivy-0.24.0-SNAPSHOT.xml.original.
> Parent=org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}
> [ivy:resolve]           module not found:
> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT
> [ivy:resolve]   ==== apache-snapshot: tried
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.pom
> [ivy:resolve]     -- artifact
> org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}!hadoop-mapreduce-client.jar:
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.jar
> [ivy:resolve]   ==== maven2: tried
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.pom
> [ivy:resolve]     -- artifact
> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT!hadoop-mapreduce-client-core.jar:
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.jar
> [ivy:resolve]   io problem while parsing ivy file:
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-20110914.034958-1.pom:
> Impossible to load parent for
> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-common/ivy-0.24.0-SNAPSHOT.xml.original.
> Parent=org.apache.hadoop#hadoop-yarn;${yarn.version}
> [ivy:resolve]           module not found:
> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT
> [ivy:resolve]   ==== apache-snapshot: tried
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.pom
> [ivy:resolve]     -- artifact
> org.apache.hadoop#hadoop-yarn;${yarn.version}!hadoop-yarn.jar:
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.jar
> [ivy:resolve]   ==== maven2: tried
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.pom
> [ivy:resolve]     -- artifact
> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT!hadoop-yarn-common.jar:
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.jar
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]           ::          UNRESOLVED DEPENDENCIES         ::
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]           ::
> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT: not found
> [ivy:resolve]           ::
> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT: not found
> [ivy:resolve]           ::
> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT: not found
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]
> [ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
> BUILD FAILED
> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml:2223:
> impossible to resolve dependencies:
>         resolve failed - see output for details
> Total time: 23 seconds
> [tbroberg@f15 hadoop-mapreduce-project]$
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hadoop on Eclipse

Tim Broberg
After still more puttering, I gave up and just logged this in jira.

https://issues.apache.org/jira/browse/HADOOP-7726

    - Tim.




________________________________
From: Prasanth J <[hidden email]>
To: [hidden email]; Tim Broberg <[hidden email]>
Sent: Thursday, October 6, 2011 11:02 AM
Subject: Re: Hadoop on Eclipse

Am also facing the exact issue. I think the documentation for setting up
hadoop on eclipse is for older versions of hadoop. Now i am using hadoop
0.24.0 snapshot and with reference to that the documentation seems outdated.
Any help on this regard will be very useful.

On Wed, Oct 5, 2011 at 10:34 PM, Tim Broberg <[hidden email]> wrote:

> I am having issues similar to Alexandre's.
>
> The suggestion to run "mvn install -DskipTests -P-cbuild" clears up the
> initial problems, but problems ensue...
>
>  1a - There is no hdfs subdirectory to change into.
>  1b - If I instead cd to hadoop-hdfs-project and proceed, I get...
>
> [tbroberg@f15 hadoop-common]$ cd hadoop-hdfs-project/
> [tbroberg@f15 hadoop-hdfs-project]$ ant compile eclipse
> Buildfile: build.xml does not exist!
> Build failed
> [tbroberg@f15 hadoop-hdfs-project]$
>
>  2 - If I skip hdfs altogether and go to hadoop-mapreduce-project problems
> much like the original issues crop up:
>
> Output is below, debug output is attached.
>
> Looks like maybe he's failing to expand ${yarn.version}?
>
> Anybody got any better suggestions than "go out to dinner?"
>
> Thanks,
>    - Tim.
>
> [tbroberg@f15 hadoop-mapreduce-project]$ ant compile eclipse
> Buildfile:
> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml
> clover.setup:
> clover.info:
>      [echo]
>      [echo]      Clover not found. Code coverage reports disabled.
>      [echo]
> clover:
> ivy-download:
>      [get] Getting:
> http://repo2.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
>      [get] To:
> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivy-2.2.0.jar
>      [get] Not modified - so not downloaded
> ivy-init-dirs:
> ivy-probe-antlib:
> ivy-init-antlib:
> ivy-init:
> [ivy:configure] :: Ivy 2.2.0 - 20100923230623 ::
> http://ant.apache.org/ivy/ ::
> [ivy:configure] :: loading settings :: file =
> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivysettings.xml
> ivy-resolve-common:
> [ivy:resolve]
> [ivy:resolve] :: problems summary ::
> [ivy:resolve] :::: WARNINGS
> [ivy:resolve]  io problem while parsing ivy file:
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-20110914.035045-1.pom:
> Impossible to load parent for
> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-server-common/ivy-0.24.0-SNAPSHOT.xml.original.
> Parent=org.apache.hadoop#hadoop-yarn-server;${yarn.version}
> [ivy:resolve]          module not found:
> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT
> [ivy:resolve]  ==== apache-snapshot: tried
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.pom
> [ivy:resolve]    -- artifact
> org.apache.hadoop#hadoop-yarn-server;${yarn.version}!hadoop-yarn-server.jar:
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.jar
> [ivy:resolve]  ==== maven2: tried
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.pom
> [ivy:resolve]    -- artifact
> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT!hadoop-yarn-server-common.jar:
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.jar
> [ivy:resolve]  io problem while parsing ivy file:
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-20110914.035126-1.pom:
> Impossible to load parent for
> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-mapreduce-client-core/ivy-0.24.0-SNAPSHOT.xml.original.
> Parent=org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}
> [ivy:resolve]          module not found:
> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT
> [ivy:resolve]  ==== apache-snapshot: tried
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.pom
> [ivy:resolve]    -- artifact
> org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}!hadoop-mapreduce-client.jar:
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.jar
> [ivy:resolve]  ==== maven2: tried
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.pom
> [ivy:resolve]    -- artifact
> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT!hadoop-mapreduce-client-core.jar:
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.jar
> [ivy:resolve]  io problem while parsing ivy file:
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-20110914.034958-1.pom:
> Impossible to load parent for
> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-common/ivy-0.24.0-SNAPSHOT.xml.original.
> Parent=org.apache.hadoop#hadoop-yarn;${yarn.version}
> [ivy:resolve]          module not found:
> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT
> [ivy:resolve]  ==== apache-snapshot: tried
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.pom
> [ivy:resolve]    -- artifact
> org.apache.hadoop#hadoop-yarn;${yarn.version}!hadoop-yarn.jar:
> [ivy:resolve]
> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.jar
> [ivy:resolve]  ==== maven2: tried
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.pom
> [ivy:resolve]    -- artifact
> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT!hadoop-yarn-common.jar:
> [ivy:resolve]
> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.jar
> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]          ::          UNRESOLVED DEPENDENCIES        ::
> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]          ::
> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT: not found
> [ivy:resolve]          ::
> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT: not found
> [ivy:resolve]          ::
> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT: not found
> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]
> [ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
> BUILD FAILED
> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml:2223:
> impossible to resolve dependencies:
>        resolve failed - see output for details
> Total time: 23 seconds
> [tbroberg@f15 hadoop-mapreduce-project]$
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Fw: Hadoop on Eclipse

Eric Payne-2
I have been working in the 0.23 branch. Supposedly, there is not a lot of difference between 0.23 and 0.24.
 
I get the 'UNRESOLVED DEPENDENCIES' error sometimes, but then on the second try, it goes away. Go figure.
 
I'm an eclipse newbie, but with a lot of help, I was able to get it going on the 0.23 branch on Linux. Here's what I did:
 
-- from command line pull down the SVN repo:
export SVNROOT=http://svn.apache.org/repos/asf 
svn co $SVNROOT/hadoop/common/branches/branch-0.23
 
-- just to be safe, I remove my .m2 and .ivy directories from my home directory.
 
-- in 'branch-0.23' directory, use maven to build:
mvn clean install -Pdist -Dtar -DskipTests

-- in 'branch-0.23/hadoop-mapreduce-project' directory, build again:
mvn clean install assembly:assembly -DskipTests

-- In same directory, build using ant:
ant -Dresolvers=internal -Dcompile.c+=true -Dcompile.native=true -Dforrest.home=$FORREST_HOME create-c++-configure tar 
    -- At this point, I do get the 'UNRESOLVED DEPENDENCIES' error. If I do, I just try it again and it works.
 
-- start eclipse
-- I use the following maven plugin: http://m2eclipse.sonatype.org/sites/m2e
-- I go to the project explorer and choose to import a maven project and select the 'branch-0.23' directory. It works for a while (10 minutes or so), and then you can edit, navigate, etc.
 
NOTE: I build from the command line, not from w/i eclipse.
 
Hope that helps.
-Eric
 
 
 
----- Forwarded Message -----

>From: Eric Payne <[hidden email]>
>To: "[hidden email]" <[hidden email]>
>Sent: Friday, October 7, 2011 8:20 AM
>Subject: RE: Hadoop on Eclipse
>
>
>
>-----Original Message-----
>From: Tim Broberg [mailto:[hidden email]]
>Sent: Thursday, October 06, 2011 11:00 PM
>To: [hidden email]
>Subject: Re: Hadoop on Eclipse
>
>After still more puttering, I gave up and just logged this in jira.
>
>https://issues.apache.org/jira/browse/HADOOP-7726
>
>    - Tim.
>
>
>
>
>________________________________
>From: Prasanth J <[hidden email]>
>To: [hidden email]; Tim Broberg <[hidden email]>
>Sent: Thursday, October 6, 2011 11:02 AM
>Subject: Re: Hadoop on Eclipse
>
>Am also facing the exact issue. I think the documentation for setting up
>hadoop on eclipse is for older versions of hadoop. Now i am using hadoop
>0.24.0 snapshot and with reference to that the documentation seems outdated.
>Any help on this regard will be very useful.
>
>On Wed, Oct 5, 2011 at 10:34 PM, Tim Broberg <[hidden email]> wrote:
>
>> I am having issues similar to Alexandre's.
>>
>> The suggestion to run "mvn install -DskipTests -P-cbuild" clears up the
>> initial problems, but problems ensue...
>>
>>  1a - There is no hdfs subdirectory to change into.
>>  1b - If I instead cd to hadoop-hdfs-project and proceed, I get...
>>
>> [tbroberg@f15 hadoop-common]$ cd hadoop-hdfs-project/
>> [tbroberg@f15 hadoop-hdfs-project]$ ant compile eclipse
>> Buildfile: build.xml does not exist!
>> Build failed
>> [tbroberg@f15 hadoop-hdfs-project]$
>>
>>  2 - If I skip hdfs altogether and go to hadoop-mapreduce-project problems
>> much like the original issues crop up:
>>
>> Output is below, debug output is attached.
>>
>> Looks like maybe he's failing to expand ${yarn.version}?
>>
>> Anybody got any better suggestions than "go out to dinner?"
>>
>> Thanks,
>>    - Tim.
>>
>> [tbroberg@f15 hadoop-mapreduce-project]$ ant compile eclipse
>> Buildfile:
>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml
>> clover.setup:
>> clover.info:
>>      [echo]
>>      [echo]      Clover not found. Code coverage reports disabled.
>>      [echo]
>> clover:
>> ivy-download:
>>      [get] Getting:
>> http://repo2.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
>>      [get] To:
>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivy-2.2.0.jar
>>      [get] Not modified - so not downloaded
>> ivy-init-dirs:
>> ivy-probe-antlib:
>> ivy-init-antlib:
>> ivy-init:
>> [ivy:configure] :: Ivy 2.2.0 - 20100923230623 ::
>> http://ant.apache.org/ivy/ ::
>> [ivy:configure] :: loading settings :: file =
>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivysettings.xml
>> ivy-resolve-common:
>> [ivy:resolve]
>> [ivy:resolve] :: problems summary ::
>> [ivy:resolve] :::: WARNINGS
>> [ivy:resolve]  io problem while parsing ivy file:
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-20110914.035045-1.pom:
>> Impossible to load parent for
>> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-server-common/ivy-0.24.0-SNAPSHOT.xml.original.
>> Parent=org.apache.hadoop#hadoop-yarn-server;${yarn.version}
>> [ivy:resolve]          module not found:
>> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT
>> [ivy:resolve]  ==== apache-snapshot: tried
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-yarn-server;${yarn.version}!hadoop-yarn-server.jar:
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.jar
>> [ivy:resolve]  ==== maven2: tried
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT!hadoop-yarn-server-common.jar:
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.jar
>> [ivy:resolve]  io problem while parsing ivy file:
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-20110914.035126-1.pom:
>> Impossible to load parent for
>> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-mapreduce-client-core/ivy-0.24.0-SNAPSHOT.xml.original.
>> Parent=org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}
>> [ivy:resolve]          module not found:
>> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT
>> [ivy:resolve]  ==== apache-snapshot: tried
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}!hadoop-mapreduce-client.jar:
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.jar
>> [ivy:resolve]  ==== maven2: tried
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT!hadoop-mapreduce-client-core.jar:
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.jar
>> [ivy:resolve]  io problem while parsing ivy file:
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-20110914.034958-1.pom:
>> Impossible to load parent for
>> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-common/ivy-0.24.0-SNAPSHOT.xml.original.
>> Parent=org.apache.hadoop#hadoop-yarn;${yarn.version}
>> [ivy:resolve]          module not found:
>> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT
>> [ivy:resolve]  ==== apache-snapshot: tried
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-yarn;${yarn.version}!hadoop-yarn.jar:
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.jar
>> [ivy:resolve]  ==== maven2: tried
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT!hadoop-yarn-common.jar:
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.jar
>> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
>> [ivy:resolve]          ::          UNRESOLVED DEPENDENCIES        ::
>> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
>> [ivy:resolve]          ::
>> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT: not found
>> [ivy:resolve]          ::
>> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT: not found
>> [ivy:resolve]          ::
>> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT: not found
>> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
>> [ivy:resolve]
>> [ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
>> BUILD FAILED
>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml:2223:
>> impossible to resolve dependencies:
>>        resolve failed - see output for details
>> Total time: 23 seconds
>> [tbroberg@f15 hadoop-mapreduce-project]$
>>
>>
>
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hadoop on Eclipse

Eric Payne-2
Sorry, my bad. It's the 'FAILED DOWNLOADS' error that goes away the second time. I don't see the 'UNRESOLVED DEPENDENCIES' error.
 
-Eric


>________________________________
>From: Eric Payne <[hidden email]>
>To: "[hidden email]" <[hidden email]>
>Sent: Friday, October 7, 2011 9:09 AM
>Subject: Fw: Hadoop on Eclipse
>
>
>I have been working in the 0.23 branch. Supposedly, there is not a lot of difference between 0.23 and 0.24.

>I get the 'UNRESOLVED DEPENDENCIES' error sometimes, but then on the second try, it goes away. Go figure.

>I'm an eclipse newbie, but with a lot of help, I was able to get it going on the 0.23 branch on Linux. Here's what I did:

>-- from command line pull down the SVN repo:
>export SVNROOT=http://svn.apache.org/repos/asf 
>svn co $SVNROOT/hadoop/common/branches/branch-0.23

>-- just to be safe, I remove my .m2 and .ivy directories from my home directory.

>-- in 'branch-0.23' directory, use maven to build:
>mvn clean install -Pdist -Dtar -DskipTests
>
>-- in 'branch-0.23/hadoop-mapreduce-project' directory, build again:
>mvn clean install assembly:assembly -DskipTests
>
>-- In same directory, build using ant:
>ant -Dresolvers=internal -Dcompile.c+=true -Dcompile.native=true -Dforrest.home=$FORREST_HOME create-c++-configure tar 
>    -- At this point, I do get the 'UNRESOLVED DEPENDENCIES' error. If I do, I just try it again and it works.
>
>-- start eclipse
>-- I use the following maven plugin: http://m2eclipse.sonatype.org/sites/m2e
>-- I go to the project explorer and choose to import a maven project and select the 'branch-0.23' directory. It works for a while (10 minutes or so), and then you can edit, navigate, etc.
>
>NOTE: I build from the command line, not from w/i eclipse.
>
>Hope that helps.
>-Eric
>
>
>
>----- Forwarded Message -----
>>From: Eric Payne <[hidden email]>
>>To: "[hidden email]" <[hidden email]>
>>Sent: Friday, October 7, 2011 8:20 AM
>>Subject: RE: Hadoop on Eclipse
>>
>>
>>
>>-----Original Message-----
>>From: Tim Broberg [mailto:[hidden email]]
>>Sent: Thursday, October 06, 2011 11:00 PM
>>To: [hidden email]
>>Subject: Re: Hadoop on Eclipse
>>
>>After still more puttering, I gave up and just logged this in jira.
>>
>>https://issues.apache.org/jira/browse/HADOOP-7726
>>
>>    - Tim.
>>
>>
>>
>>
>>________________________________
>>From: Prasanth J <[hidden email]>
>>To: [hidden email]; Tim Broberg <[hidden email]>
>>Sent: Thursday, October 6, 2011 11:02 AM
>>Subject: Re: Hadoop on Eclipse
>>
>>Am also facing the exact issue. I think the documentation for setting up
>>hadoop on eclipse is for older versions of hadoop. Now i am using hadoop
>>0.24.0 snapshot and with reference to that the documentation seems outdated.
>>Any help on this regard will be very useful.
>>
>>On Wed, Oct 5, 2011 at 10:34 PM, Tim Broberg <[hidden email]> wrote:
>>
>>> I am having issues similar to Alexandre's.
>>>
>>> The suggestion to run "mvn install -DskipTests -P-cbuild" clears up the
>>> initial problems, but problems ensue...
>>>
>>>  1a - There is no hdfs subdirectory to change into.
>>>  1b - If I instead cd to hadoop-hdfs-project and proceed, I get...
>>>
>>> [tbroberg@f15 hadoop-common]$ cd hadoop-hdfs-project/
>>> [tbroberg@f15 hadoop-hdfs-project]$ ant compile eclipse
>>> Buildfile: build.xml does not exist!
>>> Build failed
>>> [tbroberg@f15 hadoop-hdfs-project]$
>>>
>>>  2 - If I skip hdfs altogether and go to hadoop-mapreduce-project problems
>>> much like the original issues crop up:
>>>
>>> Output is below, debug output is attached.
>>>
>>> Looks like maybe he's failing to expand ${yarn.version}?
>>>
>>> Anybody got any better suggestions than "go out to dinner?"
>>>
>>> Thanks,
>>>    - Tim.
>>>
>>> [tbroberg@f15 hadoop-mapreduce-project]$ ant compile eclipse
>>> Buildfile:
>>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml
>>> clover.setup:
>>> clover.info:
>>>      [echo]
>>>      [echo]      Clover not found. Code coverage reports disabled.
>>>      [echo]
>>> clover:
>>> ivy-download:
>>>      [get] Getting:
>>> http://repo2.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
>>>      [get] To:
>>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivy-2.2.0.jar
>>>      [get] Not modified - so not downloaded
>>> ivy-init-dirs:
>>> ivy-probe-antlib:
>>> ivy-init-antlib:
>>> ivy-init:
>>> [ivy:configure] :: Ivy 2.2.0 - 20100923230623 ::
>>> http://ant.apache.org/ivy/ ::
>>> [ivy:configure] :: loading settings :: file =
>>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivysettings.xml
>>> ivy-resolve-common:
>>> [ivy:resolve]
>>> [ivy:resolve] :: problems summary ::
>>> [ivy:resolve] :::: WARNINGS
>>> [ivy:resolve]  io problem while parsing ivy file:
>>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-20110914.035045-1.pom:
>>> Impossible to load parent for
>>> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-server-common/ivy-0.24.0-SNAPSHOT.xml.original.
>>> Parent=org.apache.hadoop#hadoop-yarn-server;${yarn.version}
>>> [ivy:resolve]          module not found:
>>> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT
>>> [ivy:resolve]  ==== apache-snapshot: tried
>>> [ivy:resolve]
>>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.pom
>>> [ivy:resolve]    -- artifact
>>> org.apache.hadoop#hadoop-yarn-server;${yarn.version}!hadoop-yarn-server.jar:
>>> [ivy:resolve]
>>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.jar
>>> [ivy:resolve]  ==== maven2: tried
>>> [ivy:resolve]
>>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.pom
>>> [ivy:resolve]    -- artifact
>>> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT!hadoop-yarn-server-common.jar:
>>> [ivy:resolve]
>>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.jar
>>> [ivy:resolve]  io problem while parsing ivy file:
>>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-20110914.035126-1.pom:
>>> Impossible to load parent for
>>> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-mapreduce-client-core/ivy-0.24.0-SNAPSHOT.xml.original.
>>> Parent=org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}
>>> [ivy:resolve]          module not found:
>>> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT
>>> [ivy:resolve]  ==== apache-snapshot: tried
>>> [ivy:resolve]
>>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.pom
>>> [ivy:resolve]    -- artifact
>>> org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}!hadoop-mapreduce-client.jar:
>>> [ivy:resolve]
>>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.jar
>>> [ivy:resolve]  ==== maven2: tried
>>> [ivy:resolve]
>>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.pom
>>> [ivy:resolve]    -- artifact
>>> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT!hadoop-mapreduce-client-core.jar:
>>> [ivy:resolve]
>>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.jar
>>> [ivy:resolve]  io problem while parsing ivy file:
>>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-20110914.034958-1.pom:
>>> Impossible to load parent for
>>> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-common/ivy-0.24.0-SNAPSHOT.xml.original.
>>> Parent=org.apache.hadoop#hadoop-yarn;${yarn.version}
>>> [ivy:resolve]          module not found:
>>> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT
>>> [ivy:resolve]  ==== apache-snapshot: tried
>>> [ivy:resolve]
>>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.pom
>>> [ivy:resolve]    -- artifact
>>> org.apache.hadoop#hadoop-yarn;${yarn.version}!hadoop-yarn.jar:
>>> [ivy:resolve]
>>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.jar
>>> [ivy:resolve]  ==== maven2: tried
>>> [ivy:resolve]
>>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.pom
>>> [ivy:resolve]    -- artifact
>>> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT!hadoop-yarn-common.jar:
>>> [ivy:resolve]
>>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.jar
>>> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
>>> [ivy:resolve]          ::          UNRESOLVED DEPENDENCIES        ::
>>> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
>>> [ivy:resolve]          ::
>>> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT: not found
>>> [ivy:resolve]          ::
>>> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT: not found
>>> [ivy:resolve]          ::
>>> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT: not found
>>> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
>>> [ivy:resolve]
>>> [ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
>>> BUILD FAILED
>>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml:2223:
>>> impossible to resolve dependencies:
>>>        resolve failed - see output for details
>>> Total time: 23 seconds
>>> [tbroberg@f15 hadoop-mapreduce-project]$
>>>
>>>
>>
>>
>>
>
>
Loading...