Implicit routing changes to Composite while re-deploy configuration changes

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Implicit routing changes to Composite while re-deploy configuration changes

Ketan Thanki
Hi,

I have implemented implicit routing with below configuration.
Created one default collection manually 'AMS_Config' which contains configurations files  schema,solrconfig etc.

Using 'AMS_Config' I have created 2 collections model,workset respectively with below command which created 2 shard for each collection containing 2 node for each shard where nodes are each solr instance where collection created.

Command: /admin/collections?action=CREATE&name=model&replicationFactor=2&router.name=implicit&router.field=dr&shards=shard1,shard2&maxShardsPerNode=2&collection.configName=AMS_Config

Collection Detail:
Model = Shard1,Shard2
Shard1 = node1,node2[leader]
Shard2 =node1[leader],node2

Configuration in admin UI on solr for model collection:
Shard count:2
configName:AMS_Config
replicationFactor:2
maxShardsPerNode:2
router:implicit
autoAddReplicas:false

after this I have index document to particular shard using set value (router.field) dr = shard1

Issue:  After indexing the document made changes in schema files and redeploy using below command  for set latest configs
zkcli.bat -cmd upconfig -confdir ../../solr/AMS_Config/conf -confname AMS_Config -z <zk Ips>

It will changes the router value implicit to compositeId and now my document are index across all shard so why this should happens.How to avoid this.

Please do needful.

Regards,
Ketan.

[CC Award Winners!]