Lucene stops working

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Lucene stops working

egorlex
Hi, I am new in Lucene and i have strange problem. Lucene  stops working
without any errors after some time. It works fine for 1 day or several
hours. I did some investigation and found that 5 IndexReaders are opened in
the search method, but they do not close when exiting the method..can it be
a cause? Do I need to close the IndexReader after use?
(Lucene version 7.3.0)

I would be very grateful for the help.



--
Sent from: http://lucene.472066.n3.nabble.com/Lucene-Java-Users-f532864.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Lucene stops working

Erick Erickson
Is this custom code? What method? Can you show us a sample?

There's not enough information here to say much.
On Fri, Nov 2, 2018 at 7:38 AM egorlex <[hidden email]> wrote:

>
> Hi, I am new in Lucene and i have strange problem. Lucene  stops working
> without any errors after some time. It works fine for 1 day or several
> hours. I did some investigation and found that 5 IndexReaders are opened in
> the search method, but they do not close when exiting the method..can it be
> a cause? Do I need to close the IndexReader after use?
> (Lucene version 7.3.0)
>
> I would be very grateful for the help.
>
>
>
> --
> Sent from: http://lucene.472066.n3.nabble.com/Lucene-Java-Users-f532864.html
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]