Moving index from stand-alone Solr 6.6.0 to 3 node Solr Cloud 6.6.0 with Zookeeper

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Moving index from stand-alone Solr 6.6.0 to 3 node Solr Cloud 6.6.0 with Zookeeper

kevinc
Hi all,

I'm sure I've done this before but this seems to be falling down a bit and I was wondering if anyone had any helpful ideas.
I have a large index (51GB) that exists in a 4 node Solr Cloud instance. The reprocessing for this takes a long time and so we normally reindex on a secondary cluster and swap them out.
I have reindexed to a single Solr 6.6.0 index and spun up a new 3 node Solr cluster with 1 shard and replication factor of 3.
I want to copy over the index and have it replicate to the rest of the cluster. I have taken a copy of the data directory from the reprocessed core and copied it into the leader's data directory. This shows up correctly as having a 51GB index and the documents are searchable.
I have tried the following curl commands to kick off replication:
curl http://localhost:8983/solr/solrCollection1/update -H "Content-Type: text/xml" --data-binary @test.xml
curl http://localhost:8983/solr/solrCollection1/update?stream.body=%3Ccommit/%3E

I've tried this a few times and had a few different results:
The index gets set to 0 and has the single record I commit

A timed index gets created (index.201904082111232) and index.properties then points to that

I had an issue with IndexWriter being closed

The index stays consistent and doesn't replicate

I've tried copying the index to both the leader and one other node to see if that helps but I'm faced with similar results as above.

Does anyone have any advice to how I can get this index moved and replicated onto this new cluster?
Thanks a lot!
Kevin.