Re: Hadoop-trunk-Commit failing due to libprotoc version

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Hadoop-trunk-Commit failing due to libprotoc version

Aaron Fabbri
This appears to be happening again, e.g.
https://builds.apache.org/job/Hadoop-trunk-Commit/14050/



On Mon, Mar 26, 2018 at 3:31 PM, Xiaoyu Yao <[hidden email]> wrote:

> Could this caused by the docker base image changes? As shown in the error
> message, we are still expecting protobuf v2.5.0 but the one in the docker
> image is changed to libprotoc 2.6.1.
>
> In hadoop/dev-support/docker/Dockerfile, we have the following lines to
> install libprotoc without specifying version like below.
>
> RUN apt-get -q update && apt-get -q install -y  libprotoc-dev
>
> I think this can be fixed by specifying the version like:
>
> RUN apt-get -q update && apt-get -q install -y  libprotoc-dev=2.5.0
>
> ´╗┐On 3/26/18, 2:37 PM, "Sean Mackrory" <[hidden email]> wrote:
>
>     Most of the commit jobs in the last few hours have failed. I would
> suspect
>     a change in the machines or images used to run the job. Who has access
> to
>     confirm such a change and perhaps correct it?
>
>     [ERROR] Failed to execute goal
>     org.apache.hadoop:hadoop-maven-plugins:3.2.0-SNAPSHOT:protoc
>     (compile-protoc) on project hadoop-common:
>     org.apache.maven.plugin.MojoExecutionException: protoc version is
>     'libprotoc 2.6.1', expected version is '2.5.0' -> [Help 1]
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>