Schema version question

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Schema version question

Robert Purdy
I was wondering if anyone could help me, I just completed a full index of my data (about 4 million documents) and noticed that when I was first setting up the schema I set the version number to "1.2" thinking that solr 1.2 uses schema version 1.2... ugh... so I am wondering if I can just set the schema to 1.1 without having to rebuild the full index? I ask because I am hoping that given an invalid schema version number, that version 1.0 is not used by default and all my fields are now mulitvalued. Any help would be greatly appreciated. Thanks in advance
Reply | Threaded
Open this post in threaded view
|

Re: Schema version question

Yonik Seeley-2
On 9/28/07, Robert Purdy <[hidden email]> wrote:
> I was wondering if anyone could help me, I just completed a full index of my
> data (about 4 million documents) and noticed that when I was first setting
> up the schema I set the version number to "1.2" thinking that solr 1.2 uses
> schema version 1.2... ugh... so I am wondering if I can just set the schema
> to 1.1 without having to rebuild the full index? I ask because I am hoping
> that given an invalid schema version number, that version 1.0 is not used by
> default and all my fields are now mulitvalued. Any help would be greatly
> appreciated. Thanks in advance

Yes, it should be OK to set it back to 1.1 w/o reindexing.
The index format does not differentiate between single and
multi-valued fields so you should be fine there.

-Yonik
Reply | Threaded
Open this post in threaded view
|

Re: Schema version question

Robert Purdy
In reply to this post by Robert Purdy
Thanks Yonik I have not seen any issues with doing that beside some unrelated perfomance issues I just posted in another thread.

Robert.



Robert Purdy wrote
I was wondering if anyone could help me, I just completed a full index of my data (about 4 million documents) and noticed that when I was first setting up the schema I set the version number to "1.2" thinking that solr 1.2 uses schema version 1.2... ugh... so I am wondering if I can just set the schema to 1.1 without having to rebuild the full index? I ask because I am hoping that given an invalid schema version number, that version 1.0 is not used by default and all my fields are now mulitvalued. Any help would be greatly appreciated. Thanks in advance