SolrQuery Highlight Problem - Not working for text

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

SolrQuery Highlight Problem - Not working for text

THADC
Hi, we recently upgraded from solr 4.7  to solr 7.3. One of the things we had
to change for this was the value of text_general type in schema.xml going
from "text" to "_text_". Most everywhere things are working fine, except
that highlight info is no showing up in our search results performing
searches against text_general type. Here is a sample query:

                                SolrQuery query = new
SolrQuery().setHighlight(true).setParam("hl.simple.pre", highlightPre)
                                                               
.setParam("hl.simple.post", highlightPost).setParam("hl.fl",
highlightFieldStr.toString())
                                                               
.setParam("hl.requireFieldMatch", "true").setParam("hl.snippets",
                                                               
"10").setParam("rows", rows)
                                                               
.setParam("start", start);

The value of hl.fl we have for text_general searches is "_text_" but
highlighted values always return empty for this query in the query response
when calling solr server from CloudSolrClient client. Is there something I
have overlooked in the conversion from 4.7 to 7.3? The query results
themselves are good, its just the highlight details are missing. Maybe in
some solr configuration highlighting still is looking for "text"?

Any ideas appreciated. Thanks!




--
Sent from: http://lucene.472066.n3.nabble.com/Solr-User-f472068.html
Reply | Threaded
Open this post in threaded view
|

Re: SolrQuery Highlight Problem - Not working for text

Erick Erickson
Does your _text_ field have stored="true"? That's still a requirement
for highlighting.

the _default managed schema has _text_ as stored="false", so if you
just worked from that.....

Best,
Erick

On Thu, Aug 2, 2018 at 10:19 AM, THADC
<[hidden email]> wrote:

> Hi, we recently upgraded from solr 4.7  to solr 7.3. One of the things we had
> to change for this was the value of text_general type in schema.xml going
> from "text" to "_text_". Most everywhere things are working fine, except
> that highlight info is no showing up in our search results performing
> searches against text_general type. Here is a sample query:
>
>                                 SolrQuery query = new
> SolrQuery().setHighlight(true).setParam("hl.simple.pre", highlightPre)
>
> .setParam("hl.simple.post", highlightPost).setParam("hl.fl",
> highlightFieldStr.toString())
>
> .setParam("hl.requireFieldMatch", "true").setParam("hl.snippets",
>
> "10").setParam("rows", rows)
>
> .setParam("start", start);
>
> The value of hl.fl we have for text_general searches is "_text_" but
> highlighted values always return empty for this query in the query response
> when calling solr server from CloudSolrClient client. Is there something I
> have overlooked in the conversion from 4.7 to 7.3? The query results
> themselves are good, its just the highlight details are missing. Maybe in
> some solr configuration highlighting still is looking for "text"?
>
> Any ideas appreciated. Thanks!
>
>
>
>
> --
> Sent from: http://lucene.472066.n3.nabble.com/Solr-User-f472068.html
Reply | Threaded
Open this post in threaded view
|

Re: SolrQuery Highlight Problem - Not working for text

THADC
Thanks Erick, that indeed was the problem. All good now!



--
Sent from: http://lucene.472066.n3.nabble.com/Solr-User-f472068.html