ant eclipse on branch_6_4

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

ant eclipse on branch_6_4

rgummadi
I cloned lucene-solr git and working on git branch branch_6_4. I am trying to
make this eclipse compatible.
So I "ant eclipse" from the root folder. I am getting the below error. Can
some one suggest a resolution.

[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]          ::          UNRESOLVED DEPENDENCIES         ::
[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]          :: junit#junit;4.10: not found
[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]
[ivy:retrieve] :::: ERRORS
[ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
[ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
[ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
[ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
[ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
[ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
[ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
[ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
[ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
[ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
[ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
[ivy:retrieve]
[ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS






--
Sent from: http://lucene.472066.n3.nabble.com/Solr-User-f472068.html
Reply | Threaded
Open this post in threaded view
|

Re: ant eclipse on branch_6_4

sarowe
Hi,

You probably have a stale Ivy lock file in ~/.ivy2/cache/, very likely orphaned as a result of manually interrupting the Lucene/Solr build, e.g. via Ctrl-C.

You can find it via e.g.: find ~/.ivy2/cache -name ‘*.lck’

Once you have found the stale lock file, manually deleting it should allow the build to start working again.

FYI, LUCENE-6144[1] upgraded Lucene/Solr’s Ivy dependency to 2.4.0, and as part of that upgrade, switched the build’s lock strategy[2] from “artifact-lock” to “artifact-lock-nio”.  As a result, in branch_5_5, branch_6_6, branch_7* and master, ‘*.lck’ files are expected to be present all the time in the Ivy cache, and their presence will not cause the build to fail.  More info on IVY-1489[3].

[1] https://issues.apache.org/jira/browse/LUCENE-6144
[2] http://ant.apache.org/ivy/history/latest-milestone/settings/lock-strategies.html
[3] https://issues.apache.org/jira/browse/IVY-1489

--
Steve
www.lucidworks.com

> On Apr 12, 2018, at 10:34 AM, rgummadi <[hidden email]> wrote:
>
> I cloned lucene-solr git and working on git branch branch_6_4. I am trying to
> make this eclipse compatible.
> So I "ant eclipse" from the root folder. I am getting the below error. Can
> some one suggest a resolution.
>
> [ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:retrieve]          ::          UNRESOLVED DEPENDENCIES         ::
> [ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:retrieve]          :: junit#junit;4.10: not found
> [ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:retrieve]
> [ivy:retrieve] :::: ERRORS
> [ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
> [ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
> [ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
> [ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
> [ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
> [ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
> [ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
> [ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
> [ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
> [ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
> [ivy:retrieve]  impossible to acquire lock for junit#junit;4.10
> [ivy:retrieve]
> [ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
>
>
>
>
>
>
> --
> Sent from: http://lucene.472066.n3.nabble.com/Solr-User-f472068.html

Reply | Threaded
Open this post in threaded view
|

Re: ant eclipse on branch_6_4

rgummadi
Thanks Steve. I will look into the cache.



--
Sent from: http://lucene.472066.n3.nabble.com/Solr-User-f472068.html