java.lang.NoClassDefFoundError Nutch 0.9

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

java.lang.NoClassDefFoundError Nutch 0.9

Rajasekar Karthik
Hi,

I got nutch from svn tags - release0.9 - but can't get rid of this problem. I did
ant compile
ant jar
ant war
All of them build successfully with different versions of ant - 1.6.5 and 1.7.0

When running "nutch crawl" - I get
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/nutch/crawl/Crawl

Even tried some solutions as explained in the forum - changing ant versions, adding classpath(doesn't matter - nutch script overrides ) - but none of them worked.

How do I get rid of this problem?

Thanks,
Karthik
Reply | Threaded
Open this post in threaded view
|

Re: java.lang.NoClassDefFoundError Nutch 0.9

chrismattmann
Hi Karthik,

 The default ant target for Nutch is "job".

 You can do one of the following:

 type 'ant clean' first, to remove your working class information
 type 'ant' to call the default target ('job'), or explicitly call 'ant job'

 That should fix your issue.

Thanks!

Cheers,
  Chris



On 11/8/07 12:12 PM, "karthik085" <[hidden email]> wrote:

>
> Hi,
>
> I got nutch from svn tags - release0.9 - but can't get rid of this problem.
> I did
> ant compile
> ant jar
> ant war
> All of them build successfully with different versions of ant - 1.6.5 and
> 1.7.0
>
> When running "nutch crawl" - I get
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/nutch/crawl/Crawl
>
> Even tried some solutions as explained in the forum - changing ant versions,
> adding classpath(doesn't matter - nutch script overrides ) - but none of
> them worked.
>
> How do I get rid of this problem?
>
> Thanks,
> Karthik

______________________________________________
Chris Mattmann, Ph.D.
[hidden email]
Cognizant Development Engineer
Early Detection Research Network Project
_________________________________________________
Jet Propulsion Laboratory            Pasadena, CA
Office: 171-266B                     Mailstop:  171-246
_______________________________________________________

Disclaimer:  The opinions presented within are my own and do not reflect
those of either NASA, JPL, or the California Institute of Technology.


Reply | Threaded
Open this post in threaded view
|

Re: java.lang.NoClassDefFoundError Nutch 0.9

Sami Siren-2
In reply to this post by Rajasekar Karthik
karthik085 wrote:
> Hi,
>
> I got nutch from svn tags - release0.9 - but can't get rid of this problem.
> I did
> ant compile
> ant jar
> ant war
> All of them build successfully with different versions of ant - 1.6.5 and
> 1.7.0

do "ant job"

--
 Sami Siren
Reply | Threaded
Open this post in threaded view
|

Re: java.lang.NoClassDefFoundError Nutch 0.9

Rajasekar Karthik
In reply to this post by chrismattmann
Ah, that works....I can run the command and it works. But, it does not build jar and war file? unless I say
ant jar
ant war

The war file is needed for tomcat - so I have to do that anyway

I am little confused over what job does. I understand
ant jar - creates a jar file. Then,
job - used for just compiling??? It does create a nutch-0.9.job

Now, I can run nutch without creating a jar file....which I also don't understand. Isn't a jar needed for running nutch?

Thanks for the quick reply.


Chris Mattmann wrote
Hi Karthik,

 The default ant target for Nutch is "job".

 You can do one of the following:

 type 'ant clean' first, to remove your working class information
 type 'ant' to call the default target ('job'), or explicitly call 'ant job'

 That should fix your issue.

Thanks!

Cheers,
  Chris



On 11/8/07 12:12 PM, "karthik085" <karthik085@gmail.com> wrote:

>
> Hi,
>
> I got nutch from svn tags - release0.9 - but can't get rid of this problem.
> I did
> ant compile
> ant jar
> ant war
> All of them build successfully with different versions of ant - 1.6.5 and
> 1.7.0
>
> When running "nutch crawl" - I get
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/nutch/crawl/Crawl
>
> Even tried some solutions as explained in the forum - changing ant versions,
> adding classpath(doesn't matter - nutch script overrides ) - but none of
> them worked.
>
> How do I get rid of this problem?
>
> Thanks,
> Karthik

______________________________________________
Chris Mattmann, Ph.D.
Chris.Mattmann@jpl.nasa.gov
Cognizant Development Engineer
Early Detection Research Network Project
_________________________________________________
Jet Propulsion Laboratory            Pasadena, CA
Office: 171-266B                     Mailstop:  171-246
_______________________________________________________

Disclaimer:  The opinions presented within are my own and do not reflect
those of either NASA, JPL, or the California Institute of Technology.