[jira] [Comment Edited] (SOLR-12367) When adding a model referencing a non-existent feature the error message is very ambiguous

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Comment Edited] (SOLR-12367) When adding a model referencing a non-existent feature the error message is very ambiguous

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/SOLR-12367?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16646719#comment-16646719 ]

Kamuela Lau edited comment on SOLR-12367 at 10/11/18 4:26 PM:
--------------------------------------------------------------

A similar ClassCastException may show up for other LTRScoringModels (such as entering an int/long in matrix, ), such as NeuralNetworkModel (in particular, thinking of matrix/bias values for layers). The ambiguous message for CCE will only change for LinearModel as of right now.


was (Author: kamulau):
A similar ClassCastException may show up for other LTRScoringModels (such as entering an int/long in matrix, ), such as NeuralNetworkModel (in particular, thinking of matrix/bias values for layers). Current patch will not change the ambiguous message for NeuralNetworkModel...

> When adding a model referencing a non-existent feature the error message is very ambiguous
> ------------------------------------------------------------------------------------------
>
>                 Key: SOLR-12367
>                 URL: https://issues.apache.org/jira/browse/SOLR-12367
>             Project: Solr
>          Issue Type: Improvement
>      Security Level: Public(Default Security Level. Issues are Public)
>          Components: contrib - LTR
>    Affects Versions: 7.3.1
>            Reporter: Georg Sorst
>            Priority: Minor
>         Attachments: SOLR-12367.patch, SOLR-12367.patch, SOLR-12367.patch
>
>
> When adding a model that references a non-existent feature a very ambiguous error message is thrown, something like "Model type does not exist org.apache.solr.ltr.model.{{LinearModel}}".
>  
> To reproduce, do not add any features and just add a model, for example by doing this:
>  
> {{curl -XPUT 'http://localhost:8983/solr/gettingstarted/schema/model-store' --data-binary '}}
> {
> {{  "class": "org.apache.solr.ltr.model.LinearModel",}}
> {{  "name": "myModel",}}
> {{  "features": [ \{"name": "whatever" }],}}
> {{  "params": {"weights": {"whatever": 1.0}}}}
> {{}' -H 'Content-type:application/json'}}
>  
> The resulting error message "Model type does not exist {{org.apache.solr.ltr.model.LinearModel" is extremely misleading and cost me a while to figure out the actual cause.}}
>  
> A more suitable error message should probably indicate the name of the missing feature that the model is trying to reference.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]