[jira] Commented: (HADOOP-371) ant tar should package contrib jars

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] Commented: (HADOOP-371) ant tar should package contrib jars

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/HADOOP-371?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12462111 ]

Hadoop QA commented on HADOOP-371:
----------------------------------

-1, because the patch command could not apply the latest attachment (http://issues.apache.org/jira/secure/attachment/12348237/371.patch) as a patch to trunk revision r492365. Please note that this message is automatically generated and may represent a problem with the automation system and not the patch.

> ant tar should package contrib jars
> -----------------------------------
>
>                 Key: HADOOP-371
>                 URL: https://issues.apache.org/jira/browse/HADOOP-371
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: build
>    Affects Versions: 0.9.2
>            Reporter: Michel Tourn
>         Assigned To: Nigel Daley
>         Attachments: 371.patch, build.tarcontrib.patch, contribbuild.patch
>
>
> From Hadoop-356:
> >I note that the contrib packages are not included in distributions (the "tar" target).  
> >They probably should be.  Michel, would you like to modify "tar" to include the contrib code?  
> >This should be done in a separate bug.
> OK.
> This packaging is done in target deploy-contrib.
> So I can just add a dependency to the top-level tar target:
> <!-- Make release tarball(s)                                               -->
> <target name="tar" depends="package, deploy-contrib">

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira