[jira] [Commented] (NUTCH-2375) Upgrade the code base from org.apache.hadoop.mapred to org.apache.hadoop.mapreduce

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] [Commented] (NUTCH-2375) Upgrade the code base from org.apache.hadoop.mapred to org.apache.hadoop.mapreduce

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/NUTCH-2375?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16079395#comment-16079395 ]

ASF GitHub Bot commented on NUTCH-2375:
---------------------------------------

lewismc commented on issue #188: NUTCH-2375 Upgrade the code base from org.apache.hadoop.mapred to org.apache.hadoop.mapreduce
URL: https://github.com/apache/nutch/pull/188#issuecomment-313890314
 
 
   @jnioche @sebastian-nagel @chrismattmann @jorgelbg and rest of team, would it be preferred for all Mapper and Reducer functions to be extracted from individual Job's which ```extends Configured implements Tool``` into a ```mapper``` and ```reducer``` package respectively or is it fine to retain them as nested classes within the Job they belong to? Thanks for any input.
 
----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
[hidden email]


> Upgrade the code base from org.apache.hadoop.mapred to org.apache.hadoop.mapreduce
> ----------------------------------------------------------------------------------
>
>                 Key: NUTCH-2375
>                 URL: https://issues.apache.org/jira/browse/NUTCH-2375
>             Project: Nutch
>          Issue Type: Improvement
>          Components: deployment
>            Reporter: Omkar Reddy
>
> Nutch is still using the deprecated org.apache.hadoop.mapred dependency which has been deprecated. It need to be updated to org.apache.hadoop.mapreduce dependency.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)
Loading...