[jira] [Commented] (NUTCH-2633) Fix deprecation warnings when building Nutch master branch under JDK 10.0.2+13

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (NUTCH-2633) Fix deprecation warnings when building Nutch master branch under JDK 10.0.2+13

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/NUTCH-2633?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16576958#comment-16576958 ]

ASF GitHub Bot commented on NUTCH-2633:
---------------------------------------

sebastian-nagel commented on issue #374: NUTCH-2633 Fix deprecation warnings when building Nutch master branch…
URL: https://github.com/apache/nutch/pull/374#issuecomment-412231476
 
 
   Work to make Hadoop ready for Java 9/10/11 is still ongoing ([HADOOP-11123](https://issues.apache.org/jira/browse/HADOOP-11123)). After that and when the Hadoop distributions integrated support for Java 9, users need to upgrade their Hadoop clusters. Just, as an estimate, we probably have to make sure that Nutch runs and compiles on Java 8 for the next 2-3 years. For this time I would prefer to keep the javac.version as is. It avoids that a patch introduces usage of new Java features which do not work on Java 8.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
[hidden email]


> Fix deprecation warnings when building Nutch master branch under JDK 10.0.2+13
> ------------------------------------------------------------------------------
>
>                 Key: NUTCH-2633
>                 URL: https://issues.apache.org/jira/browse/NUTCH-2633
>             Project: Nutch
>          Issue Type: Improvement
>          Components: build
>    Affects Versions: 1.16
>         Environment: java version "10.0.2" 2018-07-17
> Java(TM) SE Runtime Environment 18.3 (build 10.0.2+13)
> Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.2+13, mixed mode)
> Nutch master 01c5d6ea17d7b60d25d4e65462b2a654f10680c3 (Thu Jul 26 14:55:38 2018 +0200)
>            Reporter: Lewis John McGibbney
>            Assignee: Lewis John McGibbney
>            Priority: Major
>             Fix For: 1.16
>
>
> I just got around to making a dev upgrade to >= JDK 10.
> When building master using environment JDK
> I get several compile time deprecations which are reflected in the attached build log.
> Additionally, I get some issues with Ivy... see below
> {code}
> WARNING: An illegal reflective access operation has occurred
> WARNING: Illegal reflective access by org.apache.ivy.util.url.IvyAuthenticator (file:/Users/lmcgibbn/.ant/lib/ivy-2.3.0.jar) to field java.net.Authenticator.theAuthenticator
> WARNING: Please consider reporting this to the maintainers of org.apache.ivy.util.url.IvyAuthenticator
> WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
> WARNING: All illegal access operations will be denied in a future release
> [ivy:resolve] :: problems summary ::
> [ivy:resolve] :::: ERRORS
> [ivy:resolve] unknown resolver null
> [ivy:resolve] unknown resolver null
> [ivy:resolve] unknown resolver null
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)