[jira] [Commented] (SOLR-11624) _default configset overwrites a a configset if collection.configName isn't specified even if a confiset of the same name already exists.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (SOLR-11624) _default configset overwrites a a configset if collection.configName isn't specified even if a confiset of the same name already exists.

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/SOLR-11624?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16251619#comment-16251619 ]

Steve Rowe commented on SOLR-11624:
-----------------------------------

bq. User manually creates a configset prefixed by {{SOLR_CONFIGSET}} 'cause "Hey, that's the convention apparently" then drops the associated collection

Probably better to use something like {{collection.AUTOMATIC_COPY_OF_DEFAULT_CONFIGSET}} (suffix probably better than prefix imho), or less wordily-ish: {{collection.AUTO_DEFAULT_COPY}}.

> _default configset overwrites a a configset if collection.configName isn't specified even if a confiset of the same name already exists.
> ----------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: SOLR-11624
>                 URL: https://issues.apache.org/jira/browse/SOLR-11624
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public)
>    Affects Versions: 7.2
>            Reporter: Erick Erickson
>            Assignee: Erick Erickson
>         Attachments: SOLR-11624.patch
>
>
> Looks like a problem that crept in when we changed the _default configset stuff.
> setup:
> upload a configset named "wiki"
> collections?action=CREATE&name=wiki&.....
> My custom configset "wiki" gets overwritten by _default and then used by the "wiki" collection.
> Assigning to myself only because it really needs to be fixed IMO and I don't want to lose track of it. Anyone else please feel free to take it.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]