[jira] [Commented] (SOLR-11853) Solr installer: Make check for used tool "service" compatible with SuSE Linux like OpenSuse or SLES

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (SOLR-11853) Solr installer: Make check for used tool "service" compatible with SuSE Linux like OpenSuse or SLES

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/SOLR-11853?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16325426#comment-16325426 ]

ASF GitHub Bot commented on SOLR-11853:
---------------------------------------

GitHub user Mandalka opened a pull request:

    https://github.com/apache/lucene-solr/pull/305

    SOLR-11853: Make check for used tool "service" compatible with SuSE Linux

    On current SuSE Linux releases like SLES or OpenSuSE the Solr installer stops with the error message "Script requires the 'service' command".
   
    This happens because before installation the installer checks if the used command "service" exists by its option "service --version".
   
    The command line option "--version" doesn't exist for "service" on current SuSE Linux stable releases.
   
    Since the command "service" is there and has an option "--help", this option can be used as additional fallback.
   
    So in the pull request i extended the check with "service --help" as second check / fallback before printing this error and exiting.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/Mandalka/lucene-solr master

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/lucene-solr/pull/305.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #305
   
----
commit 0aa573740b55027192440fc5997a93945ca9b9b3
Author: Markus Mandalka <github@...>
Date:   2018-01-14T02:14:47Z

    Make check for used tool 'service' compatible with SuSE Linux like OpenSuse or SLES

----


> Solr installer: Make check for used tool "service" compatible with SuSE Linux like OpenSuse or SLES
> ---------------------------------------------------------------------------------------------------
>
>                 Key: SOLR-11853
>                 URL: https://issues.apache.org/jira/browse/SOLR-11853
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public)
>    Affects Versions: 7.2
>         Environment: SuSE Linux (SLES & OpenSuSE)
>            Reporter: Markus Mandalka
>            Priority: Minor
>              Labels: github-import, newbie
>             Fix For: master (8.0), 7.3, 7.2.2
>
>
> On current SuSE Linux releases like SLES or OpenSuSE the Solr installer stops with the error message "Script requires the 'service' command".
> This happens because before installation the installer checks if the used command "service" exists by its option "service --version".
> The command line option "--version" doesn't exist for "service" on current SuSE Linux stable releases.
> Since the command "service" is there and has an option "--help", this option can be used as additional fallback.
> So in the pull request i extended the check with "service --help" as second check / fallback before printing this error and exiting.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]