[jira] [Created] (HADOOP-14330) Kerby breaks multiple SPN support

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] [Created] (HADOOP-14330) Kerby breaks multiple SPN support

JIRA jira@apache.org
Wei-Chiu Chuang created HADOOP-14330:
----------------------------------------

             Summary: Kerby breaks multiple SPN support
                 Key: HADOOP-14330
                 URL: https://issues.apache.org/jira/browse/HADOOP-14330
             Project: Hadoop Common
          Issue Type: Bug
          Components: security
    Affects Versions: 3.0.0-alpha1
            Reporter: Wei-Chiu Chuang
            Priority: Blocker


Hadoop 3 currently pulls in Kerby 1.0.0 RC2. Via downstream application tests, we found a bug in this version that breaks multiple SPN support implemented in HADOOP-10158, because Kerby can't read keytabs generated by some applications, and it gets malformed SPNs. The bug is fixed by DIRKRB-621, targeting Kerby 1.0.0 GA release.

I also verified this regression is fixed in latest Kerby, by having my local Hadoop repo depend on my local 1.0.0-RC3-SNAPSHOT Kerby artifacts. So the easiest fix is to wait for a Kerby 1.0 RC3/GA, and update Hadoop pom.xml to depend on Kerby 1.0 GA.

The planned alpha 3 release is approaching, so I don't anticipate this can get resolved by then. Beta1 is probably a more realistic target version.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...