[jira] Created: (LUCENE-2530) rename docsEnum.getBulkResult() to make its role clearer

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (LUCENE-2530) rename docsEnum.getBulkResult() to make its role clearer

JIRA jira@apache.org
rename docsEnum.getBulkResult() to make its role clearer
--------------------------------------------------------

                 Key: LUCENE-2530
                 URL: https://issues.apache.org/jira/browse/LUCENE-2530
             Project: Lucene - Java
          Issue Type: Bug
          Components: Index
    Affects Versions: 4.0
            Reporter: Andi Vajda
            Assignee: Michael McCandless
            Priority: Minor


Before docsEnum.read() can be called a BulkResult instance must be allocated for it (it == the default implementation of that method).
This is done by calling docsEnum.getBulkResult(). Failure to call this method before read() is called results in a NullPointerException.
It is somewhat counterintuitive to "get" the results of an operation before calling said operation.
Maybe this method should be renamed to something more definite-sounding like obtainBulkResult() or prepareBulkResult() ?

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[jira] Commented: (LUCENE-2530) rename docsEnum.getBulkResult() to make its role clearer

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/LUCENE-2530?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12886676#action_12886676 ]

Michael McCandless commented on LUCENE-2530:
--------------------------------------------

I agree, we should rename it, to make it clear it's mandatory that you call it.  I like prepareBulkResult.

> rename docsEnum.getBulkResult() to make its role clearer
> --------------------------------------------------------
>
>                 Key: LUCENE-2530
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2530
>             Project: Lucene - Java
>          Issue Type: Bug
>          Components: Index
>    Affects Versions: 4.0
>            Reporter: Andi Vajda
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 4.0
>
>
> Before docsEnum.read() can be called a BulkResult instance must be allocated for it (it == the default implementation of that method).
> This is done by calling docsEnum.getBulkResult(). Failure to call this method before read() is called results in a NullPointerException.
> It is somewhat counterintuitive to "get" the results of an operation before calling said operation.
> Maybe this method should be renamed to something more definite-sounding like obtainBulkResult() or prepareBulkResult() ?

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (LUCENE-2530) rename docsEnum.getBulkResult() to make its role clearer

JIRA jira@apache.org
In reply to this post by JIRA jira@apache.org

     [ https://issues.apache.org/jira/browse/LUCENE-2530?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Michael McCandless updated LUCENE-2530:
---------------------------------------

    Fix Version/s: 4.0

> rename docsEnum.getBulkResult() to make its role clearer
> --------------------------------------------------------
>
>                 Key: LUCENE-2530
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2530
>             Project: Lucene - Java
>          Issue Type: Bug
>          Components: Index
>    Affects Versions: 4.0
>            Reporter: Andi Vajda
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 4.0
>
>
> Before docsEnum.read() can be called a BulkResult instance must be allocated for it (it == the default implementation of that method).
> This is done by calling docsEnum.getBulkResult(). Failure to call this method before read() is called results in a NullPointerException.
> It is somewhat counterintuitive to "get" the results of an operation before calling said operation.
> Maybe this method should be renamed to something more definite-sounding like obtainBulkResult() or prepareBulkResult() ?

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]