[jira] Created: (TIKA-217) TikaConfig fails when a parser can't be loaded due to an Error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (TIKA-217) TikaConfig fails when a parser can't be loaded due to an Error

JIRA jira@apache.org
TikaConfig fails when a parser can't be loaded due to an Error
--------------------------------------------------------------

                 Key: TIKA-217
                 URL: https://issues.apache.org/jira/browse/TIKA-217
             Project: Tika
          Issue Type: Bug
          Components: config
    Affects Versions: 0.3
            Reporter: Jukka Zitting
            Priority: Minor


When running in Java 1.4, some of the Parser classes can't be loaded due to dependencies (POI, etc.) that require Java 5 or higher. These cases throw UnsupportedClassVersionErrors or somilar Throwables that aren't caught by the current "catch (Exception e)" clause. We should catch all Throwables there.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Resolved: (TIKA-217) TikaConfig fails when a parser can't be loaded due to an Error

JIRA jira@apache.org

     [ https://issues.apache.org/jira/browse/TIKA-217?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jukka Zitting resolved TIKA-217.
--------------------------------

       Resolution: Fixed
    Fix Version/s: 0.4
         Assignee: Jukka Zitting

Fixed in revision 763234.

> TikaConfig fails when a parser can't be loaded due to an Error
> --------------------------------------------------------------
>
>                 Key: TIKA-217
>                 URL: https://issues.apache.org/jira/browse/TIKA-217
>             Project: Tika
>          Issue Type: Bug
>          Components: config
>    Affects Versions: 0.3
>            Reporter: Jukka Zitting
>            Assignee: Jukka Zitting
>            Priority: Minor
>             Fix For: 0.4
>
>
> When running in Java 1.4, some of the Parser classes can't be loaded due to dependencies (POI, etc.) that require Java 5 or higher. These cases throw UnsupportedClassVersionErrors or somilar Throwables that aren't caught by the current "catch (Exception e)" clause. We should catch all Throwables there.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.