Quantcast

solr error after relacing schema.xml

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

solr error after relacing schema.xml

BillB1951
Trouble getting solr and Haystack working together.  I have solar
working (can get admin screen and query test data).  I then create my
search_indexes.py (per getting started example, I also have run syndb
and added data to the Notes table).  I run manage.py
build_solar_schema, it generates XML for the schema.xml file. I
replace the contents of the schema.xml with the new content.  I
restart the solr server, then try to start admin  but get following
error>

HTTP ERROR 500

Problem accessing /solr/admin/. Reason:

    Severe errors in solr configuration.

Check your log files for more detailed information on what may be
wrong.

If you want solr to continue after configuration errors, change:

 <abortOnConfigurationError>false</abortOnConfigurationError>

in solr.xml

-------------------------------------------------------------
org.apache.solr.common.SolrException: No cores were created, please
check the logs for errors

what am I doing wrong.
BillB1951
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: solr error after relacing schema.xml

Mark Miller-3
Try looking at the logs.

On Apr 25, 2012, at 10:53 PM, BillB1951 wrote:

> Trouble getting solr and Haystack working together.  I have solar
> working (can get admin screen and query test data).  I then create my
> search_indexes.py (per getting started example, I also have run syndb
> and added data to the Notes table).  I run manage.py
> build_solar_schema, it generates XML for the schema.xml file. I
> replace the contents of the schema.xml with the new content.  I
> restart the solr server, then try to start admin  but get following
> error>
>
> HTTP ERROR 500
>
> Problem accessing /solr/admin/. Reason:
>
>    Severe errors in solr configuration.
>
> Check your log files for more detailed information on what may be
> wrong.
>
> If you want solr to continue after configuration errors, change:
>
> <abortOnConfigurationError>false</abortOnConfigurationError>
>
> in solr.xml
>
> -------------------------------------------------------------
> org.apache.solr.common.SolrException: No cores were created, please
> check the logs for errors
>
> what am I doing wrong.
>
> -----
> BillB1951
> --
> View this message in context: http://lucene.472066.n3.nabble.com/solr-error-after-relacing-schema-xml-tp3940133p3940133.html
> Sent from the Solr - User mailing list archive at Nabble.com.

- Mark Miller
lucidimagination.com











Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: solr error after relacing schema.xml

BillB1951
It does not appear that any logfiles were created.
BillB1951
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: solr error after relacing schema.xml

Mark Miller-3
By default logging goes to std out. You probably want to configure real logging though: http://wiki.apache.org/solr/SolrJetty#Logging

On Apr 26, 2012, at 1:33 PM, BillB1951 wrote:

> It does not appear that any logfiles were created.
>
>
> -----
> BillB1951
> --
> View this message in context: http://lucene.472066.n3.nabble.com/solr-error-after-relacing-schema-xml-tp3940133p3941997.html
> Sent from the Solr - User mailing list archive at Nabble.com.

- Mark Miller
lucidimagination.com











Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: solr error after relacing schema.xml

Lance Norskog-2
Which version of Solr does Haystack expect? The schema builder might
be targeting an older version of Solr.

On Thu, Apr 26, 2012 at 10:47 AM, Mark Miller <[hidden email]> wrote:

> By default logging goes to std out. You probably want to configure real logging though: http://wiki.apache.org/solr/SolrJetty#Logging
>
> On Apr 26, 2012, at 1:33 PM, BillB1951 wrote:
>
>> It does not appear that any logfiles were created.
>>
>>
>> -----
>> BillB1951
>> --
>> View this message in context: http://lucene.472066.n3.nabble.com/solr-error-after-relacing-schema-xml-tp3940133p3941997.html
>> Sent from the Solr - User mailing list archive at Nabble.com.
>
> - Mark Miller
> lucidimagination.com
>
>
>
>
>
>
>
>
>
>
>



--
Lance Norskog
[hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: solr error after relacing schema.xml

BillB1951
I'm using haystack 2.0.0Beta, and Apache-Solr-3.6.0.  

I'm not sure how to determine the schema.xml version, but I do notice that the solr example's  schema.xml is

<schema name="example" version="1.5">    -  and the schema.xml generated by haystack is

<schema name="default" version="1.4">.  Can I specify another schema.xml generator for haystack?  If so , where?


BillB1951
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: solr error after relacing schema.xml

BillB1951
PROBLEM RESOLVED.

Solr 3.6.0 changed where it looks for stopwords_en.txt (now in sub-directory /lang) .  Schema.xml generated by Haystack 2.0.0 beta need to be edited.  Everthing working now.
BillB1951
Loading...