strange updating inconsistency

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

strange updating inconsistency

patrik-6
I'm working with a reasonably big index with solr-1.2, and have noticed some
odd behavior while updating. The use case is that a document gets indexed
with a status, in this case it's -1 for documents that aren't ready to be
searched yet and 1 otherwise. Initial indexing works perfectly, and getting
a result set of documents with the status of -1 works as well.

 

Where things get messy is the update post after a document has been deemed
ready for searching. The unique ID in my index is a long called clipId.
Below are two documents that I've posted multiple times to my index. The
first one updates the index, the second does not. Is there something I'm
missing about?

 

patrik

 

 

<doc>

        <field
name="imageUrl"><![CDATA[http://brightcove.vo.llnwd.net/d5/unsecured/media/7
16039752/716039752_1404952466

_edc836cf8fb0535d1fc3e93d30ce10c9857fc368.jpg?pubId=716039752]]></field>

        <field
name="sourceUrl"><![CDATA[http://link.brightcove.com/services/link/bcpid7697
54033/bclid958498245/bctid139

8267160]]></field>

        <field name="descriptionBeginning"><![CDATA[A rally against FARC in
Colombia was held at Houston City Hall Monda

y. The Houston rally was just one of many held world-wide. Video by Julio
Cortez. Feb. 4, 2008.]]></field>

        <field
name="originalImageUrl"><![CDATA[http://brightcove.vo.llnwd.net/d5/unsecured
/media/716039752/716039752_14

04952466_edc836cf8fb0535d1fc3e93d30ce10c9857fc368.jpg?pubId=716039752]]></fi
eld>

        <field name="title"><![CDATA[Rallying against FARC]]></field>

        <field name="description"><![CDATA[A rally against FARC in Colombia
was held at Houston City Hall Monday. The Ho

uston rally was just one of many held world-wide. Video by Julio Cortez.
Feb. 4, 2008.]]></field>

        <field name="workflowKey">1</field>

        <field name="published"><![CDATA[2008-02-04T00:00:00Z]]></field>

        <field name="classes"><![CDATA[News]]></field>

        <field name="hasImage"><![CDATA[1]]></field>

        <field name="keywords"><![CDATA[null]]></field>

        <field name="added"><![CDATA[2008-02-05T00:00:00Z]]></field>

        <field name="status">-1</field>

        <field name="podcast"><![CDATA[]]></field>

        <field name="embeddable"><![CDATA[]]></field>

        <field
name="url"><![CDATA[http://clipblast.com/link/1352560412]]></field>

        <field name="feedId">7005</field>

        <field name="categoryId">0</field>

        <field name="explicit"><![CDATA[]]></field>

        <field name="owner"><![CDATA[Houston Chronicle]]></field>

        <field name="ownerId">1045</field>

        <field name="clipId">1352560412</field>

        <field name="rating">2</field>

        <field name="hasMedia"><![CDATA[]]></field>

        <field name="viewCount">0</field>

</doc>

 

 

<doc>

        <field
name="imageUrl"><![CDATA[http://brightcove.vo.llnwd.net/d5/unsecured/media/7
16039752/716039752_1406180801

_c2d5355fdc924d4ff3f8faa877f7229954e6fdd4.jpg?pubId=716039752]]></field>

        <field
name="sourceUrl"><![CDATA[http://link.brightcove.com/services/link/bcpid7697
54033/bclid1078635048/bctid13

98268178]]></field>

        <field name="descriptionBeginning"><![CDATA[Kristin Finan visits
Urban Jungle martial arts training center.]]></

field>

        <field
name="originalImageUrl"><![CDATA[http://brightcove.vo.llnwd.net/d5/unsecured
/media/716039752/716039752_14

06180801_c2d5355fdc924d4ff3f8faa877f7229954e6fdd4.jpg?pubId=716039752]]></fi
eld>

        <field name="title"><![CDATA[Urban Jungle]]></field>

        <field name="description"><![CDATA[Kristin Finan visits Urban Jungle
martial arts training center.]]></field>

        <field name="workflowKey">1</field>

        <field name="published"><![CDATA[2008-02-05T00:00:00Z]]></field>

        <field name="classes"><![CDATA[News]]></field>

        <field name="hasImage"><![CDATA[true]]></field>

        <field name="keywords"><![CDATA[null]]></field>

        <field name="added"><![CDATA[2008-02-05T00:00:00Z]]></field>

        <field name="status">-1</field>

        <field name="podcast"><![CDATA[]]></field>

        <field name="embeddable"><![CDATA[]]></field>

        <field
name="url"><![CDATA[http://clipblast.com/link/3391393924]]></field>

        <field name="feedId">7005</field>

        <field name="categoryId">0</field>

        <field name="explicit"><![CDATA[]]></field>

        <field name="owner"><![CDATA[Houston Chronicle]]></field>

        <field name="ownerId">1045</field>

        <field name="clipId">3391393924</field>

        <field name="rating">2</field>

        <field name="hasMedia"><![CDATA[]]></field>

        <field name="viewCount">0</field>

</doc>

 

 

Reply | Threaded
Open this post in threaded view
|

Re: strange updating inconsistency

hossman
: odd behavior while updating. The use case is that a document gets indexed
: with a status, in this case it's -1 for documents that aren't ready to be
: searched yet and 1 otherwise. Initial indexing works perfectly, and getting
: a result set of documents with the status of -1 works as well.
        ...
: Where things get messy is the update post after a document has been deemed
: ready for searching. The unique ID in my index is a long called clipId.
: Below are two documents that I've posted multiple times to my index. The
: first one updates the index, the second does not. Is there something I'm
: missing about?

I'm confused: the sentences above suggest that you aren't seeing updates
when you try to index a document with the same uniqueKey value as a
previous documnet (because some fields have changed) ... yet in the two
example docs you listed the "clipId" value is differnet (they seem to be
completley differnet docs)

what part of your question am i not understanding?

general suggestions: have you double checed that no interesting error
messages are getting logged after hte updates that don't seem to work?

what does hte response (HTTP status code and body) look like for the
updates?


-Hoss

Reply | Threaded
Open this post in threaded view
|

RE: strange updating inconsistency

patrik-6
Chris, thanks for the response. The two documents attached were different
docs, one of them was working and one wasn't. I found the problem, and it
wasn't related to SOLR though for a long while it did to me. Sorry to have
taken up your time.

patrik

-----Original Message-----
From: Chris Hostetter [mailto:[hidden email]]
Sent: Thursday, February 07, 2008 2:05 PM
To: [hidden email]
Subject: Re: strange updating inconsistency

: odd behavior while updating. The use case is that a document gets indexed
: with a status, in this case it's -1 for documents that aren't ready to be
: searched yet and 1 otherwise. Initial indexing works perfectly, and
getting
: a result set of documents with the status of -1 works as well.
        ...
: Where things get messy is the update post after a document has been deemed
: ready for searching. The unique ID in my index is a long called clipId.
: Below are two documents that I've posted multiple times to my index. The
: first one updates the index, the second does not. Is there something I'm
: missing about?

I'm confused: the sentences above suggest that you aren't seeing updates
when you try to index a document with the same uniqueKey value as a
previous documnet (because some fields have changed) ... yet in the two
example docs you listed the "clipId" value is differnet (they seem to be
completley differnet docs)

what part of your question am i not understanding?

general suggestions: have you double checed that no interesting error
messages are getting logged after hte updates that don't seem to work?

what does hte response (HTTP status code and body) look like for the
updates?


-Hoss