upgrade to 7.0.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

upgrade to 7.0.0

Stefano Mancini
Hi,

i’ve just installed solr 7.0.0 and i’ve an error opening an index created with 6.6.1.

The server works fine if  start it with an empty index so i suppose that configurations is ok

this is the stack trace:


Error waiting for SolrCore to be created
java.util.concurrent.ExecutionException: org.apache.solr.common.SolrException: Unable to create core [tps]
        at java.util.concurrent.FutureTask.report(FutureTask.java:122)
        at java.util.concurrent.FutureTask.get(FutureTask.java:192)
        at org.apache.solr.core.CoreContainer.lambda$load$118(CoreContainer.java:647)
        at com.codahale.metrics.InstrumentedExecutorService$InstrumentedRunnable.run(InstrumentedExecutorService.java:176)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at org.apache.solr.common.util.ExecutorUtil$MDCAwareThreadPoolExecutor.lambda$execute$128(ExecutorUtil.java:188)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
        at java.lang.Thread.run(Thread.java:748)
Caused by: org.apache.solr.common.SolrException: Unable to create core [tps]
        at org.apache.solr.core.CoreContainer.createFromDescriptor(CoreContainer.java:996)
        at org.apache.solr.core.CoreContainer.lambda$load$117(CoreContainer.java:619)
        at com.codahale.metrics.InstrumentedExecutorService$InstrumentedCallable.call(InstrumentedExecutorService.java:197)
        ... 5 more
Caused by: org.apache.solr.common.SolrException: Error opening new searcher
        at org.apache.solr.core.SolrCore.<init>(SolrCore.java:988)
        at org.apache.solr.core.SolrCore.<init>(SolrCore.java:843)
        at org.apache.solr.core.CoreContainer.createFromDescriptor(CoreContainer.java:980)
        ... 7 more
Caused by: org.apache.solr.common.SolrException: Error opening new searcher
        at org.apache.solr.core.SolrCore.openNewSearcher(SolrCore.java:2066)
        at org.apache.solr.core.SolrCore.getSearcher(SolrCore.java:2186)
        at org.apache.solr.core.SolrCore.initSearcher(SolrCore.java:1071)
        at org.apache.solr.core.SolrCore.<init>(SolrCore.java:960)
        ... 9 more
Caused by: java.lang.NullPointerException
        at java.util.Objects.requireNonNull(Objects.java:203)
        at java.util.Optional.<init>(Optional.java:96)
        at java.util.Optional.of(Optional.java:108)
        at java.util.stream.ReduceOps$2ReducingSink.get(ReduceOps.java:129)
        at java.util.stream.ReduceOps$2ReducingSink.get(ReduceOps.java:107)
        at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708)
        at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
        at java.util.stream.ReferencePipeline.reduce(ReferencePipeline.java:479)
        at org.apache.solr.index.SlowCompositeReaderWrapper.<init>(SlowCompositeReaderWrapper.java:76)
        at org.apache.solr.index.SlowCompositeReaderWrapper.wrap(SlowCompositeReaderWrapper.java:57)
        at org.apache.solr.search.SolrIndexSearcher.<init>(SolrIndexSearcher.java:252)
        at org.apache.solr.core.SolrCore.openNewSearcher(SolrCore.java:2034)
        ... 12 more


Any hint ?

Reply | Threaded
Open this post in threaded view
|

Re: upgrade to 7.0.0

David Haynie
Reply | Threaded
Open this post in threaded view
|

Re: upgrade to 7.0.0

Shawn Heisey-2
In reply to this post by Stefano Mancini
On 9/27/2017 4:36 AM, Stefano Mancini wrote:
> i’ve just installed solr 7.0.0 and i’ve an error opening an index created with 6.6.1.
>
> The server works fine if  start it with an empty index so i suppose that configurations is ok

I thought that I replied to this, turns out that I didn't.  I replicated
the error a couple of days ago and opened an issue.  You (Stefano) are
the mailing list user that I mentioned in the issue.

https://issues.apache.org/jira/browse/SOLR-11406

The problem has been located and Steve Rowe has figured out how to fix
it.  He has also volunteered to be the release manager for the 7.0.1
version that will contain the fix.  It's impossible to predict when that
release will be ready, but a preliminary estimate is about a week, maybe
two.

You have the option of grabbing the branch_7_0 source code and building
a SNAPSHOT package yourself if you want it right now.

Thanks,
Shawn

Reply | Threaded
Open this post in threaded view
|

Re: upgrade to 7.0.0

Stefano Mancini
thanks a lot,

i’ve just installed 7.0.1 and it works fine with all the indexes  i’ve created with 6.x

Stefano Mancini




Nella  nuvola  del  futuro
 
Tupla srl © 2011 – P.Iva 03019191208
via Porrettana, 277 - 40033 Casalecchio di Reno (BO)
Ph +39 051 0956963 – [hidden email]  www.tupla.it

Il presente messaggio è normalmente protetto dalla normativa vigente sulla privacy (d.l. 196/1996, d.p.r. 695/2003). Ogni informazione contenuta in esso e nei suoi eventuali allegati, costituisce materiale riservato e confidenziale. Il messaggio potrebbe contenere opinioni personali non necessariamente riconducibili a quelle di Tupla srl. Qualora abbia ricevuto il presente messaggio per errore, La preghiamo di darcene notizia e di provvedere all'immediata eliminazione dello stesso e di ogni sua eventuale copia (come già previsto dalla normativa citata).





Il giorno 30 set 2017, alle ore 00:14, Shawn Heisey <[hidden email]> ha scritto:

On 9/27/2017 4:36 AM, Stefano Mancini wrote:
i’ve just installed solr 7.0.0 and i’ve an error opening an index created with 6.6.1.

The server works fine if  start it with an empty index so i suppose that configurations is ok

I thought that I replied to this, turns out that I didn't.  I replicated
the error a couple of days ago and opened an issue.  You (Stefano) are
the mailing list user that I mentioned in the issue.

https://issues.apache.org/jira/browse/SOLR-11406

The problem has been located and Steve Rowe has figured out how to fix
it.  He has also volunteered to be the release manager for the 7.0.1
version that will contain the fix.  It's impossible to predict when that
release will be ready, but a preliminary estimate is about a week, maybe
two.

You have the option of grabbing the branch_7_0 source code and building
a SNAPSHOT package yourself if you want it right now.

Thanks,
Shawn


Reply | Threaded
Open this post in threaded view
|

Re: upgrade to 7.0.0

Erick Erickson
Thanks for verifying!

Erick

On Mon, Oct 9, 2017 at 2:27 AM, Stefano Mancini <[hidden email]> wrote:
thanks a lot,

i’ve just installed 7.0.1 and it works fine with all the indexes  i’ve created with 6.x

Stefano Mancini




Nella  nuvola  del  futuro
 
Tupla srl © 2011 – P.Iva 03019191208
Ph <a href="tel:+39%20051%20095%206963" value="+390510956963" target="_blank">+39 051 0956963 – [hidden email]  www.tupla.it

Il presente messaggio è normalmente protetto dalla normativa vigente sulla privacy (d.l. 196/1996, d.p.r. 695/2003). Ogni informazione contenuta in esso e nei suoi eventuali allegati, costituisce materiale riservato e confidenziale. Il messaggio potrebbe contenere opinioni personali non necessariamente riconducibili a quelle di Tupla srl. Qualora abbia ricevuto il presente messaggio per errore, La preghiamo di darcene notizia e di provvedere all'immediata eliminazione dello stesso e di ogni sua eventuale copia (come già previsto dalla normativa citata).





Il giorno 30 set 2017, alle ore 00:14, Shawn Heisey <[hidden email]> ha scritto:

On 9/27/2017 4:36 AM, Stefano Mancini wrote:
i’ve just installed solr 7.0.0 and i’ve an error opening an index created with 6.6.1.

The server works fine if  start it with an empty index so i suppose that configurations is ok

I thought that I replied to this, turns out that I didn't.  I replicated
the error a couple of days ago and opened an issue.  You (Stefano) are
the mailing list user that I mentioned in the issue.

https://issues.apache.org/jira/browse/SOLR-11406

The problem has been located and Steve Rowe has figured out how to fix
it.  He has also volunteered to be the release manager for the 7.0.1
version that will contain the fix.  It's impossible to predict when that
release will be ready, but a preliminary estimate is about a week, maybe
two.

You have the option of grabbing the branch_7_0 source code and building
a SNAPSHOT package yourself if you want it right now.

Thanks,
Shawn