Quantcast

upgrading from 4.0 to 4.1 causes "CorruptIndexException: checksum mismatch in segments file"

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

upgrading from 4.0 to 4.1 causes "CorruptIndexException: checksum mismatch in segments file"

solr-user
hi all

I have been working on moving us from 4.0 to a newer build of 4.1

I am seeing a "CorruptIndexException: checksum mismatch in segments file" error when I try to use the existing index files.

I did see something in the build log for #119 re "LUCENE-4446" that mentions "flip file formats to point to 4.1 format"

Do I just need to reindex or is this some other issue (ie do I need to configure something differently)?

or should I move back a few builds?

note, we are currently using:

solr-spec 4.0.0.2012.04.05.15.05.52
solr-impl 4.0-SNAPSHOT 1310094M - xxxx- 2012-04-05 15:05:52
lucene-spec 4.0-SNAPSHOT
lucene-impl 4.0-SNAPSHOT 1309921 - xxxx- 2012-04-05 10:25:27

and are considering moving to:

solr-spec 4.1.0.2012.11.03.18.08.42
solr-impl 4.1-2012-11-03_18-05-49 1405392 - hudson - 2012-11-03 18:08:42
lucene-spec 4.1-2012-11-03_18-05-49
lucene-impl 4.1-2012-11-03_18-05-49 1405392 - hudson - 2012-11-03 18:06:50
(aka apache-solr-4.1-2012-11-03_18-05-49)

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrading from 4.0 to 4.1 causes "CorruptIndexException: checksum mismatch in segments file"

Jack Krupansky-2
Moving from the final release of 4.0 to 4.1 should be fine, but you appear
to be using a snapshot of 4.0 that is even older than the ALPHA release of
4.0 and a number of format changes occurred last Spring. So, yeah, you will
have to re-index.

-- Jack Krupansky

-----Original Message-----
From: solr-user
Sent: Thursday, November 22, 2012 2:03 PM
To: [hidden email]
Subject: upgrading from 4.0 to 4.1 causes "CorruptIndexException: checksum
mismatch in segments file"

hi all

I have been working on moving us from 4.0 to a newer build of 4.1

I am seeing a "CorruptIndexException: checksum mismatch in segments file"
error when I try to use the existing index files.

I did see something in the build log for #119 re "LUCENE-4446" that mentions
"flip file formats to point to 4.1 format"

Do I just need to reindex or is this some other issue (ie do I need to
configure something differently)?

or should I move back a few builds?

note, we are currently using:

solr-spec 4.0.0.2012.04.05.15.05.52
solr-impl 4.0-SNAPSHOT 1310094M - xxxx- 2012-04-05 15:05:52
lucene-spec 4.0-SNAPSHOT
lucene-impl 4.0-SNAPSHOT 1309921 - xxxx- 2012-04-05 10:25:27

and are considering moving to:

solr-spec 4.1.0.2012.11.03.18.08.42
solr-impl 4.1-2012-11-03_18-05-49 1405392 - hudson - 2012-11-03 18:08:42
lucene-spec 4.1-2012-11-03_18-05-49
lucene-impl 4.1-2012-11-03_18-05-49 1405392 - hudson - 2012-11-03 18:06:50
(aka apache-solr-4.1-2012-11-03_18-05-49)





--
View this message in context:
http://lucene.472066.n3.nabble.com/upgrading-from-4-0-to-4-1-causes-CorruptIndexException-checksum-mismatch-in-segments-file-tp4021913.html
Sent from the Solr - User mailing list archive at Nabble.com.

Loading...