Buggy search Solr1.4 Multicore

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Buggy search Solr1.4 Multicore

Jörg Agatz
Hi...

I have a Problem with Solr, I try it with 3 cores, and it starts. I can
search but i only become results, when i exaktly search for the howls field.

i mean, in the field stand: "Dell Widescreen Ultra"

when i search for
"name:Widescreen" i get Nothing
"name:Dell Widescreen Ultra" i get the file
"name:Dell*" i get the file

now i creat copyfiels and search only for "Dell*" and get it, bit
"Widescreen" Nothing

What is wrong with the index?

I will search each word in each field!

Pleas Help me
Reply | Threaded
Open this post in threaded view
|

Re: Buggy search Solr1.4 Multicore

Rafał Kuć-2
Hello!

> Hi...

> I have a Problem with Solr, I try it with 3 cores, and it starts. I can
> search but i only become results, when i exaktly search for the howls field.

> i mean, in the field stand: "Dell Widescreen Ultra"

> when i search for
> "name:Widescreen" i get Nothing
> "name:Dell Widescreen Ultra" i get the file
> "name:Dell*" i get the file

> now i creat copyfiels and search only for "Dell*" and get it, bit
> "Widescreen" Nothing

> What is wrong with the index?

> I will search each word in each field!

> Pleas Help me

I assume your name field type is string right ? If it is right, than
change it to text, it should work as You would like.

--
Regards,
 Rafał Kuć

Reply | Threaded
Open this post in threaded view
|

Re: Buggy search Solr1.4 Multicore

Erick Erickson
In reply to this post by Jörg Agatz
If Rafal's response doesn't help (but it's sure where I'd
look first, it sounds like you're using a field type that's
not Tokenized), then could you post the relevant parts
of your config file that define the field and the analyzers
used at *both* query and index time?

Best
Erick

On Wed, Nov 25, 2009 at 6:35 AM, Jörg Agatz <[hidden email]>wrote:

> Hi...
>
> I have a Problem with Solr, I try it with 3 cores, and it starts. I can
> search but i only become results, when i exaktly search for the howls
> field.
>
> i mean, in the field stand: "Dell Widescreen Ultra"
>
> when i search for
> "name:Widescreen" i get Nothing
> "name:Dell Widescreen Ultra" i get the file
> "name:Dell*" i get the file
>
> now i creat copyfiels and search only for "Dell*" and get it, bit
> "Widescreen" Nothing
>
> What is wrong with the index?
>
> I will search each word in each field!
>
> Pleas Help me
>