ClasscastException while running solr 4 from eclipse

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

ClasscastException while running solr 4 from eclipse

santoash
I setup the Solr project in eclipse after running "ant eclipse" from source directory. I don't see any build errors in eclipse. I see the following exception while trying to run Solr4 from Eclipse.

Caused by: java.lang.ClassCastException: class org.apache.lucene.codecs.pulsing.Pulsing40PostingsFormat
        at java.lang.Class.asSubclass(Class.java:3018)
        at org.apache.lucene.util.SPIClassIterator.next(SPIClassIterator.java:126)
        at org.apache.lucene.util.NamedSPILoader.reload(NamedSPILoader.java:60)
        at org.apache.lucene.util.NamedSPILoader.<init>(NamedSPILoader.java:42)
        at org.apache.lucene.util.NamedSPILoader.<init>(NamedSPILoader.java:37)
        at org.apache.lucene.codecs.PostingsFormat.<clinit>(PostingsFormat.java:44)
        ... 45 more


I would really appreciate any pointers/suggestions.

Thanks!

Santoash