Config files not replicating

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Config files not replicating

Atita Arora
Hi,

We are using Solr 6.6.2 in the Master-Slave mode ( hot star of the
discussion thread these days !!) and lately, I got into this weird issue
that at each replication trigger my index gets correctly replicated but my
config changes are not replicated to my slaves.

We are using referential properties i.e. my solrconfig.xml imports the
different configs like requesthandler_config.xml,
replication_handler_config.xml, etc  which essentially means if going by
solr doc (https://lucene.apache.org/solr/guide/6_6/index-replication.html) :

Unlike the index files, where the timestamp is good enough to figure out if
they are identical, configuration files are compared against their
checksum. The schema.xml files (on master and slave) are judged to be
identical if their checksums are identical.

The checksum of my solrconfig.xml would not vary, is it why my files won't
replicate?

I already have another Master-Slave in a different environment working with
the same config version, so I don't smell any issue with the replication
configuration.

I have tried manual replication too but the files would not change.
Maybe it is something weirdly trivial or stupid that I seem to be missing
here, any pointers or ideas what else can I check?

Thank you,

Atita
Reply | Threaded
Open this post in threaded view
|

Re: Config files not replicating

Erick Erickson
Did you put your auxiliary files in the
confFiles tag? E.g. from the page you referenced:

<str name="confFiles">schema.xml,stopwords.txt,elevate.xml</str>

Best,
Erick

> On Jun 30, 2020, at 5:38 AM, Atita Arora <[hidden email]> wrote:
>
> Hi,
>
> We are using Solr 6.6.2 in the Master-Slave mode ( hot star of the
> discussion thread these days !!) and lately, I got into this weird issue
> that at each replication trigger my index gets correctly replicated but my
> config changes are not replicated to my slaves.
>
> We are using referential properties i.e. my solrconfig.xml imports the
> different configs like requesthandler_config.xml,
> replication_handler_config.xml, etc  which essentially means if going by
> solr doc (https://lucene.apache.org/solr/guide/6_6/index-replication.html) :
>
> Unlike the index files, where the timestamp is good enough to figure out if
> they are identical, configuration files are compared against their
> checksum. The schema.xml files (on master and slave) are judged to be
> identical if their checksums are identical.
>
> The checksum of my solrconfig.xml would not vary, is it why my files won't
> replicate?
>
> I already have another Master-Slave in a different environment working with
> the same config version, so I don't smell any issue with the replication
> configuration.
>
> I have tried manual replication too but the files would not change.
> Maybe it is something weirdly trivial or stupid that I seem to be missing
> here, any pointers or ideas what else can I check?
>
> Thank you,
>
> Atita

Reply | Threaded
Open this post in threaded view
|

Re: Config files not replicating

Atita Arora
Yes, The config is there and it works for me in live environment but not
the new staging environment.


On Tue, Jun 30, 2020 at 2:29 PM Erick Erickson <[hidden email]>
wrote:

> Did you put your auxiliary files in the
> confFiles tag? E.g. from the page you referenced:
>
> <str name="confFiles">schema.xml,stopwords.txt,elevate.xml</str>
>
> Best,
> Erick
>
> > On Jun 30, 2020, at 5:38 AM, Atita Arora <[hidden email]> wrote:
> >
> > Hi,
> >
> > We are using Solr 6.6.2 in the Master-Slave mode ( hot star of the
> > discussion thread these days !!) and lately, I got into this weird issue
> > that at each replication trigger my index gets correctly replicated but
> my
> > config changes are not replicated to my slaves.
> >
> > We are using referential properties i.e. my solrconfig.xml imports the
> > different configs like requesthandler_config.xml,
> > replication_handler_config.xml, etc  which essentially means if going by
> > solr doc (
> https://lucene.apache.org/solr/guide/6_6/index-replication.html) :
> >
> > Unlike the index files, where the timestamp is good enough to figure out
> if
> > they are identical, configuration files are compared against their
> > checksum. The schema.xml files (on master and slave) are judged to be
> > identical if their checksums are identical.
> >
> > The checksum of my solrconfig.xml would not vary, is it why my files
> won't
> > replicate?
> >
> > I already have another Master-Slave in a different environment working
> with
> > the same config version, so I don't smell any issue with the replication
> > configuration.
> >
> > I have tried manual replication too but the files would not change.
> > Maybe it is something weirdly trivial or stupid that I seem to be missing
> > here, any pointers or ideas what else can I check?
> >
> > Thank you,
> >
> > Atita
>
>