GermanAnalyzer

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

GermanAnalyzer

heidi.weber
Hello,

i use the GermanAnalyzer. But i believe that this analyzer isn´t working correct or i make an error in my code.

For indexing and searching i take of course the same (German-) analyzer.

But if i search for e.g.:

müller
schönheit
...

then i have no results. When i take the standardanalyzer for indexing and searching, then the documents are found.

Do i need another (german-) steemer?
Or what could be wrong? Is this a bug in the germananalyzer?

Many thanks
Best regards
Heidi
Reply | Threaded
Open this post in threaded view
|

Re: GermanAnalyzer

Daniel Naber-10
On Mittwoch, 3. September 2008, heidiweber wrote:

> Do i need another (german-) steemer?
> Or what could be wrong? Is this a bug in the germananalyzer?

I suggest you use the hints from
http://wiki.apache.org/lucene-java/LuceneFAQ#head-3558e5121806fb4fce80fc022d889484a9248b71 
to debug this. If that doesn't help, you could post a short code example
to java-user list (which has more traffic than this list).

Regards
 Daniel

--
http://www.danielnaber.de
Reply | Threaded
Open this post in threaded view
|

Re: GermanAnalyzer

heidi.weber
In reply to this post by heidi.weber
Thank you very much for the Infos.

But i think really, that the GermanAnalyzer isn´t working correctly.


Reply | Threaded
Open this post in threaded view
|

Re: GermanAnalyzer

Neils-2
In reply to this post by heidi.weber
Hello Heidi, I'm using the german-analyzer without problems. Letters like ä,ü,ö are can be Searched. Maybe something in your code. Can you post some lines? Thanks, Neil s http://www.shoobridge.de
heidiweber wrote
Hello, i use the GermanAnalyzer. But i believe that this analyzer isn´t working correct or i make an error in my code. For indexing and searching i take of course the same (German-) analyzer. But if i search for e.g.: müller schönheit ... then i have no results. When i take the standardanalyzer for indexing and searching, then the documents are found. Do i need another (german-) steemer? Or what could be wrong? Is this a bug in the germananalyzer? Many thanks Best regards Heidi