[HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

[HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Apache Jenkins Server
Build: https://hudson.apache.org/hudson/job/Lucene-Solr-tests-only-trunk/5336/

1 tests failed.
REGRESSION:  org.apache.lucene.index.TestNRTThreads.testNRTThreads

Error Message:
null

Stack Trace:
junit.framework.AssertionFailedError:
        at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1213)
        at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1145)
        at org.apache.lucene.index.TestNRTThreads.testNRTThreads(TestNRTThreads.java:386)




Build Log (for compile errors):
[...truncated 3089 lines...]



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Michael McCandless-2
Uh-oh!  I suspect this failure is from LUCENE-2881 -- the assert that
tripped was verifying all merges were done w/ bulk copy.  So, somehow,
in this test we are failing to consistently assign the same field
number to the same field name...

Mike

On Sat, Feb 26, 2011 at 4:46 AM, Apache Hudson Server
<[hidden email]> wrote:

> Build: https://hudson.apache.org/hudson/job/Lucene-Solr-tests-only-trunk/5336/
>
> 1 tests failed.
> REGRESSION:  org.apache.lucene.index.TestNRTThreads.testNRTThreads
>
> Error Message:
> null
>
> Stack Trace:
> junit.framework.AssertionFailedError:
>        at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1213)
>        at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1145)
>        at org.apache.lucene.index.TestNRTThreads.testNRTThreads(TestNRTThreads.java:386)
>
>
>
>
> Build Log (for compile errors):
> [...truncated 3089 lines...]
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>



--
Mike

http://blog.mikemccandless.com

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Simon Willnauer
I am running this now for a while with no failure :(

mike can your reproduce?

On Sat, Feb 26, 2011 at 2:30 PM, Michael McCandless
<[hidden email]> wrote:

> Uh-oh!  I suspect this failure is from LUCENE-2881 -- the assert that
> tripped was verifying all merges were done w/ bulk copy.  So, somehow,
> in this test we are failing to consistently assign the same field
> number to the same field name...
>
> Mike
>
> On Sat, Feb 26, 2011 at 4:46 AM, Apache Hudson Server
> <[hidden email]> wrote:
>> Build: https://hudson.apache.org/hudson/job/Lucene-Solr-tests-only-trunk/5336/
>>
>> 1 tests failed.
>> REGRESSION:  org.apache.lucene.index.TestNRTThreads.testNRTThreads
>>
>> Error Message:
>> null
>>
>> Stack Trace:
>> junit.framework.AssertionFailedError:
>>        at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1213)
>>        at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1145)
>>        at org.apache.lucene.index.TestNRTThreads.testNRTThreads(TestNRTThreads.java:386)
>>
>>
>>
>>
>> Build Log (for compile errors):
>> [...truncated 3089 lines...]
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>
>
>
> --
> Mike
>
> http://blog.mikemccandless.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Yonik Seeley-2-2
On Sat, Feb 26, 2011 at 8:43 AM, Simon Willnauer
<[hidden email]> wrote:
> I am running this now for a while with no failure :(

I haven't been able to reproduce this either.

-Yonik
http://lucidimagination.com

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Michael McCandless-2
In reply to this post by Simon Willnauer
Alas no I cannot repro so far :(

I tried the seed that failed, and I'm running while(1) on beast but no
failure so far.... gonna be a tricky one!!

Mike

On Sat, Feb 26, 2011 at 8:43 AM, Simon Willnauer
<[hidden email]> wrote:

> I am running this now for a while with no failure :(
>
> mike can your reproduce?
>
> On Sat, Feb 26, 2011 at 2:30 PM, Michael McCandless
> <[hidden email]> wrote:
>> Uh-oh!  I suspect this failure is from LUCENE-2881 -- the assert that
>> tripped was verifying all merges were done w/ bulk copy.  So, somehow,
>> in this test we are failing to consistently assign the same field
>> number to the same field name...
>>
>> Mike
>>
>> On Sat, Feb 26, 2011 at 4:46 AM, Apache Hudson Server
>> <[hidden email]> wrote:
>>> Build: https://hudson.apache.org/hudson/job/Lucene-Solr-tests-only-trunk/5336/
>>>
>>> 1 tests failed.
>>> REGRESSION:  org.apache.lucene.index.TestNRTThreads.testNRTThreads
>>>
>>> Error Message:
>>> null
>>>
>>> Stack Trace:
>>> junit.framework.AssertionFailedError:
>>>        at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1213)
>>>        at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1145)
>>>        at org.apache.lucene.index.TestNRTThreads.testNRTThreads(TestNRTThreads.java:386)
>>>
>>>
>>>
>>>
>>> Build Log (for compile errors):
>>> [...truncated 3089 lines...]
>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>>
>>
>>
>> --
>> Mike
>>
>> http://blog.mikemccandless.com
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>



--
Mike

http://blog.mikemccandless.com

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Michael McCandless-2
Hmmm beast hit a failure, but, a different one from the build:

*** Thread: Lucene Merge Thread #1 ***
org.apache.lucene.index.MergePolicy$MergeException:
java.lang.NullPointerException
        at org.apache.lucene.index.ConcurrentMergeScheduler.handleMergeException(ConcurrentMergeScheduler.java:507)
        at org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:472)
Caused by: java.lang.NullPointerException
        at org.apache.lucene.index.SegmentReader$FieldsReaderLocal.initialValue(SegmentReader.java:245)
        at org.apache.lucene.index.SegmentReader$FieldsReaderLocal.initialValue(SegmentReader.java:242)
        at org.apache.lucene.util.CloseableThreadLocal.get(CloseableThreadLocal.java:68)
        at org.apache.lucene.index.SegmentReader.getFieldsReader(SegmentReader.java:749)
        at org.apache.lucene.index.SegmentReader.document(SegmentReader.java:838)
        at org.apache.lucene.index.IndexReader.document(IndexReader.java:951)
        at org.apache.lucene.index.TestNRTThreads$1.warm(TestNRTThreads.java:86)
        at org.apache.lucene.index.IndexWriter.mergeMiddle(IndexWriter.java:3311)
        at org.apache.lucene.index.IndexWriter.merge(IndexWriter.java:2875)
        at org.apache.lucene.index.ConcurrentMergeScheduler.doMerge(ConcurrentMergeScheduler.java:379)
        at org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:447)

Not sure what's up...

--
Mike

http://blog.mikemccandless.com

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Robert Muir
On Sat, Feb 26, 2011 at 12:30 PM, Michael McCandless
<[hidden email]> wrote:
> Hmmm beast hit a failure, but, a different one from the build:

Maybe we should back this change out, until it can be stabilized on an
issue? I don't like an unstable trunk.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Simon Willnauer
In reply to this post by Michael McCandless-2
WTF - you got that running that test with while(true)?

hmm... weird. Not sure if it is related to 2881 though

On Sat, Feb 26, 2011 at 6:30 PM, Michael McCandless
<[hidden email]> wrote:

> Hmmm beast hit a failure, but, a different one from the build:
>
> *** Thread: Lucene Merge Thread #1 ***
> org.apache.lucene.index.MergePolicy$MergeException:
> java.lang.NullPointerException
>        at org.apache.lucene.index.ConcurrentMergeScheduler.handleMergeException(ConcurrentMergeScheduler.java:507)
>        at org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:472)
> Caused by: java.lang.NullPointerException
>        at org.apache.lucene.index.SegmentReader$FieldsReaderLocal.initialValue(SegmentReader.java:245)
>        at org.apache.lucene.index.SegmentReader$FieldsReaderLocal.initialValue(SegmentReader.java:242)
>        at org.apache.lucene.util.CloseableThreadLocal.get(CloseableThreadLocal.java:68)
>        at org.apache.lucene.index.SegmentReader.getFieldsReader(SegmentReader.java:749)
>        at org.apache.lucene.index.SegmentReader.document(SegmentReader.java:838)
>        at org.apache.lucene.index.IndexReader.document(IndexReader.java:951)
>        at org.apache.lucene.index.TestNRTThreads$1.warm(TestNRTThreads.java:86)
>        at org.apache.lucene.index.IndexWriter.mergeMiddle(IndexWriter.java:3311)
>        at org.apache.lucene.index.IndexWriter.merge(IndexWriter.java:2875)
>        at org.apache.lucene.index.ConcurrentMergeScheduler.doMerge(ConcurrentMergeScheduler.java:379)
>        at org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:447)
>
> Not sure what's up...
>
> --
> Mike
>
> http://blog.mikemccandless.com
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Michael Busch
In reply to this post by Michael McCandless-2
Well, after LUCENE-2881 assigning the same fieldNumber to the same
fieldName across segments is best effort - not guaranteed anymore.  It
looks like in most cases it works fine, just very rarely we get
different field numbers.  I don't see how we can improve the best
effort, because I don't think we can assign field numbers on flush (like
codecIDs)?

So the assert might be too strict now.  It'd be good to disable the
assert and see if the test still fails.  I can't do that right now, but
later tonight...

  Michael

On 2/26/11 9:09 AM, Michael McCandless wrote:

> Alas no I cannot repro so far :(
>
> I tried the seed that failed, and I'm running while(1) on beast but no
> failure so far.... gonna be a tricky one!!
>
> Mike
>
> On Sat, Feb 26, 2011 at 8:43 AM, Simon Willnauer
> <[hidden email]>  wrote:
>> I am running this now for a while with no failure :(
>>
>> mike can your reproduce?
>>
>> On Sat, Feb 26, 2011 at 2:30 PM, Michael McCandless
>> <[hidden email]>  wrote:
>>> Uh-oh!  I suspect this failure is from LUCENE-2881 -- the assert that
>>> tripped was verifying all merges were done w/ bulk copy.  So, somehow,
>>> in this test we are failing to consistently assign the same field
>>> number to the same field name...
>>>
>>> Mike
>>>
>>> On Sat, Feb 26, 2011 at 4:46 AM, Apache Hudson Server
>>> <[hidden email]>  wrote:
>>>> Build: https://hudson.apache.org/hudson/job/Lucene-Solr-tests-only-trunk/5336/
>>>>
>>>> 1 tests failed.
>>>> REGRESSION:  org.apache.lucene.index.TestNRTThreads.testNRTThreads
>>>>
>>>> Error Message:
>>>> null
>>>>
>>>> Stack Trace:
>>>> junit.framework.AssertionFailedError:
>>>>         at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1213)
>>>>         at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1145)
>>>>         at org.apache.lucene.index.TestNRTThreads.testNRTThreads(TestNRTThreads.java:386)
>>>>
>>>>
>>>>
>>>>
>>>> Build Log (for compile errors):
>>>> [...truncated 3089 lines...]
>>>>
>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>>
>>>
>>>
>>> --
>>> Mike
>>>
>>> http://blog.mikemccandless.com
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Simon Willnauer
On Sat, Feb 26, 2011 at 11:02 PM, Michael Busch <[hidden email]> wrote:
> Well, after LUCENE-2881 assigning the same fieldNumber to the same fieldName
> across segments is best effort - not guaranteed anymore.  It looks like in
> most cases it works fine, just very rarely we get different field numbers.
>  I don't see how we can improve the best effort, because I don't think we
> can assign field numbers on flush (like codecIDs)?
There is one thing I don't understand. AFAIK LUCENE-2881 guarantees
consistent Field IDs within one IndexWriter session, is that correct
or do I miss something? If so I don't see why we should disable this
assert - then it seems like there is an issue in FieldInfos though.
Segments written with another IW session might have different Field
IDs but we could pre-populate the BiMap when we open IW with field IDs
from a previous segment, no?

What I wonder about is the second failure mike produced (the NPE)
which looks very odd.

simon

>
> So the assert might be too strict now.  It'd be good to disable the assert
> and see if the test still fails.  I can't do that right now, but later
> tonight...
>
>  Michael
>
> On 2/26/11 9:09 AM, Michael McCandless wrote:
>>
>> Alas no I cannot repro so far :(
>>
>> I tried the seed that failed, and I'm running while(1) on beast but no
>> failure so far.... gonna be a tricky one!!
>>
>> Mike
>>
>> On Sat, Feb 26, 2011 at 8:43 AM, Simon Willnauer
>> <[hidden email]>  wrote:
>>>
>>> I am running this now for a while with no failure :(
>>>
>>> mike can your reproduce?
>>>
>>> On Sat, Feb 26, 2011 at 2:30 PM, Michael McCandless
>>> <[hidden email]>  wrote:
>>>>
>>>> Uh-oh!  I suspect this failure is from LUCENE-2881 -- the assert that
>>>> tripped was verifying all merges were done w/ bulk copy.  So, somehow,
>>>> in this test we are failing to consistently assign the same field
>>>> number to the same field name...
>>>>
>>>> Mike
>>>>
>>>> On Sat, Feb 26, 2011 at 4:46 AM, Apache Hudson Server
>>>> <[hidden email]>  wrote:
>>>>>
>>>>> Build:
>>>>> https://hudson.apache.org/hudson/job/Lucene-Solr-tests-only-trunk/5336/
>>>>>
>>>>> 1 tests failed.
>>>>> REGRESSION:  org.apache.lucene.index.TestNRTThreads.testNRTThreads
>>>>>
>>>>> Error Message:
>>>>> null
>>>>>
>>>>> Stack Trace:
>>>>> junit.framework.AssertionFailedError:
>>>>>        at
>>>>> org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1213)
>>>>>        at
>>>>> org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1145)
>>>>>        at
>>>>> org.apache.lucene.index.TestNRTThreads.testNRTThreads(TestNRTThreads.java:386)
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Build Log (for compile errors):
>>>>> [...truncated 3089 lines...]
>>>>>
>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: [hidden email]
>>>>> For additional commands, e-mail: [hidden email]
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> Mike
>>>>
>>>> http://blog.mikemccandless.com
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>>
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Michael McCandless-2
In reply to this post by Simon Willnauer
On Sat, Feb 26, 2011 at 2:42 PM, Simon Willnauer
<[hidden email]> wrote:
> WTF - you got that running that test with while(true)?
>
> hmm... weird. Not sure if it is related to 2881 though

Yeah... I think this is pre-existing.  I'll open a separate issue...

--
Mike

http://blog.mikemccandless.com

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Simon Willnauer
In reply to this post by Michael Busch
On Sat, Feb 26, 2011 at 11:02 PM, Michael Busch <[hidden email]> wrote:
> Well, after LUCENE-2881 assigning the same fieldNumber to the same fieldName
> across segments is best effort - not guaranteed anymore.  It looks like in
> most cases it works fine, just very rarely we get different field numbers.
>  I don't see how we can improve the best effort, because I don't think we
> can assign field numbers on flush (like codecIDs)?

Can you elaborate this? I am not sure if I understand what you mean here!

simon

>
> So the assert might be too strict now.  It'd be good to disable the assert
> and see if the test still fails.  I can't do that right now, but later
> tonight...
>
>  Michael
>
> On 2/26/11 9:09 AM, Michael McCandless wrote:
>>
>> Alas no I cannot repro so far :(
>>
>> I tried the seed that failed, and I'm running while(1) on beast but no
>> failure so far.... gonna be a tricky one!!
>>
>> Mike
>>
>> On Sat, Feb 26, 2011 at 8:43 AM, Simon Willnauer
>> <[hidden email]>  wrote:
>>>
>>> I am running this now for a while with no failure :(
>>>
>>> mike can your reproduce?
>>>
>>> On Sat, Feb 26, 2011 at 2:30 PM, Michael McCandless
>>> <[hidden email]>  wrote:
>>>>
>>>> Uh-oh!  I suspect this failure is from LUCENE-2881 -- the assert that
>>>> tripped was verifying all merges were done w/ bulk copy.  So, somehow,
>>>> in this test we are failing to consistently assign the same field
>>>> number to the same field name...
>>>>
>>>> Mike
>>>>
>>>> On Sat, Feb 26, 2011 at 4:46 AM, Apache Hudson Server
>>>> <[hidden email]>  wrote:
>>>>>
>>>>> Build:
>>>>> https://hudson.apache.org/hudson/job/Lucene-Solr-tests-only-trunk/5336/
>>>>>
>>>>> 1 tests failed.
>>>>> REGRESSION:  org.apache.lucene.index.TestNRTThreads.testNRTThreads
>>>>>
>>>>> Error Message:
>>>>> null
>>>>>
>>>>> Stack Trace:
>>>>> junit.framework.AssertionFailedError:
>>>>>        at
>>>>> org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1213)
>>>>>        at
>>>>> org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:1145)
>>>>>        at
>>>>> org.apache.lucene.index.TestNRTThreads.testNRTThreads(TestNRTThreads.java:386)
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Build Log (for compile errors):
>>>>> [...truncated 3089 lines...]
>>>>>
>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: [hidden email]
>>>>> For additional commands, e-mail: [hidden email]
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> Mike
>>>>
>>>> http://blog.mikemccandless.com
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>>
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Michael Busch
On 2/27/11 2:47 AM, Simon Willnauer wrote:
> On Sat, Feb 26, 2011 at 11:02 PM, Michael Busch<[hidden email]>  wrote:
>> Well, after LUCENE-2881 assigning the same fieldNumber to the same fieldName
>> across segments is best effort - not guaranteed anymore.  It looks like in
>> most cases it works fine, just very rarely we get different field numbers.
>>   I don't see how we can improve the best effort, because I don't think we
>> can assign field numbers on flush (like codecIDs)?
> Can you elaborate this? I am not sure if I understand what you mean here!
>

Sorry should have explained this better.  I actually posted a comment
describing what I meant with "best effort" on LUCENE-2881, so that it's
easier to find in the future.

  Michael

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [HUDSON] Lucene-Solr-tests-only-trunk - Build # 5336 - Failure

Simon Willnauer
On Mon, Feb 28, 2011 at 8:32 AM, Michael Busch <[hidden email]> wrote:

> On 2/27/11 2:47 AM, Simon Willnauer wrote:
>>
>> On Sat, Feb 26, 2011 at 11:02 PM, Michael Busch<[hidden email]>
>>  wrote:
>>>
>>> Well, after LUCENE-2881 assigning the same fieldNumber to the same
>>> fieldName
>>> across segments is best effort - not guaranteed anymore.  It looks like
>>> in
>>> most cases it works fine, just very rarely we get different field
>>> numbers.
>>>  I don't see how we can improve the best effort, because I don't think we
>>> can assign field numbers on flush (like codecIDs)?
>>
>> Can you elaborate this? I am not sure if I understand what you mean here!
>>
>
> Sorry should have explained this better.  I actually posted a comment
> describing what I meant with "best effort" on LUCENE-2881, so that it's
> easier to find in the future.

Thanks michael, now this failure makes way more sense to me....


simon
>
>  Michael
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]