Optimization and Corruption Issues

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Optimization and Corruption Issues

lowfreq
I have a Lucene index that is very large in size.
It was created using a pre 2.1 version of Lucene.net 2.0.0.4.

The index is currently almost 20 GB, and has almost 7000 segment files.
The problem I am having is that I need to optimize it, and cant do this without the search functionality of my app being down for a week.

I used the Luke tool from getopt.org and it worked flawlessly, optimizing the index in just over 2 hours. Problem is that my search cannot use it, and the error states Unknown Format Version errors, or just plain nothing found.

I understand that versions of Lucene that are newer than what the index was built and is searched with can cause problems.

What can I do to make this work? I have tried older versions of Luke, 0.7 was the oldest I could lay hands on, but even it uses a newer version of Lucene.

My index version shows as 633103800023469045. The version the index is written as after optimizing with Luke 7.0 is 633103800023469057.

Any help here would be awesome!

Thank you,

Hugh