Re: Branch-2 and Tomcat

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Branch-2 and Tomcat

Masatake Iwasaki
 > Since 7.0.x is live for a while, upgrading to 7.0.94 first would be
easier step.

Upgrading Tomcat itself seems to be small fix than I thought.
I attached the patch to HADOOP-16439 for discussion.

On 7/19/19 17:23, Masatake Iwasaki wrote:

> Thinks for working on this,  Wei-Chiu Chuang.
>
> > I am sending this out again because we are evaluating the
> possibility of
> > upgrading to Tomcat 7, 8 or 9.
> >
> > Thoughts? We've got customers asking us to do it so I am quite serious
> > about this proposal.
>
> Currently supported versions of Tomcat are 7.0.x, 8.5.x and 9.0.x.
> #
> http://tomcat.10.x6.nabble.com/Please-help-EOL-TOMCAT-7-and-8-5-td5073688.html
>
> Tomcat 9.0.x seems not to be good candidate because it requires Java 8
> or later.
> Since 7.0.x is live for a while, upgrading to 7.0.94 first would be
> easier step.
>
> Masatake Iwasaki
>
>
> On 7/16/19 13:40, Wei-Chiu Chuang wrote:
>> Ping.
>> I am sending this out again because we are evaluating the possibility of
>> upgrading to Tomcat 7, 8 or 9.
>>
>> Thoughts? We've got customers asking us to do it so I am quite serious
>> about this proposal.
>>
>> The impact includes KMS and Httpfs. We are also looking into upgrading
>> Tomcat versions in other projects (Oozie, for example)
>>
>> On Fri, Jun 28, 2019 at 11:47 PM Wei-Chiu Chuang <[hidden email]>
>> wrote:
>>
>>> During the Wednesday's meetup, we discussed the plan for the "bridge
>>> release" branch-2.10.
>>>
>>> A smooth upgrade path (that is, rolling upgrade) from 2.10 to Hadoop
>>> 3 was
>>> called out as the most critical release criteria.
>>>
>>> I am wondering if Tomcat (as well as other dependency upgrade) upgrade
>>> should be considered as well?
>>>
>>> We migrated from Tomcat to Jetty in Hadoop3, because Tomcat 6 went
>>> EOL in
>>> 2016. But we did not realize three years after Tomcat 6's EOL, a
>>> majority
>>> of Hadoop users are still in Hadoop 2, and it looks like Hadoop 2
>>> will stay
>>> alive for another few years.
>>>
>>> Backporting Jetty to Hadoop2 is probably too big of an imcompatibility.
>>> How about migrating to Tomcat9?
>>>
>>> FWIW, Tomcat 6 EOL along is big enough a reason why you should move
>>> up to
>>> Hadoop 3. :)
>>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]