SOLR / Zookeeper Compatibility

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

SOLR / Zookeeper Compatibility

Paul Russell
ALCON,

 

We have been asked by our customer to not install Zookeeper V3.4.x for use
with the SOLR cluster. Currently we have a 3 node SOLR V6.6.0 cluster using
zookeeper V3.4.11.

 

The customer identified several stig related issues with 3.4.x
(CVE-2016-5017, CVE-2017-5637, and CVE 2019-0201.

 

We have staged SOLR 6.x and 7.x environments with ZK V3.5.5 as requested and
it does not appear to work. If we back off to ZK 3.4.x it works fine.

 

It also appears that SOLR V8.x is currently packaged with ZK V3.4.14.

 

Are there known solutions to the issues with ZK V3.5.5 and SOLR?

 

Thanks for your help

 

Paul Russell

www.qflow.com

 

Reply | Threaded
Open this post in threaded view
|

Re: SOLR / Zookeeper Compatibility

Shawn Heisey-2
On 8/14/2019 11:46 AM, Paul Russell wrote:
> We have staged SOLR 6.x and 7.x environments with ZK V3.5.5 as requested and
> it does not appear to work. If we back off to ZK 3.4.x it works fine.

The ZK project has documentation about backward compatibility:

https://cwiki.apache.org/confluence/display/ZOOKEEPER/ReleaseManagement

This says that 3.4.x and 3.5.x should be compatible.

There may be configuration changes required to get them working.  When
we upgraded ZK to 3.5.5 in Solr (which was done with SOLR-8346 and
released in version 8.2.0), we found that running Solr against a 3.5.5
server required adding this line to the ZK server config:

4lw.commands.whitelist=mntr,conf,ruok

When you say that it doesn't work, can you tell us EXACTLY what doesn't
work?  Ideally, you'll be able to let us know what errors are being logged.

Thanks,
Shawn
Reply | Threaded
Open this post in threaded view
|

Re: SOLR / Zookeeper Compatibility

Jörn Franke
In reply to this post by Paul Russell
8.2 works with 3.5.5 - with a minor glitch in the Admin UI, which does not affect Solr itself

> Am 14.08.2019 um 19:46 schrieb Paul Russell <[hidden email]>:
>
> ALCON,
>
>
>
> We have been asked by our customer to not install Zookeeper V3.4.x for use
> with the SOLR cluster. Currently we have a 3 node SOLR V6.6.0 cluster using
> zookeeper V3.4.11.
>
>
>
> The customer identified several stig related issues with 3.4.x
> (CVE-2016-5017, CVE-2017-5637, and CVE 2019-0201.
>
>
>
> We have staged SOLR 6.x and 7.x environments with ZK V3.5.5 as requested and
> it does not appear to work. If we back off to ZK 3.4.x it works fine.
>
>
>
> It also appears that SOLR V8.x is currently packaged with ZK V3.4.14.
>
>
>
> Are there known solutions to the issues with ZK V3.5.5 and SOLR?
>
>
>
> Thanks for your help
>
>
>
> Paul Russell
>
> www.qflow.com
>
>
>