Setting up SolrCloud Behind Azure Application Gateway

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Setting up SolrCloud Behind Azure Application Gateway

Victor Kretzer
I'm attempting to set up SolrCloud for use with Sitecore 9.0.2. I want to set up my Azure Application Gateway with a TSL cert. I want a private IP for Sitecore and a public IP for accessing the Solr Admin Dashboard. My goal is to use Application Gateway for the TSL and then route to the backend using http protocol.

I currently have the following configuration:
                *             2 SolrCloud 6.6.6 nodes on 2 Azure Ubuntu 18.04 LTS VMs
                *             3 Zookeeper nodes on 3 Azure Ubuntu VMs
                *             A VPN with the IPs of all the above
                *             An application Gateway with:
                                o             public listener on port 443
                                o             public listener on port 80 (to eliminate the cert as a cause of my issues)
                                o             backend pool for the two sorlCloud VMs
                                o             an HTTP setting for Backend port 8983

I can access the dashboard for the nodes using:
                *             http://<node-pub-ip>:8983/solr/#/<http://%3cnode-pub-ip%3e:8983/solr/#/>

But not when using either of the following:
                *             https://<app-gtwy-ip>/solr/#<https://%3capp-gtwy-ip%3e/solr/#> with a public listener on port 443
                *             http://<app-gtwy-ip>/solr/#<http://%3capp-gtwy-ip%3e/solr/#> with a public listener on port 80

The private IPs of both SolrCloud VMs are reporting healthy on port 8983 with a 302-status code according to the default Backend Health monitor on Application Gateway.

I greatly appreciate any help provided.

Thanks,

Victor