Solr 6.6.2 build from source is failing

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Solr 6.6.2 build from source is failing

Guruprasad Jois
Hi,
    After Jan 15th maven is allowing only https connections to repo. But
solr 6.6.2 version uses http connection. So builds are failing.
Is there any workaround for this?

Below are the errors we are getting when we do ant ivy-bootstrap && ant
compile && ant package

ivy-bootstrap1:
    [mkdir] Created dir: /root/.ant/lib
     [echo] installing ivy 2.3.0 to /root/.ant/lib
      [get] Getting:
http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar
      [get] To: /root/.ant/lib/ivy-2.3.0.jar
      [get] Error opening connection java.io.IOException: Server
returned HTTP response code: 501 for URL:
http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar
      [get] Error opening connection java.io.IOException: Server
returned HTTP response code: 501 for URL:
http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar
      [get] Error opening connection java.io.IOException: Server
returned HTTP response code: 501 for URL:
http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar
      [get] Can't get
http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar
to /root/.ant/lib/ivy-2.3.0.jar


Regards,
Guru.
Reply | Threaded
Open this post in threaded view
|

Re: Solr 6.6.2 build from source is failing

Jan Høydahl / Cominvent
This is of course unfortunate, but we’ll most likely not release a 6.x version, so the official solution is to upgrade.
You can of course patch your local checkout of 6.x to fix the urls so you can build.
And if you make a Pull Request we may merge that to branch_6_6 even if there will not be a new release.

Jan

> 28. jan. 2020 kl. 11:46 skrev Guruprasad Jois <[hidden email]>:
>
> Hi,
>    After Jan 15th maven is allowing only https connections to repo. But
> solr 6.6.2 version uses http connection. So builds are failing.
> Is there any workaround for this?
>
> Below are the errors we are getting when we do ant ivy-bootstrap && ant
> compile && ant package
>
> ivy-bootstrap1:
>    [mkdir] Created dir: /root/.ant/lib
>     [echo] installing ivy 2.3.0 to /root/.ant/lib
>      [get] Getting:
> http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar
>      [get] To: /root/.ant/lib/ivy-2.3.0.jar
>      [get] Error opening connection java.io.IOException: Server
> returned HTTP response code: 501 for URL:
> http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar
>      [get] Error opening connection java.io.IOException: Server
> returned HTTP response code: 501 for URL:
> http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar
>      [get] Error opening connection java.io.IOException: Server
> returned HTTP response code: 501 for URL:
> http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar
>      [get] Can't get
> http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar
> to /root/.ant/lib/ivy-2.3.0.jar
>
>
> Regards,
> Guru.

Reply | Threaded
Open this post in threaded view
|

Re: Solr 6.6.2 build from source is failing

sevanthi
Hi Even I am facing issue with ant build for lucene6.0 version, even after
changing the URLS from http to https .

Can you please provide the exact change files to make ant build to be work.





--
Sent from: https://lucene.472066.n3.nabble.com/Solr-User-f472068.html