[Solr8.7] UI request reply empty after 8s

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Solr8.7] UI request reply empty after 8s

Bruno Mannina
Hi All,



I'm facing a problem with my Solr8.7.

When I do a query on my collection from the Solr UI, if the request takes
more than 8s nothing happens.

I mean, Solr UI answer a blank page. No error in log, no response, nothing
at all.

And if I do the same request just behind, the answer appears quickly as
expected.



Is there a UI timeout somewhere?



Thanks,

Bruno





--
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus
Reply | Threaded
Open this post in threaded view
|

RE: [Solr8.7] UI request reply empty after 8s

ufuk yılmaz
Hi,

A while ago I asked the same thing here. Looking at the source javascript code of the frontend app, I saw  a 10k millisecond timeout config in httpInterceptor inside app.js. I changed it to something much larger and results of long queries began to show.

Hope it helps

Sent from Mail for Windows 10

From: Bruno Mannina
Sent: 13 January 2021 16:39
To: [hidden email]
Subject: [Solr8.7] UI request reply empty after 8s

Hi All,

 

I'm facing a problem with my Solr8.7.

When I do a query on my collection from the Solr UI, if the request takes
more than 8s nothing happens.

I mean, Solr UI answer a blank page. No error in log, no response, nothing
at all.

And if I do the same request just behind, the answer appears quickly as
expected.

 

Is there a UI timeout somewhere?

 

Thanks,

Bruno

 



--
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus

Reply | Threaded
Open this post in threaded view
|

RE: [Solr8.7] UI request reply empty after 8s

Bruno Mannina
Hi,

Perfect !
it works when I increase the config.timeout (row 597).

The file app.js can be found here:
/opt/solr/server/solr-webapp/webapp/js/angular


-----Message d'origine-----
De : ufuk yılmaz [mailto:[hidden email]]
Envoyé : mercredi 13 janvier 2021 14:57
À : [hidden email]
Objet : RE: [Solr8.7] UI request reply empty after 8s

Hi,

A while ago I asked the same thing here. Looking at the source javascript code of the frontend app, I saw  a 10k millisecond timeout config in httpInterceptor inside app.js. I changed it to something much larger and results of long queries began to show.

Hope it helps

Sent from Mail for Windows 10

From: Bruno Mannina
Sent: 13 January 2021 16:39
To: [hidden email]
Subject: [Solr8.7] UI request reply empty after 8s

Hi All,



I'm facing a problem with my Solr8.7.

When I do a query on my collection from the Solr UI, if the request takes more than 8s nothing happens.

I mean, Solr UI answer a blank page. No error in log, no response, nothing at all.

And if I do the same request just behind, the answer appears quickly as expected.



Is there a UI timeout somewhere?



Thanks,

Bruno





--
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus



--
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus