Unable to create core [nutch] Caused by: enablePositionIncrements is not a valid option as of Lucene 5.0

classic Classic list List threaded Threaded
3 messages Options
S L
Reply | Threaded
Open this post in threaded view
|

Unable to create core [nutch] Caused by: enablePositionIncrements is not a valid option as of Lucene 5.0

S L
Hi,

I'm following the tutorial to set up nutch with solr. I'm using a supported
pair:  nutch 1.13 with solr 5.5.0. I get this error creating the nutch core
in solr.

$ ./bin/solr create -c nutch -d server/solr/configsets/nutch/conf/

Copying configuration to new core instance directory:
/home/ledermans/apache-solr/solr-5.5.0/server/solr/nutch

Creating new core 'nutch' using command:
http://localhost:8983/solr/admin/cores?action=CREATE&name=nutch&instanceDir=nutch


ERROR: Error CREATEing SolrCore 'nutch': Unable to create core [nutch]
Caused by: enablePositionIncrements is not a valid option as of Lucene 5.0


What am I missing?

Thanks.

Sol
Reply | Threaded
Open this post in threaded view
|

Re: Unable to create core [nutch] Caused by: enablePositionIncrements is not a valid option as of Lucene 5.0

BlackIce
My guess would be that you need to look at schema.xml and disable
PositionIncrements

On Thu, Sep 28, 2017 at 6:44 PM, Sol Lederman <[hidden email]>
wrote:

> Hi,
>
> I'm following the tutorial to set up nutch with solr. I'm using a supported
> pair:  nutch 1.13 with solr 5.5.0. I get this error creating the nutch core
> in solr.
>
> $ ./bin/solr create -c nutch -d server/solr/configsets/nutch/conf/
>
> Copying configuration to new core instance directory:
> /home/ledermans/apache-solr/solr-5.5.0/server/solr/nutch
>
> Creating new core 'nutch' using command:
> http://localhost:8983/solr/admin/cores?action=CREATE&
> name=nutch&instanceDir=nutch
>
>
> ERROR: Error CREATEing SolrCore 'nutch': Unable to create core [nutch]
> Caused by: enablePositionIncrements is not a valid option as of Lucene 5.0
>
>
> What am I missing?
>
> Thanks.
>
> Sol
>
S L
Reply | Threaded
Open this post in threaded view
|

Re: Unable to create core [nutch] Caused by: enablePositionIncrements is not a valid option as of Lucene 5.0

S L
Yeah, that worked. Thanks. I guess it's an issue with the tutorial for that
nutch/solr pair. I've run into a couple of other issues with the tutorial.
One I was able to workaround. The cleaner job dies with an IOException. It
seems to be a known problem.

Thanks again.

Sol

On Thu, Sep 28, 2017 at 11:37 AM, BlackIce <[hidden email]> wrote:

> My guess would be that you need to look at schema.xml and disable
> PositionIncrements
>
> On Thu, Sep 28, 2017 at 6:44 PM, Sol Lederman <[hidden email]>
> wrote:
>
> > Hi,
> >
> > I'm following the tutorial to set up nutch with solr. I'm using a
> supported
> > pair:  nutch 1.13 with solr 5.5.0. I get this error creating the nutch
> core
> > in solr.
> >
> > $ ./bin/solr create -c nutch -d server/solr/configsets/nutch/conf/
> >
> > Copying configuration to new core instance directory:
> > /home/ledermans/apache-solr/solr-5.5.0/server/solr/nutch
> >
> > Creating new core 'nutch' using command:
> > http://localhost:8983/solr/admin/cores?action=CREATE&
> > name=nutch&instanceDir=nutch
> >
> >
> > ERROR: Error CREATEing SolrCore 'nutch': Unable to create core [nutch]
> > Caused by: enablePositionIncrements is not a valid option as of Lucene
> 5.0
> >
> >
> > What am I missing?
> >
> > Thanks.
> >
> > Sol
> >
>