Upgrading minimum version of Maven to 3.1 from 3.0

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrading minimum version of Maven to 3.1 from 3.0

Sunil G
Hi Folks,

Recently we were doing build framework up-gradation for Yarn Ui. In order
to compile yarn-ui on various architectures, we were using
frontend-maven-plugin 0.0.22 version.
However build is failing in *ppc64le.* If we could use latest version of
frontend-maven-plugin, we could resolve this error. (such as using 1.1
version). But this requires maven version 3.1 minimum. YARN-6421 is
tracking this issue, and we thought we can propose to upgrade to maven 3.1

Kindly share your thoughts.

Thanks
+ Sunil
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading minimum version of Maven to 3.1 from 3.0

Akira Ajisaka-2
As I mentioned in YARN-6421. I'm +1 for upgrading to 3.1+ because
the latest version of Maven 3.0.x is quite old. (4 years ago)

We need to update dev-support/docker/Dockerfile to enable Maven 3.1+ for
precommit Jenkins job.

Regards,
Akira

On 2017/04/03 18:49, Sunil G wrote:

> Hi Folks,
>
> Recently we were doing build framework up-gradation for Yarn Ui. In order
> to compile yarn-ui on various architectures, we were using
> frontend-maven-plugin 0.0.22 version.
> However build is failing in *ppc64le.* If we could use latest version of
> frontend-maven-plugin, we could resolve this error. (such as using 1.1
> version). But this requires maven version 3.1 minimum. YARN-6421 is
> tracking this issue, and we thought we can propose to upgrade to maven 3.1
>
> Kindly share your thoughts.
>
> Thanks
> + Sunil
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading minimum version of Maven to 3.1 from 3.0

Junping Du-2
Thanks Sunil to bring it up. However, any reason not to go to latest version of maven (3.3+)? Even version 3.1 is quite old - released 3+ years from now (please refer: https://archive.apache.org/dist/maven/binaries/).
btw, I assume we only plan to change maven version on trunk given new YARN UI only merge to trunk branch. Isn't it?

Thanks,

Junping
________________________________________
From: Akira Ajisaka <[hidden email]>
Sent: Monday, April 03, 2017 10:02 PM
To: Sunil G; [hidden email]; [hidden email]; [hidden email]; [hidden email]
Subject: Re: Upgrading minimum version of Maven to 3.1 from 3.0

As I mentioned in YARN-6421. I'm +1 for upgrading to 3.1+ because
the latest version of Maven 3.0.x is quite old. (4 years ago)

We need to update dev-support/docker/Dockerfile to enable Maven 3.1+ for
precommit Jenkins job.

Regards,
Akira

On 2017/04/03 18:49, Sunil G wrote:

> Hi Folks,
>
> Recently we were doing build framework up-gradation for Yarn Ui. In order
> to compile yarn-ui on various architectures, we were using
> frontend-maven-plugin 0.0.22 version.
> However build is failing in *ppc64le.* If we could use latest version of
> frontend-maven-plugin, we could resolve this error. (such as using 1.1
> version). But this requires maven version 3.1 minimum. YARN-6421 is
> tracking this issue, and we thought we can propose to upgrade to maven 3.1
>
> Kindly share your thoughts.
>
> Thanks
> + Sunil
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading minimum version of Maven to 3.1 from 3.0

Sunil G
Thanks Akira and Junping.

@Junping. Yes, we plan to change this only in trunk and new YARN UI is
available there.
I also feel that there is no issue in moving to a latest version such as
3.3.

+ Sunil

On Tue, Apr 4, 2017 at 11:35 PM Junping Du <[hidden email]> wrote:

> Thanks Sunil to bring it up. However, any reason not to go to latest
> version of maven (3.3+)? Even version 3.1 is quite old - released 3+ years
> from now (please refer: https://archive.apache.org/dist/maven/binaries/).
> btw, I assume we only plan to change maven version on trunk given new YARN
> UI only merge to trunk branch. Isn't it?
>
> Thanks,
>
> Junping
> ________________________________________
> From: Akira Ajisaka <[hidden email]>
> Sent: Monday, April 03, 2017 10:02 PM
> To: Sunil G; [hidden email]; [hidden email];
> [hidden email]; [hidden email]
> Subject: Re: Upgrading minimum version of Maven to 3.1 from 3.0
>
> As I mentioned in YARN-6421. I'm +1 for upgrading to 3.1+ because
> the latest version of Maven 3.0.x is quite old. (4 years ago)
>
> We need to update dev-support/docker/Dockerfile to enable Maven 3.1+ for
> precommit Jenkins job.
>
> Regards,
> Akira
>
> On 2017/04/03 18:49, Sunil G wrote:
> > Hi Folks,
> >
> > Recently we were doing build framework up-gradation for Yarn Ui. In order
> > to compile yarn-ui on various architectures, we were using
> > frontend-maven-plugin 0.0.22 version.
> > However build is failing in *ppc64le.* If we could use latest version of
> > frontend-maven-plugin, we could resolve this error. (such as using 1.1
> > version). But this requires maven version 3.1 minimum. YARN-6421 is
> > tracking this issue, and we thought we can propose to upgrade to maven
> 3.1
> >
> > Kindly share your thoughts.
> >
> > Thanks
> > + Sunil
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading minimum version of Maven to 3.1 from 3.0

Akira Ajisaka-2
Agreed to upgrade to 3.3+ and change the version only in trunk.

-Akira

On 2017/04/05 11:21, Sunil G wrote:

> Thanks Akira and Junping.
>
> @Junping. Yes, we plan to change this only in trunk and new YARN UI is
> available there.
> I also feel that there is no issue in moving to a latest version such as
> 3.3.
>
> + Sunil
>
> On Tue, Apr 4, 2017 at 11:35 PM Junping Du <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Thanks Sunil to bring it up. However, any reason not to go to latest
>     version of maven (3.3+)? Even version 3.1 is quite old - released 3+
>     years from now (please refer:
>     https://archive.apache.org/dist/maven/binaries/).
>     btw, I assume we only plan to change maven version on trunk given
>     new YARN UI only merge to trunk branch. Isn't it?
>
>     Thanks,
>
>     Junping
>     ________________________________________
>     From: Akira Ajisaka <[hidden email] <mailto:[hidden email]>>
>     Sent: Monday, April 03, 2017 10:02 PM
>     To: Sunil G; [hidden email]
>     <mailto:[hidden email]>; [hidden email]
>     <mailto:[hidden email]>; [hidden email]
>     <mailto:[hidden email]>; [hidden email]
>     <mailto:[hidden email]>
>     Subject: Re: Upgrading minimum version of Maven to 3.1 from 3.0
>
>     As I mentioned in YARN-6421. I'm +1 for upgrading to 3.1+ because
>     the latest version of Maven 3.0.x is quite old. (4 years ago)
>
>     We need to update dev-support/docker/Dockerfile to enable Maven 3.1+ for
>     precommit Jenkins job.
>
>     Regards,
>     Akira
>
>     On 2017/04/03 18:49, Sunil G wrote:
>     > Hi Folks,
>     >
>     > Recently we were doing build framework up-gradation for Yarn Ui.
>     In order
>     > to compile yarn-ui on various architectures, we were using
>     > frontend-maven-plugin 0.0.22 version.
>     > However build is failing in *ppc64le.* If we could use latest
>     version of
>     > frontend-maven-plugin, we could resolve this error. (such as using 1.1
>     > version). But this requires maven version 3.1 minimum. YARN-6421 is
>     > tracking this issue, and we thought we can propose to upgrade to
>     maven 3.1
>     >
>     > Kindly share your thoughts.
>     >
>     > Thanks
>     > + Sunil
>     >
>
>     ---------------------------------------------------------------------
>     To unsubscribe, e-mail: [hidden email]
>     <mailto:[hidden email]>
>     For additional commands, e-mail: [hidden email]
>     <mailto:[hidden email]>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading minimum version of Maven to 3.1 from 3.0

Akira Ajisaka-2
Based on the positive feedback from Junping, filed HADOOP-14285 for the
update.
Discussion can continue in the JIRA.

Thanks,
Akira

On 2017/04/05 12:56, Akira Ajisaka wrote:

> Agreed to upgrade to 3.3+ and change the version only in trunk.
>
> -Akira
>
> On 2017/04/05 11:21, Sunil G wrote:
>> Thanks Akira and Junping.
>>
>> @Junping. Yes, we plan to change this only in trunk and new YARN UI is
>> available there.
>> I also feel that there is no issue in moving to a latest version such as
>> 3.3.
>>
>> + Sunil
>>
>> On Tue, Apr 4, 2017 at 11:35 PM Junping Du <[hidden email]
>> <mailto:[hidden email]>> wrote:
>>
>>     Thanks Sunil to bring it up. However, any reason not to go to latest
>>     version of maven (3.3+)? Even version 3.1 is quite old - released 3+
>>     years from now (please refer:
>>     https://archive.apache.org/dist/maven/binaries/).
>>     btw, I assume we only plan to change maven version on trunk given
>>     new YARN UI only merge to trunk branch. Isn't it?
>>
>>     Thanks,
>>
>>     Junping
>>     ________________________________________
>>     From: Akira Ajisaka <[hidden email]
>> <mailto:[hidden email]>>
>>     Sent: Monday, April 03, 2017 10:02 PM
>>     To: Sunil G; [hidden email]
>>     <mailto:[hidden email]>; [hidden email]
>>     <mailto:[hidden email]>; [hidden email]
>>     <mailto:[hidden email]>; [hidden email]
>>     <mailto:[hidden email]>
>>     Subject: Re: Upgrading minimum version of Maven to 3.1 from 3.0
>>
>>     As I mentioned in YARN-6421. I'm +1 for upgrading to 3.1+ because
>>     the latest version of Maven 3.0.x is quite old. (4 years ago)
>>
>>     We need to update dev-support/docker/Dockerfile to enable Maven
>> 3.1+ for
>>     precommit Jenkins job.
>>
>>     Regards,
>>     Akira
>>
>>     On 2017/04/03 18:49, Sunil G wrote:
>>     > Hi Folks,
>>     >
>>     > Recently we were doing build framework up-gradation for Yarn Ui.
>>     In order
>>     > to compile yarn-ui on various architectures, we were using
>>     > frontend-maven-plugin 0.0.22 version.
>>     > However build is failing in *ppc64le.* If we could use latest
>>     version of
>>     > frontend-maven-plugin, we could resolve this error. (such as
>> using 1.1
>>     > version). But this requires maven version 3.1 minimum. YARN-6421 is
>>     > tracking this issue, and we thought we can propose to upgrade to
>>     maven 3.1
>>     >
>>     > Kindly share your thoughts.
>>     >
>>     > Thanks
>>     > + Sunil
>>     >
>>
>>     ---------------------------------------------------------------------
>>     To unsubscribe, e-mail: [hidden email]
>>     <mailto:[hidden email]>
>>     For additional commands, e-mail: [hidden email]
>>     <mailto:[hidden email]>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]