Wild card searching not working properly

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Wild card searching not working properly

Roopesh P Raj
Dear All,

I am using solr in my project. But I find that wildcard searching is not
working properly.

For example, following are the search queries and the corresponding results
tomcat* -> 3 results
tomca* -> 0 results
tom*at -> 0 results
tom~at -> 0 results
Where as all the queries should have returned the same result. Can
anyone please tell me what I have to do to make this proper.

Thanks in advance
Roopesh

------------------
DigitalGlue, India



Reply | Threaded
Open this post in threaded view
|

Re: Wild card searching not working properly

hossman

Problems like this depend heavily on example what the fieldtype and
"index" analyzer is for the field you are querying on.  it's important to
keep in mind that wildcard and fuzzy queries are not "analyzed" so things
like lowercasing and stemming have to be taken into account -- typically
it's useful to use copyField to have a special version of your field with
simplified analysis for doing wildcard searches on.

as for your specific problem: given the limited information you've
provided, no guesses immediately jump out at me as to what you should od
to get things working the way you want ... it depends on your schema, and
what the orriginal text was in those 3 documents you want to match.

: For example, following are the search queries and the corresponding results
: tomcat* -> 3 results
: tomca* -> 0 results
: tom*at -> 0 results
: tom~at -> 0 results


-Hoss