Zookeeper upgrade required with Solr upgrade?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Zookeeper upgrade required with Solr upgrade?

Rahul Goswami
Hello,
We are running a SolrCloud (7.2.1) cluster and upgrading to Solr 7.7.2. We
run a separate multi node zookeeper ensemble which currently runs
Zookeeper 3.4.10.
Is it also required to upgrade Zookeeper (to  3.4.14 as per change.txt for
Solr 7.7.2) along with Solr ?

I tried a few basic updates requests for a 2 node SolrCloud cluster with
the older (3.4.10) zookeeper and it seemed to work fine. But just want to
know if there are any caveats I should be aware of.

Thanks,
Rahul
Reply | Threaded
Open this post in threaded view
|

Re: Zookeeper upgrade required with Solr upgrade?

Erick Erickson
That should be OK. There were no code changes necessary for that upgrade. see SOLR-13363

> On Feb 12, 2020, at 5:34 PM, Rahul Goswami <[hidden email]> wrote:
>
> Hello,
> We are running a SolrCloud (7.2.1) cluster and upgrading to Solr 7.7.2. We
> run a separate multi node zookeeper ensemble which currently runs
> Zookeeper 3.4.10.
> Is it also required to upgrade Zookeeper (to  3.4.14 as per change.txt for
> Solr 7.7.2) along with Solr ?
>
> I tried a few basic updates requests for a 2 node SolrCloud cluster with
> the older (3.4.10) zookeeper and it seemed to work fine. But just want to
> know if there are any caveats I should be aware of.
>
> Thanks,
> Rahul

Reply | Threaded
Open this post in threaded view
|

Re: Zookeeper upgrade required with Solr upgrade?

Rahul Goswami
Thanks Eric. Also, thanks for that little pointer about the JIRA. Just to
make sure I also checked for the upgrade JIRAs for other two intermediate
Zookeeper versions 3.4.11 and 3.4.13 between Solr 7.2.1 and Solr 7.7.2 and
they didn't seem to contain any Solr code changes either.

On Thu, Feb 13, 2020 at 9:26 AM Erick Erickson <[hidden email]>
wrote:

> That should be OK. There were no code changes necessary for that upgrade.
> see SOLR-13363
>
> > On Feb 12, 2020, at 5:34 PM, Rahul Goswami <[hidden email]>
> wrote:
> >
> > Hello,
> > We are running a SolrCloud (7.2.1) cluster and upgrading to Solr 7.7.2.
> We
> > run a separate multi node zookeeper ensemble which currently runs
> > Zookeeper 3.4.10.
> > Is it also required to upgrade Zookeeper (to  3.4.14 as per change.txt
> for
> > Solr 7.7.2) along with Solr ?
> >
> > I tried a few basic updates requests for a 2 node SolrCloud cluster with
> > the older (3.4.10) zookeeper and it seemed to work fine. But just want to
> > know if there are any caveats I should be aware of.
> >
> > Thanks,
> > Rahul
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Zookeeper upgrade required with Solr upgrade?

Erick Erickson
Yeah, 3.4.x upgrades were pretty strainght-forward.

The 3.5.5 upgrade was trickier, but the problems were in the
admin UI. The admin UI uses several “4 letter words” to do its
ZooKeeper reporting, and that required explicit permissions, but IIRC
that all only affected the admin UI reporting about Zookeeper. There
were a _lot_ of Solr changes, but that was mostly cosmetic and mostly
in the test code.

Best,
Erick

> On Feb 13, 2020, at 4:07 PM, Rahul Goswami <[hidden email]> wrote:
>
> Thanks Eric. Also, thanks for that little pointer about the JIRA. Just to
> make sure I also checked for the upgrade JIRAs for other two intermediate
> Zookeeper versions 3.4.11 and 3.4.13 between Solr 7.2.1 and Solr 7.7.2 and
> they didn't seem to contain any Solr code changes either.
>
> On Thu, Feb 13, 2020 at 9:26 AM Erick Erickson <[hidden email]>
> wrote:
>
>> That should be OK. There were no code changes necessary for that upgrade.
>> see SOLR-13363
>>
>>> On Feb 12, 2020, at 5:34 PM, Rahul Goswami <[hidden email]>
>> wrote:
>>>
>>> Hello,
>>> We are running a SolrCloud (7.2.1) cluster and upgrading to Solr 7.7.2.
>> We
>>> run a separate multi node zookeeper ensemble which currently runs
>>> Zookeeper 3.4.10.
>>> Is it also required to upgrade Zookeeper (to  3.4.14 as per change.txt
>> for
>>> Solr 7.7.2) along with Solr ?
>>>
>>> I tried a few basic updates requests for a 2 node SolrCloud cluster with
>>> the older (3.4.10) zookeeper and it seemed to work fine. But just want to
>>> know if there are any caveats I should be aware of.
>>>
>>> Thanks,
>>> Rahul
>>
>>