bin/solr auth enable

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

bin/solr auth enable

David Glick
When I issue “bin/solr auth enable -prompt true -blockUnknown true”, I get a Null Pointer Exception.  I’m using the 8.5.1 release.  Am I doing something wrong?

Thanks.

Sent from my iPhone
Reply | Threaded
Open this post in threaded view
|

Re: bin/solr auth enable

Jason Gerlowski
Hi David,

I tried this out locally but couldn't reproduce. The command you
provided above works just fine for me.

Can you tell us a bit about your environment?  Do you have the full
stack trace of the NPE handy?

Best,

Jason

On Fri, Jul 24, 2020 at 8:01 PM David Glick <[hidden email]> wrote:
>
> When I issue “bin/solr auth enable -prompt true -blockUnknown true”, I get a Null Pointer Exception.  I’m using the 8.5.1 release.  Am I doing something wrong?
>
> Thanks.
>
> Sent from my iPhone
Reply | Threaded
Open this post in threaded view
|

Re: bin/solr auth enable

David Glick
Hi Jason,

I don’t have the full stack trace unfortunately.  The environment is a Docker SolrCloud on Ubuntu 20.04.  It has three Zookeepers and three Solrs.  I run the command as:

docker exec -it solr1 “bin/solr auth enable -prompt true“

I also tried a shell in the container and  typing bin/solr auth enable -prompt true

Both fail with the NPE.

Thanks,

David.

Sent from my iPhone

> On Jul 31, 2020, at 7:03 PM, Jason Gerlowski <[hidden email]> wrote:
>
> Hi David,
>
> I tried this out locally but couldn't reproduce. The command you
> provided above works just fine for me.
>
> Can you tell us a bit about your environment?  Do you have the full
> stack trace of the NPE handy?
>
> Best,
>
> Jason
>
>> On Fri, Jul 24, 2020 at 8:01 PM David Glick <[hidden email]> wrote:
>>
>> When I issue “bin/solr auth enable -prompt true -blockUnknown true”, I get a Null Pointer Exception.  I’m using the 8.5.1 release.  Am I doing something wrong?
>>
>> Thanks.
>>
>> Sent from my iPhone