field collapsing

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

field collapsing

muddassir hasan
Hi,

I have unsuccessfully tried to apply solr field collapsing patches available at

https://issues.apache.org/jira/browse/SOLR-236?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

One of the patch could be applied to trunk but it could not be compiled.

Please let me know which of the available field collapsing patch could be applied to solr trunk or release 1.2.0.

Thanks.

M.Hasan

       
---------------------------------
 Now you can chat without downloading messenger. Click here to know how.
Reply | Threaded
Open this post in threaded view
|

Re: field collapsing

dsteiger
The latest one won't apply to the trunk because it's too old.  It hasn't been updated to match
changes made to Solr since mid-February.  One of the things I know has to change is that in
CollapseComponent->prepare/process, the parameters need to change to just accept a ResponseBuilder.

Other than that, I'm not sure what will have to be changed.  I'm not planning on updating our Solr
build until 1.3 is released.

Doug

muddassir hasan wrote:

> Hi,
>
> I have unsuccessfully tried to apply solr field collapsing patches available at
>
> https://issues.apache.org/jira/browse/SOLR-236?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
>
> One of the patch could be applied to trunk but it could not be compiled.
>
> Please let me know which of the available field collapsing patch could be applied to solr trunk or release 1.2.0.
>
> Thanks.
>
> M.Hasan
>
>        
> ---------------------------------
>  Now you can chat without downloading messenger. Click here to know how.
Reply | Threaded
Open this post in threaded view
|

Re: field collapsing

muddassir hasan
Hi Doug,

Please let me know on which solr revision you applied patch.

Thanks.
M. Hasan

Doug Steigerwald <[hidden email]> wrote: The latest one won't apply to the trunk because it's too old.  It hasn't been updated to match
changes made to Solr since mid-February.  One of the things I know has to change is that in
CollapseComponent->prepare/process, the parameters need to change to just accept a ResponseBuilder.

Other than that, I'm not sure what will have to be changed.  I'm not planning on updating our Solr
build until 1.3 is released.

Doug

muddassir hasan wrote:

> Hi,
>
> I have unsuccessfully tried to apply solr field collapsing patches available at
>
> https://issues.apache.org/jira/browse/SOLR-236?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
>
> One of the patch could be applied to trunk but it could not be compiled.
>
> Please let me know which of the available field collapsing patch could be applied to solr trunk or release 1.2.0.
>
> Thanks.
>
> M.Hasan
>
>        
> ---------------------------------
>  Now you can chat without downloading messenger. Click here to know how.


       
---------------------------------
 Save all your chat conversations. Find them online.
Reply | Threaded
Open this post in threaded view
|

Re: field collapsing

dsteiger
We're on r614955.

On Wednesday 19 March 2008 11:33:36 am muddassir hasan wrote:

> Hi Doug,
>
> Please let me know on which solr revision you applied patch.
>
> Thanks.
> M. Hasan
>
> Doug Steigerwald <[hidden email]> wrote: The latest
> one won't apply to the trunk because it's too old.  It hasn't been updated
> to match changes made to Solr since mid-February.  One of the things I know
> has to change is that in CollapseComponent->prepare/process, the parameters
> need to change to just accept a ResponseBuilder.
>
> Other than that, I'm not sure what will have to be changed.  I'm not
> planning on updating our Solr build until 1.3 is released.
>
> Doug
>
> muddassir hasan wrote:
> > Hi,
> >
> > I have unsuccessfully tried to apply solr field collapsing patches
> > available at
> >
> > https://issues.apache.org/jira/browse/SOLR-236?page=com.atlassian.jira.pl
> >ugin.system.issuetabpanels:all-tabpanel
> >
> > One of the patch could be applied to trunk but it could not be compiled.
> >
> > Please let me know which of the available field collapsing patch could be
> > applied to solr trunk or release 1.2.0.
> >
> > Thanks.
> >
> > M.Hasan
> >
> >
> > ---------------------------------
> >  Now you can chat without downloading messenger. Click here to know how.
>
> ---------------------------------
>  Save all your chat conversations. Find them online.

--
Doug