[jira] [Commented] (NUTCH-2671) Upgrade ant ivy library

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (NUTCH-2671) Upgrade ant ivy library

Tim Allison (Jira)

    [ https://issues.apache.org/jira/browse/NUTCH-2671?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16963954#comment-16963954 ]

Sebastian Nagel commented on NUTCH-2671:
----------------------------------------

[Ivy 2.5.0|https://ant.apache.org/ivy/history/2.5.0/release-notes.html] has been released. We might try to upgrade. Tests with the Nutch build and the 2.5.0 release candidate have been successful, see discussion in IVY-1586. The upgrade also requires:
- (eventually) modify retrieve pattern and include "classifier" (see IVY-1586)
- add note to CHANGES.txt about the incompatibility of Ivy caches are not compatible between versions 2.4.0 and 2.5.0
- make sure the Ivy caches in the Jenkins nightly build machines are cleaned or separate caches in workspace are used.


> Upgrade ant ivy library
> -----------------------
>
>                 Key: NUTCH-2671
>                 URL: https://issues.apache.org/jira/browse/NUTCH-2671
>             Project: Nutch
>          Issue Type: Sub-task
>          Components: build
>    Affects Versions: 2.4, 1.16
>            Reporter: Sebastian Nagel
>            Assignee: Sebastian Nagel
>            Priority: Major
>             Fix For: 1.17
>
>
> Upgrade the [ant ivy library|https://ant.apache.org/ivy/index.html] to latest release (2.5.0-rc1) to address NUTCH-2669.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)