[jira] [Commented] (TIKA-2032) OptimaizeLangDetector can not be resolved

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (TIKA-2032) OptimaizeLangDetector can not be resolved

Tim Allison (Jira)

    [ https://issues.apache.org/jira/browse/TIKA-2032?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15385793#comment-15385793 ]

Eli Trucco commented on TIKA-2032:
----------------------------------

OptimaizeLangDetector is not included in Tika Core. maybe you need to add tika-app to the maven dependency instead.

> OptimaizeLangDetector can not be resolved
> ------------------------------------------
>
>                 Key: TIKA-2032
>                 URL: https://issues.apache.org/jira/browse/TIKA-2032
>             Project: Tika
>          Issue Type: Bug
>          Components: languageidentifier
>    Affects Versions: 1.13
>         Environment: Ubuntu 14.04, Eclipse Mars 2, Java 7 jdk and Java 8 jdk
>            Reporter: Christoph
>
> In my project I want to use the Tika language detector.
> I added the maven dependency for tika core.
> From the Javadocs I read that I can use the OptimaizeLangDetector().
> However, Eclipse always tells me, hat  OptimaizeLangDetector can not be resolved.
> When I look into the tika-core package/lib, I do not see the above mentioned class. Seems missing or am I doing sth wrong?
> Thanks in advance!



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)