[jira] [Commented] (TIKA-2959) TabularFormatsTest test fails in Germany

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (TIKA-2959) TabularFormatsTest test fails in Germany

ASF GitHub Bot (Jira)

    [ https://issues.apache.org/jira/browse/TIKA-2959?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16945122#comment-16945122 ]

Hudson commented on TIKA-2959:
------------------------------

SUCCESS: Integrated in Jenkins build tika-branch-1x #240 (See [https://builds.apache.org/job/tika-branch-1x/240/])
TIKA-2959: create localized test results because of tests failing in (tilman: [https://github.com/apache/tika/commit/d217d533db16749876ea4a86179a034cbc41762d])
* (edit) tika-parsers/src/test/java/org/apache/tika/parser/TabularFormatsTest.java


> TabularFormatsTest test fails in Germany
> ----------------------------------------
>
>                 Key: TIKA-2959
>                 URL: https://issues.apache.org/jira/browse/TIKA-2959
>             Project: Tika
>          Issue Type: Bug
>          Components: parser
>    Affects Versions: 1.22
>            Reporter: Tilman Hausherr
>            Priority: Minor
>              Labels: Locale
>             Fix For: 2.0.0, 1.23
>
>
> So I wanted to build tika from source, and failed:
> {noformat}
> TabularFormatsTest.testSAS7BDAT:229->assertContents:216 en_US Wrong text in row 9 and column 7 - 03(MAR|Mar)(63|1963)[:\s]09:46:40(.00)? vs 03Mär1963:09:46:40.00
> TabularFormatsTest.testXLS:236->assertContents:216 en_US Wrong text in row 9 and column 7 - 03(MAR|Mar)(63|1963)[:\s]09:46:40(.00)? vs 03Mär63 09:46:40
> TabularFormatsTest.testXLSB:250->assertContents:216 en_US Wrong text in row 9 and column 7 - 03(MAR|Mar)(63|1963)[:\s]09:46:40(.00)? vs 03Mär63 09:46:40
> TabularFormatsTest.testXLSX:243->assertContents:216 en_US Wrong text in row 9 and column 7 - 03(MAR|Mar)(63|1963)[:\s]09:46:40(.00)? vs 03Mär63 09:46:40
> {noformat}
> It fails because the expected "Mar" is not identical to "Mär". Setting the Locale to the US in setup doesn't help. Until there is a better solution, I'm taking Tim's suggestion to adust the expected results. See also thread on dev:
> https://mail-archives.apache.org/mod_mbox/tika-dev/201910.mbox/%3Cd55a024f-5044-a8cd-9745-399bb53711a7%40t-online.de%3E



--
This message was sent by Atlassian Jira
(v8.3.4#803005)