[jira] Created: (HADOOP-6896) Remove the Util separation in FileContext

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (HADOOP-6896) Remove the Util separation in FileContext

Tim Allison (Jira)
Remove the Util separation in FileContext
-----------------------------------------

                 Key: HADOOP-6896
                 URL: https://issues.apache.org/jira/browse/HADOOP-6896
             Project: Hadoop Common
          Issue Type: Improvement
          Components: fs
            Reporter: Owen O'Malley
            Assignee: Sanjay Radia


I think from a usability point of view, it would be nicer to write:

{code}
fc.exist(path);
{code}

instead of:

{code}
fc.utils().exist(path);
{code}

We should use the javadoc to mark the fact that the util functions are not atomic.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.