[jira] [Created] (LUCENE-3376) Move ReusableAnalyzerBase into core

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Created] (LUCENE-3376) Move ReusableAnalyzerBase into core

Walter (Jira)
Move ReusableAnalyzerBase into core
-----------------------------------

                 Key: LUCENE-3376
                 URL: https://issues.apache.org/jira/browse/LUCENE-3376
             Project: Lucene - Java
          Issue Type: Improvement
          Components: modules/analysis
            Reporter: Chris Male


In LUCENE-2309 it was suggested that we should make Analyzer reusability compulsory.  ReusableAnalyzerBase is a fantastic way to drive reusability so lets move it into core (so that we can then change all impls over to using it).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (LUCENE-3376) Move ReusableAnalyzerBase into core

Walter (Jira)

    [ https://issues.apache.org/jira/browse/LUCENE-3376?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13085499#comment-13085499 ]

Robert Muir commented on LUCENE-3376:
-------------------------------------

I agree: we should push this logic into analyzer.

the first step to doing this is sort of a nightmare, i think that is to remove tokenStream() and only support reusableTokenStream() in all the tests etc... it seems easy but its a ton of work actually.

> Move ReusableAnalyzerBase into core
> -----------------------------------
>
>                 Key: LUCENE-3376
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3376
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: modules/analysis
>            Reporter: Chris Male
>
> In LUCENE-2309 it was suggested that we should make Analyzer reusability compulsory.  ReusableAnalyzerBase is a fantastic way to drive reusability so lets move it into core (so that we can then change all impls over to using it).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (LUCENE-3376) Move ReusableAnalyzerBase into core

Walter (Jira)
In reply to this post by Walter (Jira)

    [ https://issues.apache.org/jira/browse/LUCENE-3376?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13085506#comment-13085506 ]

Chris Male commented on LUCENE-3376:
------------------------------------

My plan was to move the class ReusableAnalyzerBase into core and then port all Analyzers over to using it.  Then I would drop tokenStream() and rename ReusableAnalyzerBase to just Analyzer.

Manageable?

> Move ReusableAnalyzerBase into core
> -----------------------------------
>
>                 Key: LUCENE-3376
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3376
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: modules/analysis
>            Reporter: Chris Male
>
> In LUCENE-2309 it was suggested that we should make Analyzer reusability compulsory.  ReusableAnalyzerBase is a fantastic way to drive reusability so lets move it into core (so that we can then change all impls over to using it).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[jira] [Updated] (LUCENE-3376) Move ReusableAnalyzerBase into core

Walter (Jira)
In reply to this post by Walter (Jira)

     [ https://issues.apache.org/jira/browse/LUCENE-3376?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Chris Male updated LUCENE-3376:
-------------------------------

    Attachment: LUCENE-3376.patch

Patch which moves ReusableAnalyzerBase into core and updates all references.  

Command:

{code}
svn move modules/analysis/common/src/java/org/apache/lucene/analysis/util/ReusableAnalyzerBase.java lucene/src/java/org/apache/lucene/analysis/ReusableAnalyzerBase.java
{code}

> Move ReusableAnalyzerBase into core
> -----------------------------------
>
>                 Key: LUCENE-3376
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3376
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: modules/analysis
>            Reporter: Chris Male
>         Attachments: LUCENE-3376.patch
>
>
> In LUCENE-2309 it was suggested that we should make Analyzer reusability compulsory.  ReusableAnalyzerBase is a fantastic way to drive reusability so lets move it into core (so that we can then change all impls over to using it).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[jira] [Updated] (LUCENE-3376) Move ReusableAnalyzerBase into core

Walter (Jira)
In reply to this post by Walter (Jira)

     [ https://issues.apache.org/jira/browse/LUCENE-3376?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Chris Male updated LUCENE-3376:
-------------------------------

    Attachment: LUCENE-3376.patch

Updated patch including CHANGES.txt entry.  Will commit tomorrow

> Move ReusableAnalyzerBase into core
> -----------------------------------
>
>                 Key: LUCENE-3376
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3376
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: modules/analysis
>            Reporter: Chris Male
>         Attachments: LUCENE-3376.patch, LUCENE-3376.patch
>
>
> In LUCENE-2309 it was suggested that we should make Analyzer reusability compulsory.  ReusableAnalyzerBase is a fantastic way to drive reusability so lets move it into core (so that we can then change all impls over to using it).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[jira] [Resolved] (LUCENE-3376) Move ReusableAnalyzerBase into core

Walter (Jira)
In reply to this post by Walter (Jira)

     [ https://issues.apache.org/jira/browse/LUCENE-3376?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Chris Male resolved LUCENE-3376.
--------------------------------

       Resolution: Fixed
    Fix Version/s: 4.0
         Assignee: Chris Male

Committed revision 1160117.

> Move ReusableAnalyzerBase into core
> -----------------------------------
>
>                 Key: LUCENE-3376
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3376
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: modules/analysis
>            Reporter: Chris Male
>            Assignee: Chris Male
>             Fix For: 4.0
>
>         Attachments: LUCENE-3376.patch, LUCENE-3376.patch
>
>
> In LUCENE-2309 it was suggested that we should make Analyzer reusability compulsory.  ReusableAnalyzerBase is a fantastic way to drive reusability so lets move it into core (so that we can then change all impls over to using it).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]