[jira] [Created] (NUTCH-2759) bin/crawl: Rename option --num-slaves

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Created] (NUTCH-2759) bin/crawl: Rename option --num-slaves

Sebastian Nagel (Jira)
Sebastian Nagel created NUTCH-2759:
--------------------------------------

             Summary: bin/crawl: Rename option --num-slaves
                 Key: NUTCH-2759
                 URL: https://issues.apache.org/jira/browse/NUTCH-2759
             Project: Nutch
          Issue Type: Improvement
          Components: bin
    Affects Versions: 1.16
            Reporter: Sebastian Nagel
             Fix For: 1.17


The option {{--num-slaves}} of the script bin/crawl it isn't really precise: there is no need to set it to the actual number of nodes in the Hadoop cluster. In addition, Hadoop now uses the term "worker" , see HADOOP-13209.

Renaming the option to {{\--num-fetcher-tasks}} or {{\--num-fetcher-workers}} would be more precise.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)