[jira] Created: (TIKA-175) Retrotranslate Tika for use in Java 1.4 environments

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (TIKA-175) Retrotranslate Tika for use in Java 1.4 environments

Tim Allison (Jira)
Retrotranslate Tika for use in Java 1.4 environments
----------------------------------------------------

                 Key: TIKA-175
                 URL: https://issues.apache.org/jira/browse/TIKA-175
             Project: Tika
          Issue Type: New Feature
          Components: packaging
            Reporter: Jukka Zitting


I'd like to use Tika in Apache Jackrabbit, but currently we can't do so because Jackrabbit specifies Java 1.4 as the base platform and using Tika would force an upgrade to Java 5. Jackrabbit like many other projects will eventually upgrade to Java 5, but it would be very nice to be able to use Tika already before that.

We could achieve this by using the Retrotranslator plugin (http://mojo.codehaus.org/retrotranslator-maven-plugin/)  to automatically generate a Java 1.4 -compatible version of the Tika jar. This version could then be used by projects like Apache Jackrabbit.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (TIKA-175) Retrotranslate Tika for use in Java 1.4 environments

Tim Allison (Jira)

     [ https://issues.apache.org/jira/browse/TIKA-175?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jukka Zitting updated TIKA-175:
-------------------------------

    Attachment: TIKA-175.patch

Attached proposed patch (TIKA-175.patch).

> Retrotranslate Tika for use in Java 1.4 environments
> ----------------------------------------------------
>
>                 Key: TIKA-175
>                 URL: https://issues.apache.org/jira/browse/TIKA-175
>             Project: Tika
>          Issue Type: New Feature
>          Components: packaging
>            Reporter: Jukka Zitting
>         Attachments: TIKA-175.patch
>
>
> I'd like to use Tika in Apache Jackrabbit, but currently we can't do so because Jackrabbit specifies Java 1.4 as the base platform and using Tika would force an upgrade to Java 5. Jackrabbit like many other projects will eventually upgrade to Java 5, but it would be very nice to be able to use Tika already before that.
> We could achieve this by using the Retrotranslator plugin (http://mojo.codehaus.org/retrotranslator-maven-plugin/)  to automatically generate a Java 1.4 -compatible version of the Tika jar. This version could then be used by projects like Apache Jackrabbit.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.