[jira] [Created] (TIKA-1833) NoClassDefFoundError for POIXMLTypeLoader

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Created] (TIKA-1833) NoClassDefFoundError for POIXMLTypeLoader

David Eric Pugh (Jira)
Mohammed Manna created TIKA-1833:
------------------------------------

             Summary: NoClassDefFoundError for POIXMLTypeLoader
                 Key: TIKA-1833
                 URL: https://issues.apache.org/jira/browse/TIKA-1833
             Project: Tika
          Issue Type: Bug
            Reporter: Mohammed Manna


I downloaded tika-app-1.11.jar which has all the necessary dependencies (checked using 7zip opener and checked the classes). I tried to parse .doc, .docx files for my project, but it is throwing error (not exception). The stack trace is as follows:

java.lang.NoClassDefFoundError: org/apache/poi/POIXMLTypeLoader
        at org.openxmlformats.schemas.wordprocessingml.x2006.main.DocumentDocument$Factory.parse(Unknown Source)
        at org.apache.poi.xwpf.usermodel.XWPFDocument.onDocumentRead(XWPFDocument.java:158)
        at org.apache.poi.POIXMLDocument.load(POIXMLDocument.java:167)
        at org.apache.poi.xwpf.usermodel.XWPFDocument.<init>(XWPFDocument.java:119)
        at org.apache.poi.xwpf.extractor.XWPFWordExtractor.<init>(XWPFWordExtractor.java:59)
        at org.apache.poi.extractor.ExtractorFactory.createExtractor(ExtractorFactory.java:204)
        at org.apache.tika.parser.microsoft.ooxml.OOXMLExtractorFactory.parse(OOXMLExtractorFactory.java:86)
        at org.apache.tika.parser.microsoft.ooxml.OOXMLParser.parse(OOXMLParser.java:87)
        at org.apache.tika.parser.CompositeParser.parse(CompositeParser.java:280)
        at org.apache.tika.parser.CompositeParser.parse(CompositeParser.java:280)
        at org.apache.tika.parser.AutoDetectParser.parse(AutoDetectParser.java:120)
        at xxx.xxx.xxx.xxx.xxxxxAttachmentWithTika(xxxService.java:792)


I browsed the package and couldn't find any POIXMLTypeLoader class. is this a known issue? Could someone please respond to me?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)